Hello,

> 1) Make sure that your site's data/ directory and everything under it
> are owned and writable by the web server.

Yes, the sites data/ directory and everything under it is owned and
writable by the web server (user: apache, group: apache)

> 2) Check if there is a .subversion directory inside data/, and an
> auth/ directory inside that.

There is no .subversion directory inside data/. However, there's
an .ssh directory inside with a "known_hosts" file inside.
Should I create this .subversion directory? Or should it be auto-
generated?


> 3) Check if your Apache configuration sets HOME to your site's data/ 
> directory.
>
> Are you using mod_python, fastcgi, or wsgi?

My Apache configuration sets HOME to my site's data/ directory, and
I'm using mod_python.
Here's my virtual host entry in httpd.conf:

<VirtualHost *:80>
        ServerName <my server's name>
        DocumentRoot "/var/www/milmar.reviews.com/htdocs"

        # Error handlers
        ErrorDocument 500 /errordocs/500.html

        # Serve django pages
        <Location "/">
                PythonPath "['/var/www/milmar.reviews.com/conf'] +
sys.path"
                SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
                SetEnv PYTHON_EGG_CACHE "/var/www/milmar.reviews.com/
tmp/egg_cache"
                SetEnv HOME "/var/www/milmar.reviews.com/data"
                SetHandler mod_python
                PythonHandler django.core.handlers.modpython
                PythonAutoReload Off
                PythonDebug Off

                # Used to run multiple mod_python sites in the same
apache
                PythonInterpreter reviewboard_milmar_reviews_com

        </Location>

        # Serve static media without running it through mod_python
        # (overrides the above)

        <Location "/media">
                SetHandler None
        </Location>

        <Location "/errordocs">
                SetHandler None
        </Location>

        <Directory "/var/www/milmar.reviews.com/htdocs">
                AllowOverride All
        </Directory>

        # Alias static media requests to filesystem
        Alias /media "/var/www/milmar.reviews.com/htdocs/media"
        Alias /errordocs "/var/www/milmar.reviews.com/htdocs/
errordocs"
</VirtualHost>



Also, for the repository path, should I be using svn+ssh://<host> or
https://<host>? Both don't work by the way.
Here's the log I'm getting if I use svn+ssh://<host>:


2010-12-07 19:42:35,095 - DEBUG - SVNTool: Attempting ssh connection
with host: <host>, username: None

2010-12-07 19:42:35,989 - DEBUG - starting thread (client mode):
0xCBFF7910L

2010-12-07 19:42:36,198 - INFO - Connected (version 2.0, client
OpenSSH_4.3)

2010-12-07 19:42:36,392 - DEBUG - kex algos:['diffie-hellman-group-
exchange-sha1', 'diffie-hellman-group14-sha1', 'diffie-hellman-group1-
sha1'] server key:['ssh-rsa', 'ssh-dss'] client encrypt:['aes128-cbc',
'3des-cbc', 'blowfish-cbc', 'cast128-cbc', 'arcfour128', 'arcfour256',
'arcfour', 'aes192-cbc', 'aes256-cbc', 'rijndael-...@lysator.liu.se',
'aes128-ctr', 'aes192-ctr', 'aes256-ctr'] server encrypt:['aes128-
cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc', 'arcfour128',
'arcfour256', 'arcfour', 'aes192-cbc', 'aes256-cbc', 'rijndael-
c...@lysator.liu.se', 'aes128-ctr', 'aes192-ctr', 'aes256-ctr'] client
mac:['hmac-md5', 'hmac-sha1', 'hmac-ripemd160', 'hmac-
ripemd...@openssh.com', 'hmac-sha1-96', 'hmac-md5-96'] server mac:
['hmac-md5', 'hmac-sha1', 'hmac-ripemd160', 'hmac-
ripemd...@openssh.com', 'hmac-sha1-96', 'hmac-md5-96'] client compress:
['none', 'z...@openssh.com'] server compress:['none',
'z...@openssh.com'] client lang:[''] server lang:[''] kex follows?
False

2010-12-07 19:42:36,392 - DEBUG - Ciphers agreed: local=aes128-ctr,
remote=aes128-ctr

2010-12-07 19:42:36,393 - DEBUG - using kex diffie-hellman-group1-
sha1; server key type ssh-rsa; cipher: local aes128-ctr, remote aes128-
ctr; mac: local hmac-sha1, remote hmac-sha1; compression: local none,
remote none

2010-12-07 19:42:36,677 - DEBUG - Switch to new keys ...

2010-12-07 19:42:37,105 - DEBUG - userauth is OK

2010-12-07 19:42:37,358 - INFO - Authentication (password) failed.

2010-12-07 19:42:37,457 - DEBUG - EOF in transport thread



Thanks,

Milmar












>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
> Review Board -http://www.reviewboard.org
> VMware, Inc. -http://www.vmware.com
>
> On Sun, Dec 5, 2010 at 11:03 PM, Milmar <milmarq...@gmail.com> wrote:
> > I'm using ReviewBoard 1.5.1 and PySVN 1.6.2 (Arch x86_64). svn client
> > is version 1.6.4.
> > By the way, access to the repository works if I use a browser (with
> > the certificate).
>
> > On Dec 4, 1:16 pm, Christian Hammond <chip...@chipx86.com> wrote:
> >> What version of Review Board are you using?
>
> >> Also, what version of PySVN?
>
> >> Christian
>
> >> --
> >> Christian Hammond - chip...@chipx86.com
> >> Review Board -http://www.reviewboard.org
> >> VMware, Inc. -http://www.vmware.com
>
> >> On Fri, Dec 3, 2010 at 9:05 PM, Milmar <milmarq...@gmail.com> wrote:
> >> > I'm trying to add a repository (https) that requires a certificate for
> >> > authentication. No username or password is entered. How do I configure
> >> > reviewboard to use my certificate when connecting to the repository?
>
> >> > Currently, I'm getting the error:
>
> >> > "ERROR - SVN: Failed to get repository information for <repo>:
> >> > callback_ssl_client_cert_prompt required"
>
> >> > ...when attempting to connect.
>
> >> > My host is Red Hat Linux and web server is Apache.
>
> >> > Thanks.
>
> >> > --
> >> > Want to help the Review Board project? Donate today 
> >> > athttp://www.reviewboard.org/donate/
> >> > Happy user? Let us know athttp://www.reviewboard.org/users/
> >> > -~----------~----~----~----~------~----~------~--~---
> >> > To unsubscribe from this group, send email to 
> >> > reviewboard+unsubscr...@googlegroups.com
> >> > For more options, visit this group 
> >> > athttp://groups.google.com/group/reviewboard?hl=en
>
> > --
> > Want to help the Review Board project? Donate today 
> > athttp://www.reviewboard.org/donate/
> > Happy user? Let us know athttp://www.reviewboard.org/users/
> > -~----------~----~----~----~------~----~------~--~---
> > To unsubscribe from this group, send email to 
> > reviewboard+unsubscr...@googlegroups.com
> > For more options, visit this group 
> > athttp://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to