Ok, I've traced the problem to the Crypto library:

[Tue Jan 04 16:00:22 2011] [error]   File "C:\\Python27\\lib\\site-
packages\\reviewboard-1.5.1-py2.7.egg\\reviewboard\\diffviewer\
\forms.py", line 9, in <module>
[Tue Jan 04 16:00:22 2011] [error]     from
reviewboard.diffviewer.diffutils import DEFAULT_DIFF_COMPAT_VERSION
[Tue Jan 04 16:00:22 2011] [error]   File "C:\\Python27\\lib\\site-
packages\\reviewboard-1.5.1-py2.7.egg\\reviewboard\\diffviewer\
\diffutils.py", line 30, in <module>
[Tue Jan 04 16:00:22 2011] [error]     from reviewboard.scmtools.core
import PRE_CREATION, HEAD
[Tue Jan 04 16:00:22 2011] [error]   File "C:\\Python27\\lib\\site-
packages\\reviewboard-1.5.1-py2.7.egg\\reviewboard\\scmtools\
\core.py", line 5, in <module>
[Tue Jan 04 16:00:22 2011] [error]     from reviewboard.scmtools
import sshutils
[Tue Jan 04 16:00:22 2011] [error]   File "C:\\Python27\\lib\\site-
packages\\reviewboard-1.5.1-py2.7.egg\\reviewboard\\scmtools\
\sshutils.py", line 5, in <module>
[Tue Jan 04 16:00:22 2011] [error]     import paramiko
[Tue Jan 04 16:00:22 2011] [error]   File "build\\bdist.win32\\egg\
\paramiko\\__init__.py", line 69, in <module>
[Tue Jan 04 16:00:22 2011] [error]   File "build\\bdist.win32\\egg\
\paramiko\\transport.py", line 32, in <module>
[Tue Jan 04 16:00:22 2011] [error]   File "build\\bdist.win32\\egg\
\paramiko\\util.py", line 32, in <module>
[Tue Jan 04 16:00:22 2011] [error]   File "build\\bdist.win32\\egg\
\paramiko\\common.py", line 98, in <module>
[Tue Jan 04 16:00:22 2011] [error]   File "build\\bdist.win32\\egg\
\paramiko\\rng.py", line 23, in <module>
[Tue Jan 04 16:00:22 2011] [error]   File "build\\bdist.win32\\egg\
\Crypto\\Util\\randpool.py", line 30, in <module>
[Tue Jan 04 16:00:22 2011] [error]   File "build\\bdist.win32\\egg\
\Crypto\\Random\\__init__.py", line 28, in <module>
[Tue Jan 04 16:00:22 2011] [error]   File "build\\bdist.win32\\egg\
\Crypto\\Random\\OSRNG\\__init__.py", line 34, in <module>
[Tue Jan 04 16:00:22 2011] [error]   File "build\\bdist.win32\\egg\
\Crypto\\Random\\OSRNG\\nt.py", line 28, in <module>
[Tue Jan 04 16:00:22 2011] [error]   File "build\\bdist.win32\\egg\
\Crypto\\Random\\OSRNG\\winrandom.py", line 7, in <module>
[Tue Jan 04 16:00:22 2011] [error]   File "build\\bdist.win32\\egg\
\Crypto\\Random\\OSRNG\\winrandom.py", line 6, in __bootstrap__
[Tue Jan 04 16:00:22 2011] [error] ImportError: DLL load failed: The
specified module could not be found.

I will try to find out more..


On 12 Dec 2010, 12:50, Dan <birb...@gmail.com> wrote:
> Have you found solution to this problem,
> I have the same problem now.
>
> Could anyone give some hints?
> Any help will be highly appreciated.
>
> On Dec 1, 3:59 am, Travis <dahlke.tra...@gmail.com> wrote:
>
> > Trying to install Reviewboard 1.5.1 on Windows XP SP3 with Apache 2.2
> > and mod_wsgi. Below is my apache error log. In my browser I get stuck
> > on "Review Board is taking a nap". Any idea what's going on? How do I
> > tell which DLL failed?
>
> > [Tue Nov 30 13:40:12 2010] [error] [client 127.0.0.1] mod_wsgi
> > (pid=14184): Exception occurred processing WSGI script 'C:/reviewboard/
> > htdocs/reviewboard.wsgi'.
> > [Tue Nov 30 13:40:12 2010] [error] [client 127.0.0.1] Traceback (most
> > recent call last):
> > [Tue Nov 30 13:40:12 2010] [error] [client 127.0.0.1]   File "C:\
> > \Python27\\lib\\site-packages\\django-1.2.3-py2.7.egg\\django\\core\
> > \handlers\\wsgi.py", line 230, in __call__
> > [Tue Nov 30 13:40:12 2010] [error] [client 127.0.0.1]
> > self.load_middleware()
> > [Tue Nov 30 13:40:12 2010] [error] [client 127.0.0.1]   File "C:\
> > \Python27\\lib\\site-packages\\django-1.2.3-py2.7.egg\\django\\core\
> > \handlers\\base.py", line 42, in load_middleware
> > [Tue Nov 30 13:40:12 2010] [error] [client 127.0.0.1]     raise
> > exceptions.ImproperlyConfigured('Error importing middleware %s: "%s"'
> > % (mw_module, e))
> > [Tue Nov 30 13:40:12 2010] [error] [client 127.0.0.1]
> > ImproperlyConfigured: Error importing middleware
> > reviewboard.admin.middleware: "DLL load failed: The specified module
> > could not be found."

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to