Don't worry Christian, most of the problems I ran into were because I
had the wrong versions of things. Not being a server admin, I just
went and grabbed the latest and greatest of everything. Little did I
realize that versions do indeed matter, especially the version of
python. Very much a noob mistake, I'd have to say. The guy who would
be installing this on our server isn't likely to make those same
mistakes and would probably laugh and shake his head at me if he knew.
It's all good though because I learned something out of all this.

In regards to how I got that far with Patch missing, it never really
was missing. It was installed into Program Files/gnuwin32 when I was
installing everything else and the Path was updated. Once I got the
server running, I tried to use post-review and it complained about not
having the GNU diff. GNU diff wanted to be installed into Program
Files/gnuwin32 as well and I didn't want it overwriting anything Patch
needed so I moved Patch to Program Files/Patch (and added the new
location to the Path) and let GNU diff install into Program Files/
gnuwin32 (already in the Path). This was all done while the web server
was still running so I imagine the Patch check was already done, which
is probably why RB never complained. It did complain once I restarted
Apache because Apache wouldn't have known about the changes to the
Path. I'm pretty sure I had done refreshes on the RB site after I had
moved Patch but it's possible I was just refreshing from my browser's
cache. And yes, I am updating the System Path in the environment
variables.

Anyway, I did a system reboot this morning and that seemed to do the
trick... sort of. The Review Board page loads again so it looks like
it found Patch. But when I clicked on a review request, I got a 500
Server Error. The Apache error log gives me this:

DLL load failed: The specified procedure could not be found.
Traceback (most recent call last):
  File "c:\python25\lib\site-packages\django-1.2.4-py2.5.egg\django
\core\handlers\base.py", line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\accounts\decorators.py", line 27, in _check
    return view_func(*args, **kwargs)
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\accounts\decorators.py", line 46, in _check_valid_prefs
    return view_func(request, *args, **kwargs)
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\reviews\views.py", line 251, in review_detail
    'PRE_CREATION': PRE_CREATION,
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\reviews\views.py", line 91, in
make_review_request_context
    upload_diff_form = UploadDiffForm(review_request)
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\reviews\forms.py", line 229, in __init__
    data, *args, **kwargs)
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\diffviewer\forms.py", line 44, in __init__
    if self.repository.get_scmtool().get_diffs_use_absolute_paths():
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\scmtools\models.py", line 52, in get_scmtool
    return cls(self)
  File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
\reviewboard\scmtools\svn.py", line 77, in __init__
    import pysvn
  File "C:\Python25\lib\site-packages\pysvn\__init__.py", line 99, in
<module>
    import _pysvn_2_5
ImportError: DLL load failed: The specified procedure could not be
found.
ERROR:root:Exception thrown for user leppke at http://localhost/reviews/r/1/


I assumed this was a separate problem from what I was experiencing
before so I went to try post-review again and see if I could at least
upload a diff to look at when I got this new problem fixed. Post-
review encountered an error uploading the diff so it only created the
request but didn't attach the diff. I'm not sure where to look to find
out more about that error. No idea if it's related to the 500 Server
Errors but since neither started happening until after I rebooted this
morning, I'm going to assume it is.

On Jan 7, 4:17 am, Ian Battersby <ian.batter...@gmail.com> wrote:
> Hi Andrew,
>
> I can relate somewhat to the issue with version dependencies on
> Windows but do have it all working here running several instances with
> SVN and TFS (via SVNBridge) source repositories, and using AD
> integration for authentication.
>
> I'm not sure about the error you had above but our basic install
> includes:
>
> MySQL 6.1
> Apache HTTP Server 2.2.16
> GnuWin32: Patch-2.5.9.7
> Git Version 1.7.2.3-preview20100911 (mainly for it's diff generator)
> Python 2.6 MySQL-python-1.2.3c1
> Python 2.6 PIL-1.1.7
> Python 2.6 pycrypto-2.1.0
> Python 2.6 PySVN 1.7.4-1321
> Python 2.6 python-ldap-2.3.11
> Python 2.6 setuptools-0.6c11
> Python 2.6.6
> Silk Subversion 1.6.12 (x64)
> Memcached
> WSGI Apache module
> SSPI Authentication Apache module
>
> Christian: Shout me if  you want any beta testing of the installer
> module :)
>
> Regards, Ian.
>
> On Jan 6, 8:34 pm, Andrew Leppke <alep...@hotmail.com> wrote:
>
> > I'm trying to determine if Review Board is right for our company and
> > so far, I've had nothing but problems. I ran into numerous
> > installation problems because I couldn't figure out which versions of
> > what I needed to use. But I solved all that. At least, I think I've
> > solved all that since the server is up and running.
>
> > My latest problem occurred when I attempted to create my first review.
> > I used post-review to create and upload a diff. Everything looked like
> > it had worked from the command line as I got the following output:
>
> > C:\workspaces\test\src\test>post-review -o
> > ==> Review Board Login Required
> > Enter username and password for Review Board athttp://localhost/reviews/
> > Username: leppke
> > Password:
> > Review request #2 posted.
>
> >http://localhost/reviews/r/2
>
> > As expected, it opened a browser to the review and sure enough, it was
> > there. I click on the View Diff tab and am treated to this wonderful
> > stacktrace:
>
> > [Error 2] The system cannot find the file specified
>
> > Traceback (most recent call last):
> >   File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
> > \reviewboard\diffviewer\views.py", line 153, in view_diff
> >     interdiffset, highlighting, True)
> >   File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
> > \reviewboard\diffviewer\diffutils.py", line 1063, in get_diff_files
> >     large_data=True)
> >   File "c:\python25\lib\site-packages\Djblets-0.6.6-py2.5.egg\djblets
> > \util\misc.py", line 166, in cache_memoize
> >     data = lookup_callable()
> >   File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
> > \reviewboard\diffviewer\diffutils.py", line 1062, in <lambda>
> >     enable_syntax_highlighting)),
> >   File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
> > \reviewboard\diffviewer\diffutils.py", line 549, in get_chunks
> >     new = get_patched_file(old, filediff)
> >   File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
> > \reviewboard\diffviewer\diffutils.py", line 374, in get_patched_file
> >     return patch(filediff.diff, buffer, filediff.dest_file)
> >   File "c:\python25\lib\site-packages\ReviewBoard-1.5.1-py2.5.egg
> > \reviewboard\diffviewer\diffutils.py", line 222, in patch
> >     stderr=subprocess.STDOUT)
> >   File "C:\Python25\lib\subprocess.py", line 594, in __init__
> >     errread, errwrite)
> >   File "C:\Python25\lib\subprocess.py", line 822, in _execute_child
> >     startupinfo)
> > WindowsError: [Error 2] The system cannot find the file specified
>
> > From what I can tell, it threw a FileNotFound exception when trying to
> > create the diff but it doesn't say which file it was trying to find.
> > Anyone have any suggestions?

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to