Hi Praveen,

The "root:" part you're seeing is just from the logging.

To be sure, are you able to ping that hostname from the server? What happens
if you try to ssh to it directly? If that works, what happens if you try
with rbssh? That might help narrow it down, because at the point where it's
failing it appears to be network or configuration related.

What version of what distro is this?

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Fri, Jan 28, 2011 at 4:43 AM, praveen kumar <kodaliprav...@gmail.com>wrote:

> Hi Christian,
>
> I have made the changes you suggested.
> Also changed the below:
> client.connect(hostname, username)
>
> After these changes, i am getting the error:
>
> 2011-01-28 06:21:20,929 - DEBUG - start Popen
> 2011-01-28 06:21:22,971 - DEBUG -
> 2011-01-28 06:21:22,978 - DEBUG - CVSROOT/modules
> 2011-01-28 06:21:22,978 - DEBUG - HEAD
> 2011-01-28 06:21:22,979 - DEBUG - /usr/lib/python2.4/site-packages/
> pycrypto-2.3-py2.4-linux-x86_64.egg/Crypto/Util/randpool.py:40:
> RandomPool_DeprecationWarning: This application uses RandomPool, which
> is BROKEN in older releases.  See http://www.pycrypto.org/randpool-broken
> Traceback (most recent call last):
>  File "/usr/bin/rbssh", line 7, in ?
>    sys.exit(
>  File "/usr/lib/python2.4/site-packages/ReviewBoard-1.5.2-py2.4.egg/
> reviewboard/cmdline/rbssh.py", line 212, in main
>    client.connect(hostname, username)
>  File "/usr/lib/python2.4/site-packages/paramiko-1.7.6-py2.4.egg/
> paramiko/client.py", line 278, in connect
> socket.gaierror: (-8, 'Servname not supported for ai_socktype')
> cvs [checkout aborted]: end of file from server (consult above
> messages if any)
>
> 2011-01-28 06:21:22,979 - DEBUG - end Popen
> 2011-01-28 06:21:22,979 - DEBUG - .cvspass not found
>
> i looked up google. ssh for port 22 was already present.
> Then i tried adding rbssh, paramiko and openssh to the /etc/services
> file.
> Still same issue. What service/program is RB/paramiko using?
>
> these are the values passed to the connect. I do NOT think they are
> updated correctly. Of-course i could be wrong.
> hostname - root:cvs-bn
> username - root:<my id>
> command - root:['cvs server']
>
> when i tried to hardcode them as below, they did not take the values i
> gave. They retained their original values
>    213     hostname = 'cvs-bn'
>    214     username = '<my id>'
>    215     logging.error(hostname)
>    216     logging.error(username)
>
> ERROR:root:cvs-bn
> ERROR:root:<my id>
>
> I ran out of what else to try here. Help Please........
>
> Thanks
> Praveen
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to