FYI, I've got to the bottom of this with the help of the debug
output. It seems that whatever is calling rbssh is not picking up the
Username field and just passing the server component of the Path field.
As a result, the rbssh script is calculating the username from the user
running the script (aka apache), and of course the remote server is
denying access to the incoming ssh session for apache. 

By specifying
the path as ":ext:grouplb...@svn.group.game.net:/app01/repository/cvs"
was also failing, as although rbssh was now getting the correct
username, it seems that something else was going awry in checking the
validity of the CVS repository as it errored with "Unable to
authenticate against this repository using one of the supported
authentication types." 

The only way I got this to work was to specify
the username both in the path and in the Username fields. I also had to
add "svn.group.game.net:/app01/repository/cvs/" in the Mirror field to
allow post-review to find the repository when posting diffs. 

Hope this
helps anyone else with the same issue. 

Regards, 

Rob 

On Fri, 4 Mar
2011 12:30:25 -0800, Christian Hammond wrote: 

> Hi Rob,
> 
> What
OS/distro is in this on?
> 
> Try finding rbssh.py in your reviewboard
software installation dir (reviewboard/cmdline/rbssh.py). Back up this
file. We're going to make some modifications.
> 
> Near the top there
will be:
> 
> DEBUG = os.getenv('DEBUG_RBSSH')
> 
> Change this to:
DEBUG = True
> 
> Further down, you'll find a line:
logging.basicConfig(...). Should be around line 237.
> 
> Change the
"filename='...'" to point to a writeable path (/path/to/your/site/logs,
or /tmp, or something).
> 
> Then repeat your Add Repository, and check
for that log file. Assuming it was created, send it on to me privately
and I'll see if anything stands out.
> 
> Christian
> 
> -- 
> Christian
Hammond - chip...@chipx86.com [5]
> Review Board -
http://www.reviewboard.org [6]
> VMware, Inc. - http://www.vmware.com
[7]
> 
> On Fri, Mar 4, 2011 at 8:33 AM, RobC wrote:
> 
>> I've just
installed a new reviewboard server with 1.6 beta1 and am
>> hitting the
same issue. Anyone got any news on this ?
>> 
>> Thanks,
>> Rob
>> 
>>
--
>> Want to help the Review Board project? Donate today at
http://www.reviewboard.org/donate/ [1]
>> Happy user? Let us know at
http://www.reviewboard.org/users/ [2]
>>
-~----------~----~----~----~------~----~------~--~---
>> To unsubscribe
from this group, send email to reviewboard+unsubscr...@googlegroups.com
[3]
>> For more options, visit this group at
http://groups.google.com/group/reviewboard?hl=en [4]
> 
> -- 
> Want to
help the Review Board project? Donate today at
http://www.reviewboard.org/donate/ [9]
> Happy user? Let us know at
http://www.reviewboard.org/users/ [10]
>
-~----------~----~----~----~------~----~------~--~---
> To unsubscribe
from this group, send email to
reviewboard+unsubscr...@googlegroups.com
> For more options, visit this
group at http://groups.google.com/group/reviewboard?hl=en [11]



Links:
------
[1] http://www.reviewboard.org/donate/
[2]
http://www.reviewboard.org/users/
[3]
mailto:reviewboard%2bunsubscr...@googlegroups.com
[4]
http://groups.google.com/group/reviewboard?hl=en
[5]
mailto:chip...@chipx86.com
[6] http://www.reviewboard.org
[7]
http://www.vmware.com
[8] mailto:r...@jive-videos.net
[9]
http://www.reviewboard.org/donate/
[10]
http://www.reviewboard.org/users/
[11]
http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to