Hi Tom,

Most likely, it's the short SHA1. If you generate the diff with
--full-index, you should be able to get a full SHA1, which may fix your
problem.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Wed, Mar 16, 2011 at 9:27 AM, Tom De Vylder <t...@penumbra.be> wrote:

> Hi everyone,
>
> I've been struggling trying to get post-review to post a patch to the web
> interface.
> Each time I try to submit a patch post-review complains that it can't find
> a file
>
> The file specified with --diff-filename is uploaded each time.
> So my guess is that it can't find the file that needs to be patched but it
> really is there in the root of the repository.
>
> Is there a way to debug this any further? I'd like to find out what's
> blocking this.
>
> Debug info:
>
> > $ post-review --guess-summary --guess-description --target-groups=$group
> --publish --server=http://reviewboard --username=$user --password=$pass
> --diff-filename=/tmp/git-diff.patch --debug
> > >>> RBTools 0.3.2
> > >>> svn info
> > >>> git rev-parse --git-dir
> > >>> git symbolic-ref -q HEAD
> > >>> git config --get branch.master.merge
> > >>> git config --get branch.master.remote
> > >>> git config remote.origin.url
> > >>> repository info: Path: ssh+git://git@repository, Base path: ,
> Supports changesets: False
> > >>> HTTP GETting api/
> > >>> HTTP GETting http://reviewboard/api/info/
> > >>> Using the new web API
> > >>> Attempting to create review request on ssh+git://git@repository for
> None
> > >>> HTTP POSTing to http://reviewboard/api/review-requests/:
> {'repository': 'ssh+git://git@repository'}
> > >>> Review request created
> > >>> Attempting to set field 'target_groups' to 'puppet' for review
> request '31'
> > >>> HTTP PUTting to http://reviewboard/api/review-requests/31/draft/:
> {'target_groups': 'puppet'}
> > >>> Uploading diff, size: 1583
> > >>> HTTP POSTing to http://reviewboard/api/review-requests/31/diffs/: {}
> > >>> Got API Error 207 (HTTP code 400): The file was not found in the
> repository
> > >>> Error data: {u'stat': u'fail', u'file': u'test-review.pp', u'err':
> {u'msg': u'The file was not found in the repository', u'code': 207},
> u'revision': u'dd58b9e'}
> >
> > Error uploading diff
> >
> > Your review request still exists, but the diff is not attached.
>
>
> K.r.,
>
> TomDV
>
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to