I tried a few more permutations of the repository setup, all to no
avail.

1. Snapshot view on the RB server
Hosting Service : Custom
repository Type : Clear Case
Path : D:\snapshots\RC2009_int_reviewboard_ss <---- This is the path
to the snapshot view

2. Dynamic view mounted at the root of a drive (
Hosting Service : Custom
repository Type : Clear Case
Path : Y:\ <---- The docs seemed to suggest that the path would just
be the drive

One thing to note is that trying to upload a diff doesn't impair the
rest of the application - while the upload spinner is spinning, I can
open up a new tab and interact with the application. The most
difficult part is that there is no output produced anywhere when this
happens (e.g. even if I enable DEBUG=true in conf/settings_local.py).

Can anyone who has used RB w/ ClearCase provide any tips on a working
setup ?




On Mar 23, 4:06 pm, akochnev <akoch...@gmail.com> wrote:
> This seems to work as expected with a Mercurial repository. Thus, it
> would appear that the issue here might be coming from the ClearCase
> support on Windows.
>
> Following a note that only dynamic views are supported with ClearCase,
> I've set up a dynamic view on my M: drive (M:
> \RC2009_int_reviewboard) . Then in the ClearCase repository
> information, I've filled in the follwoing :
>
> Hosting Service : Custom
> repository Type : Clear Case
> Path : M:\RC2009_int_reviewboard
>
> This is the set up that makes uploading diffs hang. Any tips on how to
> deal with this (or just to debug to see where the issue is) would be
> greatly appreciated.
>
> On Mar 23, 1:20 pm, akochnev <akoch...@gmail.com> wrote:
>
>
>
>
>
>
>
> > I've followed the instructions to install reviewboard 1.5.4  with
> > python 2.6, apache 2.2, mod_python , sqlite, memcached, patch, and
> > mercurial 1.8.1 support on windows. The box itself has ClearCase
> > installed so I'm trying to test out the Clear Case support as well
> > (I've set up a CC repository in RB).
>
> > When I try to create a new review request using post-review, the
> > review request is created; however, when post-review tries to upload
> > the diff file ReviewBoard hangs and the process never completes.
>
> > When I try to create a new review request by uploading a diff through
> > the web app, review board hangs and the request never completes (the
> > spinner just keeps spinning)
>
> > I tested uploading an image and that works fine - a directory
> > structure gets created under media/uploaded/images, which seems to
> > point out that the permissions on the upload directories are OK.
>
> > I've looked both in the apache logs and in the logs folder in the rb
> > site that I've created but i don't see any error messages. I've
> > enabled Debug=True in conf/settings_local.py, but that didn't help
> > either. I've tried running apache both as a system user and myself
> > (the user used in the install process) to make sure that it's not some
> > other permissions issue, but no luck there either.
>
> > It feels like I'm missing something fundamental here - does anyone
> > have any tips of where I could look to figure out why this is not
> > working for me ?

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to