Hi,

Looks like a new python-dateutil was just released today that only works
with Python 3, and it's being fetched. That's not good. We'll have to get
out an update to be more specific about the version needed.

Try getting rid of the old version (rm -rf
/usr/lib/python2.4/site-packages/python_dateutil-2.0-py2.4.egg/)

Then:

    easy_install -U python_dateutil==1.5

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Thu, Mar 24, 2011 at 5:24 PM, storms <v...@sendmail.com> wrote:

> Just installed 1.5.4 with Apache + mod_python
> started apache, and try to access web and got the following and got
> the following error via browser:
>
> 500 - Internal Server Error | Review Board - Mozilla Firefox
> Something broke! (Error 500)
>
> It appears something broke when you tried to go to here. This is
> either a bug in Review Board or a server configuration error. Please
> report this to your administrator.
>
> here's the log file:
> [Thu Mar 24 17:10:53 2011] [notice] suEXEC mechanism enabled
> (wrapper: /usr/sbin/suexec)
> [Thu Mar 24 17:10:53 2011] [notice] Digest: generating secret for
> digest authentication ...
> [Thu Mar 24 17:10:53 2011] [notice] Digest: done
> [Thu Mar 24 17:10:53 2011] [notice] mod_python: Creating 4 session
> mutexes based on 256 max processes and 0 max threads.
> [Thu Mar 24 17:10:53 2011] [notice] Apache/2.2.3 (Red Hat) configured
> -- resuming normal operations
> /usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/db/
> __init__.py:19: DeprecationWarning: settings.DATABASE_* is deprecated;
> use settings.DATABASES instead.
>  DeprecationWarning
> /usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/db/
> __init__.py:60: DeprecationWarning: Short names for ENGINE in database
> configurations are deprecated. Prepend default.ENGINE with
> 'django.db.backends.'
>  DeprecationWarning
> /usr/lib/python2.4/site-packages/pycrypto-2.3-py2.4-linux-i686.egg/
> Crypto/Util/randpool.py:40: RandomPool_DeprecationWarning: This
> application uses RandomPool, which is BROKEN in older releases.  See
> http://www.pycrypto.org/randpool-broken
> /usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/core/
> context_processors.py:27: DeprecationWarning: The context processor at
> `django.core.context_processors.auth` is deprecated; use the path
> `django.contrib.auth.context_processors.auth` instead.
>  DeprecationWarning
> /usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/
> loaders/filesystem.py:58: DeprecationWarning:
> 'django.template.loaders.filesystem.load_template_source' is
> deprecated; use 'django.template.loaders.filesystem.Loader' instead.
>  DeprecationWarning
> ERROR:root:Exception thrown for user AnonymousUser at
>
> http://vmreviews.qa-lab.sendmail.com/reviews/account/login/?next_page=/reviews/dashboard/
>
> invalid syntax (parser.py, line 23)
> Traceback (most recent call last):
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> core/handlers/base.py", line 111, in get_response
>    response = callback(request, *callback_args, **callback_kwargs)
>  File "/usr/lib/python2.4/site-packages/Djblets-0.6.7-py2.4.egg/
> djblets/auth/views.py", line 80, in login
>    return render_to_response(template_name, context)
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> shortcuts/__init__.py", line 20, in render_to_response
>    return HttpResponse(loader.render_to_string(*args, **kwargs),
> **httpresponse_kwargs)
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> template/loader.py", line 183, in render_to_string
>    return t.render(Context(dictionary))
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> template/base.py", line 123, in render
>    return self._render(context)
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> template/base.py", line 117, in _render
>    return self.nodelist.render(context)
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> template/base.py", line 744, in render
>    bits.append(self.render_node(node, context))
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> template/base.py", line 757, in render_node
>    return node.render(context)
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> template/loader_tags.py", line 127, in render
>    return compiled_parent._render(context)
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> template/base.py", line 117, in _render
>    return self.nodelist.render(context)
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> template/base.py", line 744, in render
>    bits.append(self.render_node(node, context))
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> template/base.py", line 757, in render_node
>    return node.render(context)
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> template/loader_tags.py", line 64, in render
>    result = block.nodelist.render(context)
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> template/base.py", line 744, in render
>    bits.append(self.render_node(node, context))
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> template/base.py", line 757, in render_node
>    return node.render(context)
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> template/defaulttags.py", line 313, in render
> ...
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> core/urlresolvers.py", line 197, in _populate
>    for pattern in reversed(self.url_patterns):
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> core/urlresolvers.py", line 279, in _get_url_patterns
>    patterns = getattr(self.urlconf_module, "urlpatterns",
> self.urlconf_module)
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> core/urlresolvers.py", line 274, in _get_urlconf_module
>    self._urlconf_module = import_module(self.urlconf_name)
>  File "/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/
> utils/importlib.py", line 35, in import_module
>    __import__(name)
>  File "/usr/lib/python2.4/site-packages/ReviewBoard-1.5.4-py2.4.egg/
> reviewboard/webapi/urls.py", line 5, in ?
>    from reviewboard.webapi.resources import root_resource
>  File "/usr/lib/python2.4/site-packages/ReviewBoard-1.5.4-py2.4.egg/
> reviewboard/webapi/resources.py", line 5, in ?
>    import dateutil.parser
>  File "/usr/lib/python2.4/site-packages/python_dateutil-2.0-py2.4.egg/
> dateutil/parser.py", line 23
>     from . import relativedelta
>          ^
>  SyntaxError: invalid syntax
>
> Please help...
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to