Hi there,

We had a perfectly good Windows install of Review Board V1.5.2 but
curiosity got the better of me and I attempted to upgrade to V1.6
Beta1. Everything seemed to work great (btw collapsible reviews are
awesome) until we tried to post reviews using post-review (RBTools
V0.3.2) as Perforce is our SCM tool. Command prompt spat out some html
that indicated that the requested page did not exist. When invoking
post-review with the -d option and DEBUG = True in settings_local.py I
get the following output:

C:\Users\xxxxxxx>post-review -d 18709
>>> RBTools 0.3.2
>>> Home = C:\Users\xxxxxxx\AppData\Roaming
>>> p4 info
>>> repository info: Path: scm.xxxxxxx.com:1666, Base path: None, Supports 
>>> changesets: True
>>> p4 counters
>>> HTTP GETting api/
>>> HTTP GETting http://nzpc2261.xxxxxxx.com/reviews/api/info/
>>> Using the new web API
>>> Generating diff for changenum 18709
>>> p4 describe -s 18709
>>> Processing edit of //FPH/OSA/xxxx/Firmware/MAIN/Source/aOSK_OSKernel.c
>>> Writing "//FPH/OSA/xxxx/Firmware/MAIN/Source/aOSK_OSKernel.c#27" to 
>>> "c:\users\xxxxxxx\appdata\local\temp\tmpkqwtrl"
>>> p4 print -o c:\users\xxxxxxx\appdata\local\temp\tmpkqwtrl -q 
>>> //FPH/OSA/xxxx/Firmware/MAIN/Source/aOSK_OSKernel.c#27
>>> diff -urNp c:\users\xxxxxxx\appdata\local\temp\tmpkqwtrl 
>>> C:\Work\FPH\OSA\xxxx\Firmware\MAIN\Source\aOSK_OSKernel.c
Warning: //FPH/OSA/xxxx/Firmware/MAIN/Source/aOSK_OSKernel.c in your
changeset is unmodified
>>> Using changenums on Review Board 1.5.2. Falling back to the deprecated 1.0 
>>> API
==> Review Board Login Required
Enter username and password for Review Board at 
http://nzpc2261.xxxxxxx.com/reviews/
>>> Looking for 'nzpc2261.xxxxxxx.com /reviews/' cookie in 
>>> C:\Users\xxxxxxx\AppData\Roaming\.post-review-cookies.txt
>>> Loaded valid cookie -- no login required
>>> Attempting to create review request on nz-scm1.xxxxxxx.com:1666 for 18709
>>> HTTP POSTing to 
>>> http://nzpc2261.xxxxxxx.com/reviews/api/json/reviewrequests/new/: 
>>> {'changenum': '18709', 'repository_path': 'scm.xxxxxxx.com:1666'}
>>> Got HTTP error: 404:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://
www.w3.org/TR/html4/loose.dtd">
<html lang="en">
<head>
  <meta http-equiv="content-type" content="text/html; charset=utf-8">
  <title>Page not found at /reviews/api/json/reviewrequests/new/</
title>
  <meta name="robots" content="NONE,NOARCHIVE">
  <style type="text/css">
    html * { padding:0; margin:0; }
    body * { padding:10px 20px; }
    body * * { padding:0; }
    body { font:small sans-serif; background:#eee; }
    body>div { border-bottom:1px solid #ddd; }
    h1 { font-weight:normal; margin-bottom:.4em; }
    h1 span { font-size:60%; color:#666; font-weight:normal; }
    table { border:none; border-collapse: collapse; width:100%; }
    td, th { vertical-align:top; padding:2px 3px; }
    th { width:12em; text-align:right; color:#666; padding-right:.
5em; }
    #info { background:#f6f6f6; }
    #info ol { margin: 0.5em 4em; }
    #info ol li { font-family: monospace; }
    #summary { background: #ffc; }
    #explanation { background:#eee; border-bottom: 0px none; }
  </style>
</head>
<body>
  <div id="summary">
    <h1>Page not found <span>(404)</span></h1>
    <table class="meta">
      <tr>
        <th>Request Method:</th>
        <td>POST</td>
      </tr>
      <tr>
        <th>Request URL:</th>
      <td>http://nzpc2261.xxxxxxx.com/reviews/api/json/reviewrequests/
new/</td>
      </tr>
    </table>
  </div>
  <div id="info">

      <p>
      Using the URLconf defined in <code>djblets.util.rooturl</code>,
Django tried these URL patterns, in this order:
      </p>
      <ol>
          <li>^reviews/   ^admin/</li>
          <li>^reviews/   ^media/(?P&lt;path&gt;.*)$</li>
          <li>^reviews/   ^account/</li>
          <li>^reviews/   ^reports/</li>
          <li>^reviews/   ^s/(?P&lt;local_site_name&gt;[A-Za-z0-9\-_.]
+)/</li>
          <li>^reviews/   ^$</li>
          <li>^reviews/   ^api/   ^$</li>
          <li>^reviews/   ^api/   ^repositories/</li>
          <li>^reviews/   ^api/   ^groups/</li>
          <li>^reviews/   ^api/   ^review-requests/</li>
          <li>^reviews/   ^api/   ^info/</li>
          <li>^reviews/   ^api/   ^session/</li>
          <li>^reviews/   ^api/   ^users/</li>
          <li>^reviews/   ^api/   ^$</li>
          <li>^reviews/   ^r/</li>
          <li>^reviews/   ^dashboard/$</li>
          <li>^reviews/   ^users/$</li>
          <li>^reviews/   ^users/(?P&lt;username&gt;[A-Za-z0-9@_\-\.]
+)/$</li>
          <li>^reviews/   ^users/(?P&lt;username&gt;[A-Za-z0-9@_\-\.]
+)/infobox/$</li>
          <li>^reviews/   ^groups/$</li>
          <li>^reviews/   ^groups/(?P&lt;name&gt;[A-Za-z0-9_-]+)/$</
li>
          <li>^reviews/   ^groups/(?P&lt;name&gt;[A-Za-z0-9_-]+)/
members/$</li>
          <li>^reviews/   ^feeds/rss/(?P&lt;url&gt;.*)/$</li>
          <li>^reviews/   ^feeds/atom/(?P&lt;url&gt;.*)/$</li>
          <li>^reviews/   ^account/logout/$</li>
      </ol>
      <p>The current URL, <code>reviews/api/json/reviewrequests/new/</
code>, didn't match any of these.</p>
  </div>

  <div id="explanation">
    <p>
      You're seeing this error because you have <code>DEBUG = True</
code> in your Django settings file. Change that to <code>False</code>,
and Django will display a standard 404 page.
    </p>
  </div>
</body>
</html>

Error creating review request: HTTP 404


It looks like everything is fine until it tries to do an HTML POST to
"/reviews/api/json/reviewrequests/new/". Does anyone have any idea
what might be going wrong or am I going to have to revert back to
V1.5.2? I hope not, the collapsible reviews are handy.

Thanks in advance,
Jonathan.

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to