Glad it works!

We actually get setup/troubleshooting questions usually a couple times
a week, so yes, it does :)

Christian


On Thursday, April 21, 2011, virtualAdmin <mrcul...@gmail.com> wrote:
> <Forehead slap>
>
> Figured it out: SELinux was blocking the MySQLdb 1.2.3, but not the
> 1.2.1 version, so RB was trying to fall back on 1.2.1, which was a no-
> go.
>
> Turned off selinux (temporarily) and i get a RB login!
>
> Thanks for your help Christopher!
>
> P.S., when a total noob like me comes in and starts asking these
> questions, does that make you feel like your FOSS project is reaching
> maturity? :D
>
> On Apr 20, 6:30 pm, Christian Hammond <chip...@chipx86.com> wrote:
>> Hi,
>>
>> I believe MySQLdb has to do some compilation. So copying the data won't be
>> enough.
>>
>> I'd blow it all away again, and then do:
>>
>> sudo easy_install -U MySQL-python
>>
>> You'll need the Python development headers.
>>
>> Christian
>>
>> --
>> Christian Hammond - chip...@chipx86.com
>> Review Board -http://www.reviewboard.org
>> VMware, Inc. -http://www.vmware.com
>>
>>
>>
>>
>>
>>
>>
>> On Wed, Apr 20, 2011 at 3:05 PM, virtualAdmin <mrcul...@gmail.com> wrote:
>> > Thanks for the quick reply, Christian.
>>
>> > We're using mod_python.  The apache error logs were paydirt; it looks
>> > like some component is still looking at MySQLdb 1.2.1 instead of
>> > 1.2.3.  I blew away the mysqldb folder at /usr/lib/python2.4/site-
>> > packages and replaced it with the MySQLdb folder from the MySQL-python
>> > tar.gz, but of course this didn't work.  Ran easy_install on the
>> > tar.gz, but as before I got some warnings and was told that it was
>> > already installed.  So nothing.
>>
>> > Any advice on this one..?
>>
>> > On Apr 20, 4:21 pm, Christian Hammond <chip...@chipx86.com> wrote:
>> > > Hi,
>>
>> > > Unit tests won't really run with 'rb-site manage', so that's to be
>> > expected.
>>
>> > > If you're not seeing anything from DEBUG = True, then it sounds like you
>> > may
>> > > have more of an Apache-side problem. Have you looked in the Apache error
>> > > logs?
>>
>> > > is this using mod_wsgi, mod_python, or fastcgi?
>>
>> > > Christian
>>
>> > > --
>> > > Christian Hammond - chip...@chipx86.com
>> > > Review Board -http://www.reviewboard.org
>> > > VMware, Inc. -http://www.vmware.com
>>
>> > > On Wed, Apr 20, 2011 at 12:21 PM, virtualAdmin <mrcul...@gmail.com>
>> > wrote:
>> > > > I installed reviewboard 1.5.5, seemingly successfully, on a fresh
>> > > > CentOS 5.6 install through VirtualBox.  I eventually got all the
>> > > > dependencies resolved, including memcached.
>>
>> > > > So now I think it's going to work, right?  When I open a browser and
>> > > > go to localhost/<my site>, I get the "Review Board is taking a nap"
>> > > > 500 page, and nothing I do will change that, or get me debug output of
>> > > > some kind.  I set "DEBUG = True" in <my site>/conf/settings_local.py,
>> > > > but have been unable to find any sort of output from this.
>>
>> > > > The only thing I have gotten good output from is rb-site manage test,
>> > > > which gives this:
>>
>> > > > [test@localhost conf]$ rb-site manage /var/www/<my site>/ test
>> > > > /usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/db/
>> > > > __init__.py:19: DeprecationWarning: settings.DATABASE_* is deprecated;
>> > > > use settings.DATABASES instead.
>> > > >  DeprecationWarning
>> > > > /usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/db/
>> > > > __init__.py:60: DeprecationWarning: Short names for ENGINE in database
>> > > > configurations are deprecated. Prepend default.ENGINE with
>> > > > 'django.db.backends.'
>> > > >  DeprecationWarning
>> > > > /usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/core/
>> > > > management/commands/test.py:32: DeprecationWarning: Function-based
>> > > > test runners are deprecated. Test runners should be classes with a
>> > > > run_tests() method.
>> > > >  DeprecationWarning
>> > > > Creating test database for alias 'default'...
>> > > > Got an error creating the test database: (1007, "Can't create database
>> > > > 'test_reviewboard'; database exists")
>> > > > Type 'yes' if you would like to try deleting the test database
>> > > > 'test_reviewboard', or 'no' to cancel: yes
>> > > > Destroying old test database 'default'...
>> > > > Creating tables ...
>> > > > Installing custom SQL ...
>> > > > Installing indexes ...
>> > > > No fixtures found.
>> > > > Traceback (most recent call last):
>> > > >  File "/usr/bin/rb-site", line 7, in ?
>> > > >

-- 
-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to