What is the minimum supported version of Python for RBtools? The Windows specific docs mention 2.5 http://www.reviewboard.org/docs/manual/dev/admin/installation/windows/

I just stumbled across some code that fails in 2.4 in the ClearCase code (and hacked it to work with 2.4):


               """
               # fails with python 2.4
               self.viewtype = 'dynamic' if 'dynamic' in properties else \
                               'snapshot'
               """
               if 'dynamic' in properties:
                   self.viewtype = 'dynamic'
               else:
                   self.viewtype = 'snapshot'

I'm wondering if I should consider an upgrade of my postreview clients.

Chris

--
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to