Hi,

This looks like you're possibly running with an older version of Djblets.
You might want to run sudo setup.py develop inside the reviewboard tree to
get all the new dependencies.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Mon, May 9, 2011 at 11:04 PM, infraction <nfr...@gmail.com> wrote:

> I've worked through a few issues in an update from 1.0->1.5 but now
> encountering the following and stuck.
>
> Background is that the machine does have a git branch of reviewboard,
> and we were doing local changes.
>
> However, I would like to switch to the release 1.5.5 branch.
> I installed reviewboard through easy install, and have run the
> rb-site upgrade.  easy install and rb-site ran with very few issues,
> update
> of the data folder ownership from root to my git user was the main
> issue.
>
> Here is the error followed by the apache config:
>
> === apache log
>
> [notice] mod_python: Creating 4 session mutexes based on 256 max
> processes and 0 max threads.
> [notice] Apache/2.2.3 (Red Hat) configured -- resuming normal
> operations
>  [error] [client [Mon May 09 22:46:44 2011]] PythonHandler
> myvirtualdjango: Traceback (most recent call last):
>  [error] [client] PythonHandler myvirtualdjango:   File "/usr/lib/
> python2.4/site-packages/mod_python/apache.py", line 299, in
> HandlerDispatch\n    result = object(req)
>  [error] [client] PythonHandler myvirtualdjango:   File "/usr/lib/
> python2.4/site-packages/Django-1.3-py2.4.egg/django/core/handlers/
> modpython.py", line 213, in handler\n    return ModPythonHandler()
> (req)
>  [error] [client] PythonHandler myvirtualdjango:   File "/usr/lib/
> python2.4/site-packages/Django-1.3-py2.4.egg/django/core/handlers/
> modpython.py", line 174, in __call__\n    self.load_middleware()
>  [error] [client] PythonHandler myvirtualdjango:   File "/usr/lib/
> python2.4/site-packages/Django-1.3-py2.4.egg/django/core/handlers/
> base.py", line 45, in load_middleware\n    mod =
> import_module(mw_module)
>  [error] [client] PythonHandler myvirtualdjango:   File "/usr/lib/
> python2.4/site-packages/Django-1.3-py2.4.egg/django/utils/
> importlib.py", line 35, in import_module\n    __import__(name)
>  [error] [client] PythonHandler myvirtualdjango:   File "/home/git/
> reviewboard/reviewboard/admin/middleware.py", line 13, in ?\n    from
> reviewboard.webapi.json import service_not_configured
>  [error] [client] PythonHandler myvirtualdjango:   File "/home/git/
> reviewboard/reviewboard/webapi/json.py", line 52, in ?\n
> http_status=400) # 400 Bad Request)
>  [error] [client] PythonHandler myvirtualdjango: TypeError: __init__()
> got an unexpected keyword argument 'http_status'
>
> === end apache log
>
> mysite -> internal name...
> I have debugging and autoreload on for debugging purposes
>       <Directory "/var/www/mysite/htdocs">
>
> === begin config
>
> <VirtualHost *:80>
>        ServerName mysite.domain.com
>        DocumentRoot "/var/www/mysite/htdocs"
>
>        # Error handlers
>        ErrorDocument 500 /errordocs/500.html
>
>        # Serve django pages
>        <Location "/">
>                PythonPath "['/var/www/mysite/conf'] + sys.path"
>                SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
>                SetEnv PYTHON_EGG_CACHE "/var/www/mysite/tmp/
> egg_cache"
>                SetEnv HOME "/var/www/mysite/data"
>                SetHandler mod_python
>                PythonHandler django.core.handlers.modpython
>                PythonAutoReload True
>                PythonDebug True
>                # Used to run multiple mod_python sites in the same
> apache
>                PythonInterpreter reviewboard_mysite
>        </Location>
>
>        # Serve static media without running it through mod_python
>        # (overrides the above)
>        <Location "/media">
>                SetHandler None
>        </Location>
>        <Location "/errordocs">
>                SetHandler None
>        </Location>
>
>        <Directory "/var/www/mysite/htdocs">
>                AllowOverride All
>        </Directory>
>
>        # Alias static media requests to filesystem
>        Alias /media "/var/www/mysite/htdocs/media"
>        Alias /errordocs "/var/www/mysite/htdocs/errordocs"
> </VirtualHost>
>
> === end config
>
> Thanks for any help?
>
> 1.  Is there a hidden file pointing me at the development area
> somewhere on my system.
>
>
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to