Thanks for your response, Christian.

I have never run "evolve --hint --execute".  Until this last upgrade,
I didn't know it existed and I only ran it with the --hint flag.  It's
good to know that I should never use that.  I definitely will not in
the future.

We are using ReviewBoard at my work, so I had to revert back to
1.6beta1 because that was working.  When I kept it at 1.6beta2.1, I
received errors when trying to access the diff viewer.  I think this
database was started with version 1.5.  I don't have a very recent
database to restore from before the upgrade.  I backed it up before
the 1.6beta1 upgrade, but not before the 1.6beta2.1 upgrade - I've
learned my lesson, always backup.  I downgraded from 1.6beta2.1 to
1.6beta1 and everything seems to be working smoothly.

For deleting the evolutions, are you suggesting to re-upgrade to
1.6beta2.1 and then try, one-by-one, to delete the evolutions and run
"rb-site upgrade" after each deletion?

Thanks!
Kyle

On May 23, 3:49 pm, Christian Hammond <chip...@chipx86.com> wrote:
> Running evolve --hint --execute is the best way to cause breakages like
> this. You should never have a reason to run it, regardless of what people
> say on the forum or other sites, unless you're in some very specific
> development cases.
>
> What I imagine happened was that, for some reason, you ended up running
> evolve --hint --execute with an older version of Review Board, or something,
> and it erased the fields. Then when doing the upgrade, it expected those to
> exist, because the evolution history said they were there.
>
> Best advice would be to restore from a backup from before the upgrade, if
> you can. (Do you have a backup from before the upgrade?)
>
> Failing that, you'd need to remove all the evolution database entries from
> 1.6 beta 1 through beta 2. There's a table (django_evolution) that lists, in
> order, the evolutions performed. I think you want to delete starting at the
> "localsite".
>
> Make sure you backup your database first! This is hairy and may require a
> bit of trial and error.
>
> Is there any chance you for any moment reverted back to an older version of
> Review Board?
>
> Also, what version of Review Board did you start with when creating the
> database?
>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
> Review Board -http://www.reviewboard.org
> VMware, Inc. -http://www.vmware.com
>
> On Mon, May 23, 2011 at 7:50 AM, kylebhamilton <kylebhamil...@gmail.com>wrote:
>
>
>
>
>
>
>
> > I ran evolve --hint after reading some of the forum posts on error
> > such as this, but I didn't try to make the database changes.  I
> > haven't modified or cleared the database.
>
> > Kyle
>
> > On May 18, 2:38 pm, Christian Hammond <chip...@chipx86.com> wrote:
> > > Sorry, you said the source version in the subject.
>
> > > Most of those fields were present in beta 1. At any point, did you
> > > ever run evolve --hint, or in any way modify your database (even clear
> > > it)?
>
> > > Christian
>
> > > On Wednesday, May 18, 2011, Christian Hammond <chip...@chipx86.com>
> > wrote:
> > > > Hey Kyle,
>
> > > > What version are you coming from?
>
> > > > These are all things that have evolution files, so it sounds like they
> > > > may not be processed correctly. I assume you upgraded with
> > > > easy_install?
>
> > > > Christian
>
> > > > On Wednesday, May 18, 2011, kylebhamilton <kylebhamil...@gmail.com>
> > wrote:
> > > >> I just installed the new beta 2.1 and tried to upgrade my site, but I
> > > >> get the following evolution errors.  I understand that the RandomPool
> > > >> message is a ThirdParty issue, so that is not my concern.  I am
> > > >> referring to the unresolved evolution errors.  I have searched
> > > >> unsuccessfully through the forums to try to find an answer.
>
> > > >> I appreciate any input!
>
> > > >> Kyle
>
> > > >> ---
>
> > > >> # rb-site upgrade /var/www/reviewboard
> > > >> Rebuilding directory structure
> > > >> Updating database. This may take a while.
> > > >> There are unapplied evolutions for reviews.
> > > >> Project signature has changed - an evolution is required
> > > >> No fixtures found.
> > > >> /usr/lib/python2.4/site-packages/pycrypto-2.3-py2.4-linux-i686.egg/
> > > >> Crypto/Util/randpool.py:40: RandomPool_DeprecationWarning: This
> > > >> application uses RandomPool, which is BROKEN in older releases.  See
> > > >>http://www.pycrypto.org/randpool-broken
> > > >> The stored evolutions do not completely resolve all model changes.
> > > >> Run `./manage.py evolve --hint` to see a suggestion for the changes
> > > >> required.
>
> > > >> The following are the changes that could not be resolved:
> > > >> In model reviews.DefaultReviewer:
> > > >>     Field 'local_site' has been added
> > > >> In model reviews.ReviewRequest:
> > > >>     Field 'local_site' has been added
> > > >>     Field 'local_id' has been added
> > > >> In model reviews.Group:
> > > >>     Field 'local_site' has been added
> > > >>     Field 'incoming_request_count' has been added
> > > >>     Field 'visible' has been added
> > > >>     Field 'invite_only' has been added
> > > >>     In field 'name':
> > > >>         Property 'unique' has changed
> > > >> In model scmtools.Repository:
> > > >>     Field 'review_groups' has been added
> > > >>     Field 'local_site' has been added
> > > >>     Field 'public' has been added
> > > >>     Field 'users' has been added
> > > >>     In field 'path':
> > > >>         Property 'unique' has changed
> > > >>     In field 'name':
> > > >>         Property 'unique' has changed
> > > >> Error: Your models contain changes that Django Evolution cannot
> > > >> resolve automatically.
>
> > > >> --
> > > >> Want to help the Review Board project? Donate today athttp://
> >www.reviewboard.org/donate/
> > > >> Happy user? Let us know athttp://www.reviewboard.org/users/
> > > >> -~----------~----~----~----~------~----~------~--~---
> > > >> To unsubscribe from this group, send email to
> > reviewboard+unsubscr...@googlegroups.com
> > > >> For more options, visit this group athttp://
> > groups.google.com/group/reviewboard?hl=en
>
> > > > --
> > > > --
> > > > Christian Hammond - chip...@chipx86.com
> > > > Review Board -http://www.reviewboard.org
> > > > VMware, Inc. -http://www.vmware.com
>
> > > --
> > > --
> > > Christian Hammond - chip...@chipx86.com
> > > Review Board -http://www.reviewboard.org
> > > VMware, Inc. -http://www.vmware.com
>
> > --
> > Want to help the Review Board project? Donate today at
> >http://www.reviewboard.org/donate/
> > Happy user? Let us know athttp://www.reviewboard.org/users/
> > -~----------~----~----~----~------~----~------~--~---
> > To unsubscribe from this group, send email to
> > reviewboard+unsubscr...@googlegroups.com
> > For more options, visit this group at
> >http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to