Hi Christian, 

I guess something in the database must have got
corrupted somehow. I changed the drop down, changed it back to Bugzilla
and re-saved the repository details and all seems to be working again
now. The reviews where I had added a bug number now display without
error, and I can upload new review using post-review with the
--bugs-closed option as well. 

Thanks for the help 

Rob 

On Fri, 24
Jun 2011 01:58:24 -0700, Christian Hammond wrote: 

> I imagine the bug
tracker was set to Bugzilla, with that being the bugzilla server. What
should happen is we should then auto-append the whole
"show_bug.cgi?id=%s" when saving the repository. Perhaps something went
wrong there. If you could try to reproduce that, by setting it back to
Bugzilla in the dropdown, it would help confirm that theory.
> 
> If you
could also send a screenshot of the repository page (to me directly,
probably with portions blurred out) it would help me to see the state of
things.
> 
> Christian
> 
> -- 
> Christian Hammond -
chip...@chipx86.com [24]
> Review Board - http://www.reviewboard.org
[25]
> VMware, Inc. - http://www.vmware.com [26]
> 
> On Fri, Jun 24,
2011 at 1:47 AM, Rob Coward wrote:
> 
>> Ah, also just noticed that
adding a bug number after the review was created also triggers the
error, confirming what you are saying about a possible config issue
rather than post-review doing something wrong. 
>> 
>> In the repo admin
screen I just have "http://bugzilla.group.game.net [18]" as the Bug
tracker URL and this used to work fine resulting in the correct links
(at least in 1.6beta1 - I dont remember if we have added any new reviews
since updating to 1.6beta2). 
>> 
>> Was a change made somewhere
requiring the url to be specified as
"http://bugzilla.group.game.net/show_bug.cgi?id=%s [19]" ? 
>> 
>> I've
updated the url against the repository in question and I'm still getting
the same error when trying to view a newly created review with a bug
number against it. 
>> 
>> Regards, 
>> 
>> Rob 
>> 
>> On Fri, 24 Jun
2011 01:19:15 -0700, Christian Hammond wrote: 
>> 
>>> Sorry, I spoke
too soon. This is already checked. The problem actually may be too many
%s in the bug tracker URL. Can you check if there's only one?
>>> 
>>>
Christian
>>> 
>>> -- 
>>> Christian Hammond - chip...@chipx86.com
[10]
>>> Review Board - http://www.reviewboard.org [11]
>>> VMware, Inc.
- http://www.vmware.com [12]
>>> 
>>> On Fri, Jun 24, 2011 at 1:16 AM,
Christian Hammond wrote:
>>> 
>>>> We can fix this symptom, but it's due
to a configuration issue. The bug tracker configured for your repository
is missing a %s.
>>>> 
>>>> I'll put a fix in tonight for the crash. It
just won't set up a link without a fixed URL.
>>>> 
>>>> Christian
>>>>

>>>> -- 
>>>> Christian Hammond - chip...@chipx86.com [6]
>>>> Review
Board - http://www.reviewboard.org [7]
>>>> VMware, Inc. -
http://www.vmware.com [8] 
>>>> 
>>>> On Fri, Jun 24, 2011 at 1:14 AM,
Rob Coward wrote:
>>>> 
>>>>> Hi, 
>>>>> 
>>>>> I have just hit an issue
using post-review to upload a post-commit review of a subversion
revision range, specifying the --bugs-closed paramter. I was using the
1.6beta2 version and have just upgraded to 1.6RC1 and the problem still
exists. The post-review is from RBTools 0.3.2. 
>>>>> 
>>>>> Uploading a
diff without using the --bugs-closed option works fine, creating a draft
review which can then be updated through the web ui. However if I try to
use the --bugs-closed option, it creates a review, but whenever trying
to view the review through the ui, I get the following Internal Server
Error: 
>>>>> 
>>>>> Exception thrown for user rcowa at
http://reviewboard/r/55/ [1]
>>>>> 
>>>>> not enough arguments for
format string
>>>>> Traceback (most recent call last):
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/core/handlers/base.py",
line 111, in get_response
>>>>> response = callback(request,
*callback_args, **callback_kwargs)
>>>>> File
"/usr/lib/python2.4/site-packages/ReviewBoard-1.6rc1-py2.4.egg/reviewboard/accounts/decorators.py",
line 21, in _check
>>>>> return view_func(*args, **kwargs)
>>>>> File
"/usr/lib/python2.4/site-packages/ReviewBoard-1.6rc1-py2.4.egg/reviewboard/reviews/views.py",
line 433, in review_detail
>>>>> RequestContext(request,
_make_review_request_context(review_request, {
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/shortcuts/__init__.py",
line 20, in render_to_response
>>>>> return
HttpResponse(loader.render_to_string(*args, **kwargs),
**httpresponse_kwargs)
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/loader.py",
line 183, in render_to_string
>>>>> return
t.render(Context(dictionary))
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 123, in render
>>>>> return self._render(context)
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 117, in _render
>>>>> return self.nodelist.render(context)
>>>>>
File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 744, in render
>>>>> bits.append(self.render_node(node,
context))
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 757, in render_node
>>>>> return node.render(context)
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/loader_tags.py",
line 127, in render
>>>>> return compiled_parent._render(context)
>>>>>
File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 117, in _render
>>>>> return self.nodelist.render(context)
>>>>>
File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 744, in render
>>>>> bits.append(self.render_node(node,
context))
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 757, in render_node
>>>>> return node.render(context)
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/loader_tags.py",
line 127, in render
>>>>> return compiled_parent._render(context)
>>>>>
File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 117, in _render
>>>>> return self.nodelist.render(context)
>>>>>
File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 744, in render
>>>>> bits.append(self.render_node(node,
context))
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 757, in render_node
>>>>> return node.render(context)
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/loader_tags.py",
line 64, in render
>>>>> result = block.nodelist.render(context)
>>>>>
File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 744, in render
>>>>> bits.append(self.render_node(node,
context))
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 757, in render_node
>>>>> return node.render(context)
>>>>> File
"/usr/lib/python2.4/site-packages/Djblets-0.6.8-py2.4.egg/djblets/util/decorators.py",
line 186, in render
>>>>> return self.tag_func(context, self.nodelist,
*args)
>>>>> File
"/usr/lib/python2.4/site-packages/Djblets-0.6.8-py2.4.egg/djblets/util/templatetags/djblets_deco.py",
line 42, in box
>>>>> return render_to_string('deco/box.html', {
>>>>>
File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 744, in render
>>>>> bits.append(self.render_node(node,
context))
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 757, in render_node
>>>>> return node.render(context)
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/loader_tags.py",
line 159, in render
>>>>> return self.render_template(self.template,
context)
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/loader_tags.py",
line 141, in render_template
>>>>> output =
template.render(context)
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 123, in render
>>>>> return self._render(context)
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 117, in _render
>>>>> return self.nodelist.render(context)
>>>>>
File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 744, in render
>>>>> bits.append(self.render_node(node,
context))
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 757, in render_node
>>>>> return node.render(context)
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/defaulttags.py",
line 394, in render
>>>>> return
strip_spaces_between_tags(self.nodelist.render(context).strip())
>>>>>
File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 744, in render
>>>>> bits.append(self.render_node(node,
context))
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 757, in render_node
>>>>> return node.render(context)
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/defaulttags.py",
line 227, in render
>>>>> nodelist.append(node.render(context))
>>>>>
File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/defaulttags.py",
line 497, in render
>>>>> values = dict([(key, val.resolve(context))
for key, val in
>>>>> File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/template/base.py",
line 536, in resolve
>>>>> new_obj = func(obj, *arg_vals)
>>>>> File
"/usr/lib/python2.4/site-packages/ReviewBoard-1.6rc1-py2.4.egg/reviewboard/reviews/templatetags/reviewtags.py",
line 397, in bug_url
>>>>> return review_request.repository.bug_tracker
% bug_id
>>>>> TypeError: not enough arguments for format string
>>>>>

>>>>> Let me know if I can provide any more info.
>>>>> 
>>>>>
Regards,
>>>>> Rob
>>>>> 
>>>>> -- 
>>>>> Want to help the Review Board
project? Donate today at http://www.reviewboard.org/donate/ [2]
>>>>>
Happy user? Let us know at http://www.reviewboard.org/users/ [3]
>>>>>
-~----------~----~----~----~------~----~------~--~---
>>>>> To
unsubscribe from this group, send email to
reviewboard+unsubscr...@googlegroups.com [4]
>>>>> For more options,
visit this group at http://groups.google.com/group/reviewboard?hl=en
[5]
>>> 
>>> -- 
>>> Want to help the Review Board project? Donate today
at http://www.reviewboard.org/donate/ [14]
>>> Happy user? Let us know
at http://www.reviewboard.org/users/ [15]
>>>
-~----------~----~----~----~------~----~------~--~---
>>> To unsubscribe
from this group, send email to reviewboard+unsubscr...@googlegroups.com
[16]
>>> For more options, visit this group at
http://groups.google.com/group/reviewboard?hl=en [17]
>> 
>> -- 
>> Want
to help the Review Board project? Donate today at
http://www.reviewboard.org/donate/ [20]
>> Happy user? Let us know at
http://www.reviewboard.org/users/ [21]
>>
-~----------~----~----~----~------~----~------~--~---
>> To unsubscribe
from this group, send email to reviewboard+unsubscr...@googlegroups.com
[22]
>> For more options, visit this group at
http://groups.google.com/group/reviewboard?hl=en [23]
> 
> -- 
> Want to
help the Review Board project? Donate today at
http://www.reviewboard.org/donate/ [28]
> Happy user? Let us know at
http://www.reviewboard.org/users/ [29]
>
-~----------~----~----~----~------~----~------~--~---
> To unsubscribe
from this group, send email to
reviewboard+unsubscr...@googlegroups.com
> For more options, visit this
group at http://groups.google.com/group/reviewboard?hl=en [30]



Links:
------
[1] http://reviewboard/r/55/
[2]
http://www.reviewboard.org/donate/
[3]
http://www.reviewboard.org/users/
[4]
mailto:reviewboard%2bunsubscr...@googlegroups.com
[5]
http://groups.google.com/group/reviewboard?hl=en
[6]
mailto:chip...@chipx86.com
[7] http://www.reviewboard.org
[8]
http://www.vmware.com
[9] mailto:r...@jive-videos.net
[10]
mailto:chip...@chipx86.com
[11] http://www.reviewboard.org
[12]
http://www.vmware.com
[13] mailto:chip...@chipx86.com
[14]
http://www.reviewboard.org/donate/
[15]
http://www.reviewboard.org/users/
[16]
mailto:reviewboard%2bunsubscr...@googlegroups.com
[17]
http://groups.google.com/group/reviewboard?hl=en
[18]
http://bugzilla.group.game.net
[19]
http://bugzilla.group.game.net/show_bug.cgi?id=%s
[20]
http://www.reviewboard.org/donate/
[21]
http://www.reviewboard.org/users/
[22]
mailto:reviewboard%2bunsubscr...@googlegroups.com
[23]
http://groups.google.com/group/reviewboard?hl=en
[24]
mailto:chip...@chipx86.com
[25] http://www.reviewboard.org
[26]
http://www.vmware.com
[27] mailto:r...@jive-videos.net
[28]
http://www.reviewboard.org/donate/
[29]
http://www.reviewboard.org/users/
[30]
http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to