Hi guys, I made some progress with regards to my situation.

I am using ReviewBoard 1.5.1;
According to an answer I got from StackOverflow, I modified the
\reviewboard\scmtools\git.py file, and replaced the following lines:

self.git_dir = url_parts[2]

with:

self.git_dir = url_parts[1] + url_parts[2]

I also modified my Apache configuration file to ensure that Apache has
access to my repository folder.
Now, there remains one problem. When I try to add my repository with
the following format: file://D:/Repositoires/LocalClones/sdu-test , I
get the following error:
<django.utils.functional.__proxy__ object at 0x049AA7B0>

Nothing in my Apache log file seems to indicate a problem...

Anyone has any clue as to why I'm getting this error?



On Jun 7, 5:21 pm, hbCyber <jean.sebastien.le...@gmail.com> wrote:
> Thanks for the update. Sadly, I have yet to get Review Board to work
> with my Git repositories. Good to know, however, that I do not need a
> local clone. I will experiment more with the permissions settings and
> see if I can come up with something. Suggestions are still welcome; I
> will post an update if I manage to get this to work.
>
> Cheers,
> Jean
>
> On Jun 3, 3:40 am, Christian Hammond <chip...@chipx86.com> wrote:
>
>
>
>
>
>
>
> > Hi Jean,
>
> > Sorry for the late reply. Hope you've figured this out by now.
>
> > So, it sounds as if the main repositories are also on that same system, or
> > at least accessible by it? If that's the case, you don't need separate
> > clones. Review Board can access the main repository.
>
> > The permission errors issues sound exactly like say. Apache may not have
> > permission to access that directory. Make sure ownership and permissions are
> > correct so that that user can get to it.
>
> > The getaddrinfo error indicates that it's not looking up "localhost"
> > properly on your system. (This isn't a Review Board thing.) You could try
> > 127.0.0.1, but using the file path is probably better, once you figure out
> > the permission denied problems.
>
> > Christian
>
> > --
> > Christian Hammond - chip...@chipx86.com
> > Review Board -http://www.reviewboard.org
> > VMware, Inc. -http://www.vmware.com
>
> > On Mon, May 30, 2011 at 10:33 PM, hbCyber 
> > <jean.sebastien.le...@gmail.com>wrote:
>
> > > Hi guys, I need some help.
>
> > > I have aWindowsServer 2003 computer that I'm setting up with Git and
> > > Review-Board.
>
> > > My Git repositories are managed by Gitolite. The setup is successful
> > > and everything is working fine (tested with multiple workstations).
>
> > > The Review-Board site has installed successfully and is hosted under
> > > Apache 2.2. This is also working fine in itself (the website is
> > > accessible and responds for workstations), except the part where I'm
> > > trying to link Git repositories to Review-Board.
>
> > > Most tutorials (example:
> > >http://ericholscher.com/blog/2011/jan/24/using-reviewboard-git/)
> > > provide good details on how to setup a Git repository under Review-
> > > Board, except that they refer to Linux/Unix systems, and I am running
> > >WindowsServer 2003.
>
> > > My Gitolite repositories are stored under D:\Repositories\Git (on the
> > > same server as Review-Board)
> > > Example: D:\Repositories\Git\sdu-test\.git
>
> > > My understanding is that Review-Board needs a local clone of the
> > > repository(ies). Therefore, I created a directory named LocalClones
> > > and I cloned my repository.
> > > Example: D:\Repositories\LocalClones\[I cloned sdu-test.git here]
> > > Command used (from LocalClones directory): git clone ../Git/sdu-
> > > test.git
> > > (the clone was successful)
>
> > > Now, in Review-Board, I'm trying to declare my sdu-test repository.
> > > This is where nothing works. I always get an error no matter what
> > > combination I try! Here are my initial settings:
>
> > >    Name is 'sdu-test'
> > >    Hosting type is 'Custom'
> > >    Repository type is 'Git'
>
> > > For path, if I write:
>
> > > 'file://D/Repositories/LocalClones/sdu-test/.git' --> Error:
> > > Permission denied accessing the local Git repository '/Repositories/
> > > LocalClones/sdu-test/.git'
>
> > > '/D/Repositories/LocalClones/sdu-test/.git' --> Error: Permission
> > > denied accessing the local Git repository '/D/Repositories/LocalClones/
> > > sdu-test/.git'
>
> > > 'ssh://git@localhost/cygdrive/d/Repositories/LocalClones' --> Error:
> > > Unable to authenticate against this repository using one of the
> > > supported authentication types.
>
> > > 'D:\Repositories\LocalClones\sdu-test\.git' --> Error: (11001,
> > > 'getaddrinfo failed')
>
> > > No matter what I try, it just won't work! I've been looking for
> > > tutorials online for days, but nobody online seems to encounter this
> > > situation, which makes it even more frustrating...
>
> > > Can anyone help me out with this? Thank you so much in advance.
>
> > > Best regards,
> > > Jean
>
> > > --
> > > Want to help the Review Board project? Donate today at
> > >http://www.reviewboard.org/donate/
> > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > -~----------~----~----~----~------~----~------~--~---
> > > To unsubscribe from this group, send email to
> > > reviewboard+unsubscr...@googlegroups.com
> > > For more options, visit this group at
> > >http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to