Do you have the same problem when hitting Publish on the review request?

Generally, this is caused when Review Board tries to send an e-mail after
publishing. There could be some communication problem with the mail server.
You may want to try temporarily disabling e-mail and testing --publish. You
can also check the server logs (both Review Board and mail server) to see if
anything shows up.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Tue, Jul 19, 2011 at 7:26 AM, Stefan <stefan.louis.no...@gmail.com>wrote:

> Actually, I don't think it was. I submitted this problem as a bug with
> a workaround at:
>
> http://code.google.com/p/reviewboard/issues/detail?id=2179
>
> On Jul 18, 2:44 pm, Stefan <stefan.louis.no...@gmail.com> wrote:
> > It looks like this behavior has been addressed in commit
> > 885f880ea4a0042f8f54 ([RBTools] Brand new Clear Case implementation),
> > which was made just after the tagging for 0.3.2.
> >
> > On Jul 15, 10:06 am, Stefan <stefan.louis.no...@gmail.com> wrote:
> >
> >
> >
> >
> >
> >
> >
> > > Hi all,
> >
> > > I'm currently using RB 1.5.5 and RBTools 0.3.2. Whenever I try
> > > submitting a review via a Subversion post-commit hook with the
> > > "publish" flag, the command hangs indefinitely. Here is my debug
> > > output:
> >
> > > www-data@ainet:/home/git/svn-repositories/test$ post-review --
> > > server=http://ainet--username=admin--password=admin --submit-
> > > as=snovak --revision-range=11 --target-people=admin -p -d
> >
> > > >>> RBTools 0.3.2
> > > >>> Home = /var/www
> > > >>> svn info
> > > >>> diff --version
> > > >>> repository info: Path: file:///svn/test, Base path: /, Supports
> changesets: False
> > > >>> HTTP GETting api/
> > > >>> HTTP GETtinghttp://ainet/api/info/
> > > >>> Using the new web API
> > > >>> svn diff --diff-cmd=diff -r 11
> > > >>> svn info trunk/test.txt
> > > >>> svn info trunk/test.txt
> > > >>> svn info trunk/test.txt
> > > >>> svn info trunk/test.txt
> > > >>> HTTP GETtinghttp://ainet/api/repositories/
> > > >>> HTTP GETtinghttp://ainet/api/repositories/3/
> > > >>> HTTP GETtinghttp://ainet/api/repositories/3/info/
> > > >>> HTTP GETtinghttp://ainet/api/repositories/4/
> > > >>> HTTP GETtinghttp://ainet/api/repositories/4/info/
> > > >>> repository info: Path: file:///svn/test, Base path: /, Supports
> changesets: False
> > > >>> Attempting to create review request on TEST for None
> > > >>> Submitting the review request as snovak
> > > >>> HTTP POSTing tohttp://ainet/api/review-requests/:{'submit_as':
> 'snovak', 'repository': 'TEST'}
> > > >>> Review request created
> > > >>> Attempting to set field 'target_people' to 'admin' for review
> request '34'
> > > >>> HTTP PUTting
> tohttp://ainet/api/review-requests/34/draft/:{'target_people': 'admin'}
> > > >>> Uploading diff, size: 307
> > > >>> HTTP POSTing
> tohttp://ainet/api/review-requests/34/diffs/:{'basedir': '/'}
> > > >>> Publishing
> > > >>> HTTP PUTting
> tohttp://ainet/api/review-requests/34/draft/:{'public': 1}
> >
> > > [Hangs here.]
> >
> > > Note that accessinghttp://ainet/api/review-requests/34/draft/hasa
> > > response error code of 100 with a message "Object does not exist". The
> > > review does get posted, however, the operation hangs. This occurs
> > > whether or not I specify a target person to review the changes. If I
> > > do not include the publish flag, the operation completes as expected.
> >
> > > Does anyone have insight into addressing this issue?
> >
> > > Thanks!
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to