Where did you specify rboard as the database? It looks like it's still
configured in the site's settings_local.py as reviewboard. Can you send that
file directly to me? (remove the SECRET_KEY and password first).

Christian

On Monday, August 15, 2011, Kannaiyan Natesan <gbpnk...@gmail.com> wrote:
> Thanks Chris for taking a look and confirm it can work on a different
database.
>
> Below are my findings.
>
> Regarding the port issue, I don't see any other way (software, other than
tortoisehg & postreview) of posting it to reviewboard to validate it.
> Installed with rboard as the database. When going to homepage, i got this
StackTrace.
>
> Please let me know if you need more info.
>
> Traceback (most recent call last):
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/core/handlers/base.py",
line 117, in get_response
>
>     response = middleware_method(request, e)
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Djblets-0.6.9-py2.4.egg/djblets/log/middleware.py",
line 220, in process_exception
>
>     request.user, request.build_absolute_uri(),
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/contrib/auth/middleware.py",
line 9, in __get__
>
>     request._cached_user = get_user(request)
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/contrib/auth/__init__.py",
line 107, in get_user
>
>     user_id = request.session[SESSION_KEY]
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/contrib/sessions/backends/base.py",
line 47, in __getitem__
>
>     return self._session[key]
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/contrib/sessions/backends/base.py",
line 195, in _get_session
>
>     self._session_cache = self.load()
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/contrib/sessions/backends/db.py",
line 20, in load
>
>     expire_date__gt=datetime.datetime.now()
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/db/models/manager.py",
line 132, in get
>
>     return self.get_query_set().get(*args, **kwargs)
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/db/models/query.py",
line 344, in get
>
>     num = len(clone)
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/db/models/query.py",
line 82, in __len__
>
>     self._result_cache = list(self.iterator())
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/db/models/query.py",
line 273, in iterator
>
>     for row in compiler.results_iter():
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/db/models/sql/compiler.py",
line 680, in results_iter
>
>     for rows in self.execute_sql(MULTI):
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/db/models/sql/compiler.py",
line 734, in execute_sql
>
>     cursor = self.connection.cursor()
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/db/backends/__init__.py",
line 252, in cursor
>
>     cursor = util.CursorWrapper(self._cursor(), self)
>
>
>
>   File
"/usr/lib/python2.4/site-packages/Django-1.3-py2.4.egg/django/db/backends/mysql/base.py",
line 322, in _cursor
>
>     self.connection = Database.connect(**kwargs)
>
>
>
>   File
"/usr/lib/python2.4/site-packages/MySQL_python-1.2.3-py2.4-linux-x86_64.egg/MySQLdb/__init__.py",
line 81, in Connect
>
>
>
>   File
"/usr/lib/python2.4/site-packages/MySQL_python-1.2.3-py2.4-linux-x86_64.egg/MySQLdb/connections.py",
line 187, in __init__
>
>
>
> OperationalError: (1049, "Unknown database 'reviewboard'")
>
> On Fri, Aug 12, 2011 at 8:52 PM, Chris Tooley <ch...@tooley.com> wrote:
>
> I can say our instance of reviewboard isn't on port 80 and our database
isn't named reviewboard. It works here just fine
>
> On Aug 12, 2011 5:30 PM, "Kannaiyan Natesan" <gbpnk...@gmail.com> wrote:
>> Christin,
>>
>> Bug is on the ReviewBoard.
>>
>>
>> 1. Reviewboard cannot run on other http ports other than 80. If you want
>> to run on other ports Apache Mod-Proxy might help.
>> 2. The database should be 'reviewboard' trying to install in other
>> database names will fail.
>>
>>
>> Tested with "hg postreview" & Tortoise hg, it worked fine upon satisfying
>> the above conditions.
>> Let me know if you need more info.
>>
>>
>> Thanks,
>> Kannaiyan
>>
>>
>> On Thu, Aug 11, 2011 at 1:14 AM, Christian Hammond <chip...@chipx86.com
>wrote:
>>
>>> Hi,
>>>
>>> Sorry, I don't know that either. hg postreview isn't developed by us.
>>> However, you may want to see if a proxy server is set up and interfering
>>> with the request, and see if there's any debugging flags you can use to
help
>>> diagnose this.
>>>
>>> Christian
>>>
>>>
>>> --
>>> Christian Hammond - chip...@chipx86.com
>>> Review Board - http://www.reviewboard.org
>>> VMware, Inc. - http://www.vmware.com
>>>
>>>
>>> On Wed, Aug 10, 2011 at 11:07 PM, Kannaiyan Natesan <gbpnk...@gmail.com
>wrote:
>>>
>>>> Hi Christian,
>>>>
>>>> I even tried,
>>>>
>>>> hg postview
>>>>
>>>> It just hangs and command does not return.
>>>>
>>>> Am I missing something in config?
>>>>
>>>> Thanks,
>>>> Kannaiyan
>>>>
>>>> On Wed, Aug 10, 2011 at 7:24 PM, Christian Hammond <chip...@chipx86.com
>wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> Wish I could help, but this error is coming from TortoiseHg, and we
don't
>>>>> develop or support that. You'd have to talk to the authors and see
what they
>>>>> say.
>>>>>
>>>>> Christian
>>>>>
>>>>>
>>>>>
>>>>> On Wednesday, August 10, 2011, Kannaiyan Natesan <gbpnk...@gmail.com>
>>>>> wrote:
>>>>> > Installed reviewboard and no luck in getting it to work.
>>>>> >
>>>>> > When tried from TortoiseHg 2.1.2 (latest version)
>>>>> >
>>>>> > It says,
>>>>> >
>>>>> > {{{
>>>>> > #!python
>>>>> > ** Mercurial version (1.9.1). TortoiseHg version (2.1.2)
>>>>> > ** Command: --nofork workbench
>>>>> > ** CWD: C:\MercurialTestClone\TestRepo
>>>>> > ** Encoding: cp1252
>>>>> > ** Extensions loaded: convert, rebase, fetch, reviewboard
>>>>> > ** Python version: 2.6.6 (r266:84297, Aug 24 2010, 18:13:38) [MSC v.
>>>>> > 1500 64 bit (AMD64)]
>>>>> > ** Windows version: (5, 2, 3790, 2, 'Service Pack 2')
>>>>> > ** Processor architecture: x64
>>>>> > ** Qt-4.7.1 PyQt-4.8.3
>>>>> > Traceback (most recent call last):
>>>>> > File "tortoisehg\hgqt\postreview.pyo", line 50, in run
>>>>> > File "tortoisehg\hgqt\postreview.pyo", line 78, in loadCombos
>>>>> > AttributeError: Api20Client instance has no attribute
>>>>> > 'pending_user_requests'
>
> --
> +1-650-605-3290 <tel:%2B1-650-605-3290>
> The best things in life are free
>
> --
> Want to help the Review Board project? Donate today at
http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
reviewboard+unsubscr...@googlegroups.com <
reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
http://groups.google.com/group/reviewboard?hl=en

-- 
-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to