Hi Robert.
I believe this is the private profile feature which was added in 1.6 RC1.
http://code.google.com/p/reviewboard/issues/detail?id=2127

In general, user profiles are private by default so that email, first_name
and last_name won't show up. Maybe you can upgrade your account to site
admin if you can. Those fields should always show to site admin.

Hongbin

On Fri, Sep 2, 2011 at 2:41 AM, Robert Munteanu
<robert.munte...@gmail.com>wrote:

> Hi,
>
> I am not sure whether this is a bug or not, but here goes:
>
> The API does not return the {first_name, last_name, email} fields for some
> users ( 3 out of 8135 on reviews.review-board.org ) . I assume that this
> is some sort of privacy setting, but I think it would be best for the fields
> to be returned but empty, as it makes consistent parsing easier.
>
> This happens for both the JSON and the XML formats.
>
> One such example is
>
> http://reviews.reviewboard.org/api/users/mbait/
>
> Let me know if I should open a bug report or if this is expected .
>
> Robert
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to