> "INDEX command denied to user 'rb'@'localhost' for table
'accounts_localsiteprofile'")

Seems a Database Issue. Did you verify permissions for this user on
Database?
Kannaiyan
On Tue, Sep 6, 2011 at 10:47 AM, Mak3r <markabr...@1stplayable.com> wrote:

> I am trying to upgrade reviewboard 1.5.5 to 1.6 and have failed with
> the errors below when I run the site upgrade (sudo rb-site upgrade /
> var/www/rb) . I am able to visit the reviewboard site and see that
> 1.5.5 is still installed. Will the database update have been rolled
> back or aborted? How can I tell if my site is now corrupted? Also, do
> you have suggestions to repair my system and resolve this issue?
>
>
> ======================================
> UPDATE RB - success, (included for completeness)
> ======================================
>
> user@rb:/var/www$ sudo easy_install -U ReviewBoard
> install_dir /usr/local/lib/python2.6/dist-packages/
> Searching for ReviewBoard
> Reading http://pypi.python.org/simple/ReviewBoard/
> Reading http://www.reviewboard.org/
> Reading http://downloads.reviewboard.org/releases/ReviewBoard/1.5/
> Reading http://downloads.reviewboard.org/releases/ReviewBoard/1.6/
> Reading http://downloads.reviewboard.org/releases/ReviewBoard/1.0/
> Reading http://www.review-board.org/
> Reading http://downloads.review-board.org/releases/
> Reading http://downloads.review-board.org/releases/ReviewBoard/1.0/
> Best match: ReviewBoard 1.6
> Downloading
> http://downloads.reviewboard.org/releases/ReviewBoard/1.6/ReviewBoard-1.6-py2.6.egg
> Processing ReviewBoard-1.6-py2.6.egg
> creating /usr/local/lib/python2.6/dist-packages/ReviewBoard-1.6-
> py2.6.egg
> Extracting ReviewBoard-1.6-py2.6.egg to /usr/local/lib/python2.6/dist-
> packages
> Removing ReviewBoard 1.5.5 from easy-install.pth file
> Adding ReviewBoard 1.6 to easy-install.pth file
> Installing rb-site script to /usr/local/bin
> Installing rbssh script to /usr/local/bin
>
> Installed /usr/local/lib/python2.6/dist-packages/ReviewBoard-1.6-
> py2.6.egg
> Reading http://downloads.reviewboard.org/mirror/
> Processing dependencies for ReviewBoard
> Searching for Pygments>=1.4
> Reading http://pypi.python.org/simple/Pygments/
> Reading http://pygments.org/
> Reading http://pygments.pocoo.org/
> Best match: Pygments 1.4
> Downloading
> http://pypi.python.org/packages/2.6/P/Pygments/Pygments-1.4-py2.6.egg#md5=306241dd68799753cdb4a2c9ce8e883a
> Processing Pygments-1.4-py2.6.egg
> creating /usr/local/lib/python2.6/dist-packages/Pygments-1.4-py2.6.egg
> Extracting Pygments-1.4-py2.6.egg to /usr/local/lib/python2.6/dist-
> packages
> Removing Pygments 1.3.1 from easy-install.pth file
> Adding Pygments 1.4 to easy-install.pth file
> Installing pygmentize script to /usr/local/bin
>
> Installed /usr/local/lib/python2.6/dist-packages/Pygments-1.4-
> py2.6.egg
> Searching for Djblets>=0.6.10
> Reading http://pypi.python.org/simple/Djblets/
> Reading http://www.review-board.org/wiki/Djblets
> Reading http://downloads.review-board.org/releases/Djblets/0.6/
> Reading http://downloads.review-board.org/releases/Djblets/0.5/
> Best match: Djblets 0.6.10
> Downloading
> http://downloads.reviewboard.org/releases/Djblets/0.6/Djblets-0.6.10-py2.6.egg
> Processing Djblets-0.6.10-py2.6.egg
> creating /usr/local/lib/python2.6/dist-packages/Djblets-0.6.10-
> py2.6.egg
> Extracting Djblets-0.6.10-py2.6.egg to /usr/local/lib/python2.6/dist-
> packages
> Removing Djblets 0.6.7 from easy-install.pth file
> Adding Djblets 0.6.10 to easy-install.pth file
>
> Installed /usr/local/lib/python2.6/dist-packages/Djblets-0.6.10-
> py2.6.egg
> Reading http://downloads.review-board.org/mirror/
> Searching for django-evolution>=0.6.5
> Reading http://pypi.python.org/simple/django_evolution/
> Reading http://code.google.com/p/django-evolution/
> Best match: django-evolution 0.6.5
> Downloading
> http://pypi.python.org/packages/2.6/d/django_evolution/django_evolution-0.6.5-py2.6.egg#md5=2d710049fb1f2ce78e3c3
> a4c0d3e0783<http://pypi.python.org/packages/2.6/d/django_evolution/django_evolution-0.6.5-py2.6.egg#md5=2d710049fb1f2ce78e3c3a4c0d3e0783>
> Processing django_evolution-0.6.5-py2.6.egg
> creating /usr/local/lib/python2.6/dist-packages/django_evolution-0.6.5-
> py2.6.egg
> Extracting django_evolution-0.6.5-py2.6.egg to /usr/local/lib/
> python2.6/dist-packages
> Removing django-evolution 0.6.2 from easy-install.pth file
> Adding django-evolution 0.6.5 to easy-install.pth file
>
> Installed /usr/local/lib/python2.6/dist-packages/
> django_evolution-0.6.5-py2.6.egg
> Searching for Django>=1.3
> Reading http://pypi.python.org/simple/Django/
> Reading http://www.djangoproject.com/
> Best match: Django 1.3
> Downloading
> http://pypi.python.org/packages/source/D/Django/Django-1.3.tar.gz#md5=1b8f76e91c27564708649671f329551f
> Processing Django-1.3.tar.gz
> Running Django-1.3/setup.py -q bdist_egg --dist-dir /tmp/easy_install-
> Fwze7Y/Django-1.3/egg-dist-tmp-3LfoS9
> zip_safe flag not set; analyzing archive contents...
> django.test.simple: module references __file__
> django.test._doctest: module references __file__
> django.test._doctest: module MAY be using inspect.getsourcefile
> django.conf.__init__: module references __file__
> django.conf.project_template.manage: module references __file__
> django.contrib.admindocs.views: module references __file__
> django.contrib.sitemaps.tests.basic: module references __file__
> django.contrib.gis.geometry.test_data: module references __file__
> django.contrib.gis.tests.layermap.tests: module references __file__
> django.contrib.gis.tests.geo3d.tests: module references __file__
> django.contrib.gis.tests.geogapp.tests: module references __file__
> django.contrib.auth.tests.views: module references __file__
> django.contrib.staticfiles.storage: module references __file__
> django.contrib.flatpages.tests.views: module references __file__
> django.contrib.flatpages.tests.templatetags: module references
> __file__
> django.contrib.flatpages.tests.middleware: module references __file__
> django.contrib.flatpages.tests.csrf: module references __file__
> django.contrib.formtools.tests.__init__: module references __file__
> django.utils.autoreload: module references __file__
> django.utils.version: module references __path__
> django.utils.module_loading: module references __path__
> django.utils.unittest.loader: module references __file__
> django.utils.unittest.collector: module references __file__
> django.utils.translation.trans_real: module references __file__
> django.utils.translation.__init__: module references __file__
> django.core.management.base: module references __path__
> django.core.management.__init__: module references __file__
> django.core.management.__init__: module references __path__
> django.core.management.sql: module references __file__
> django.core.management.commands.makemessages: module references
> __file__
> django.core.management.commands.loaddata: module references __file__
> django.core.management.commands.loaddata: module references __path__
> django.core.servers.basehttp: module references __path__
> django.db.utils: module references __file__
> django.db.models.loading: module references __file__
> django.views.i18n: module references __file__
> django.template.loaders.app_directories: module references __file__
> Removing Django 1.2.3 from easy-install.pth file
> Adding Django 1.3 to easy-install.pth file
> Installing django-admin.py script to /usr/local/bin
>
> Installed /usr/local/lib/python2.6/dist-packages/Django-1.3-py2.6.egg
> Finished processing dependencies for ReviewBoard
>
>
> ================
> SITE UPGRADE - fail
> ================
>
> user@rb:/var/www$ sudo rb-site upgrade /var/www/rb
> Rebuilding directory structure
> Upgrading site settings_local.py
> Updating database. This may take a while.
> /usr/local/lib/python2.6/dist-packages/Django-1.3-py2.6.egg/django/db/
> __init__.py:19: DeprecationWarning: settings.DATABASE_*
>  is deprecated; use settings.DATABASES instead.
>  DeprecationWarning
> /usr/local/lib/python2.6/dist-packages/Django-1.3-py2.6.egg/django/db/
> __init__.py:60: DeprecationWarning: Short names for ENG
> INE in database configurations are deprecated. Prepend default.ENGINE
> with 'django.db.backends.'
>  DeprecationWarning
> Creating tables ...
> Creating table accounts_localsiteprofile
> Creating table attachments_fileattachment
> Creating table reviews_fileattachmentcomment
> Creating table site_localsite_users
> Creating table site_localsite_admins
> Creating table site_localsite
> Upgrading Review Board from 1.5.5 to 1.6
> There are unapplied evolutions for sessions.
> There are unapplied evolutions for accounts.
> There are unapplied evolutions for changedescs.
> There are unapplied evolutions for reviews.
> There are unapplied evolutions for scmtools.
> Adding baseline version for new models
> Project signature has changed - an evolution is required
> Installing custom SQL ...
> Installing indexes ...
> Failed to install index for accounts.LocalSiteProfile model: (1142,
> "INDEX command denied to user 'rb'@'localhost' for table
> 'accounts_localsiteprofile'")
> Failed to install index for reviews.FileAttachmentComment model:
> (1142, "INDEX command denied to user 'rb'@'localhost' for ta
> ble 'reviews_fileattachmentcomment'")
> Failed to install index for site.LocalSite_users model: (1142, "INDEX
> command denied to user 'rb'@'localhost' for table 'site
> _localsite_users'")
> Failed to install index for site.LocalSite_admins model: (1142, "INDEX
> command denied to user 'rb'@'localhost' for table 'sit
> e_localsite_admins'")
> No fixtures found.
> Registering new SCM Tool Plastic SCM
> (reviewboard.scmtools.plastic.PlasticTool) in database
> Evolution could not be simulated, possibly due to raw SQL mutations
> Error: Error applying evolution: (1142, "INDEX command denied to user
> 'rb'@'localhost' for table 'django_session'")
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en




-- 
+1-650-605-3290
The best things in life are free

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to