At one point or another, you installed 1.6, not 1.6.1, but I'm guessing
something went wrong. Basically, your database already has the columns that
1.6.1 thinks needs to be installed, but due to whatever happened, RB's
settings in your database didn't have that knowledge recorded.

If I know what you attempted before, it'll help me to figure out the
solution.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Tue, Sep 13, 2011 at 2:40 AM, Rohini Kumar Tharigonda
<rok...@gmail.com>wrote:

> I have installed review board with yum
> (ReviewBoard-1.5.6-1.fc15.noarch)
>
> I did the following . I get error while upgrading  site.
>
> root@localhost conf.d]# easy_install -U ReviewBoard
>
> install_dir /usr/lib/python2.7/site-packages/
> Searching for ReviewBoard
> Reading http://pypi.python.org/simple/ReviewBoard/
> Reading http://www.reviewboard.org/
> Reading http://downloads.reviewboard.org/releases/ReviewBoard/1.6/
> Reading http://downloads.reviewboard.org/releases/ReviewBoard/1.5/
> Reading http://downloads.reviewboard.org/releases/ReviewBoard/1.0/
> Reading http://www.review-board.org/
> Reading http://downloads.review-board.org/releases/
> Reading http://downloads.review-board.org/releases/ReviewBoard/1.0/
> Best match: ReviewBoard 1.6.1
> Downloading
> http://downloads.reviewboard.org/releases/ReviewBoard/1.6/ReviewBoard-1.6.1-py2.7.egg
> Processing ReviewBoard-1.6.1-py2.7.egg
> creating /usr/lib/python2.7/site-packages/ReviewBoard-1.6.1-py2.7.egg
> Extracting ReviewBoard-1.6.1-py2.7.egg to /usr/lib/python2.7/site-
> packages
> Adding ReviewBoard 1.6.1 to easy-install.pth file
> Installing rb-site script to /usr/bin
> Installing rbssh script to /usr/bin
>
> Installed /usr/lib/python2.7/site-packages/ReviewBoard-1.6.1-py2.7.egg
> Reading http://downloads.reviewboard.org/mirror/
> Processing dependencies for ReviewBoard
> Finished processing dependencies for ReviewBoard
>
>
>
>
> [root@localhost conf.d]# rb-site upgrade /var/www/reviewboard/
>
> Rebuilding directory structure
> Upgrading site settings_local.py
> Updating database. This may take a while.
> /usr/lib/python2.7/site-packages/Django-1.3.1-py2.7.egg/django/db/
> __init__.py:19: DeprecationWarning: settings.DATABASE_* is deprecated;
> use settings.DATABASES instead.
>  DeprecationWarning
> /usr/lib/python2.7/site-packages/Django-1.3.1-py2.7.egg/django/db/
> __init__.py:60: DeprecationWarning: Short names for ENGINE in database
> configurations are deprecated. Prepend default.ENGINE with
> 'django.db.backends.'
>  DeprecationWarning
> Creating tables ...
> Upgrading Review Board from 1.6 to 1.6.1
> There are unapplied evolutions for accounts.
> There are unapplied evolutions for reviews.
> There are unapplied evolutions for scmtools.
> Project signature has changed - an evolution is required
> Installing custom SQL ...
> Installing indexes ...
> No fixtures found.
> Error: Error applying evolution: (1060, "Duplicate column name
> 'is_private'")
> [root@localhost conf.d]#
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to