On Mon, 2011-10-03 at 19:09 +0530, jack jack wrote:
> I added following entries as suggested.
> Anonymous User Mask: uid=%s,CN=ldapquery,OU=Service
> Accounts,OU=Exception Accounts,DC=na,DC=companyname,DC=com

Do not use %s. It must be a specific user.

> Anonymous User Password: <password>
> After saving the page the password field got empty.

That sounds like a bug to me. Christian?

> Result: Not able to login using LDAP user: jackj  
> Note: I am expecting once user jackj login into the RB it should have
> user id RB database. Please correct me if i am wrong
> In the reviewboard log i am getting error message as
> 2011-10-03 06:29:59,909 - WARNING - LDAP error: {'desc': "Can't
> contact LDAP server"}

"Can't contact LDAP server" usually means one of the following:

1) The LDAP URI is incorrect. Check for typos. Also, it could mean that
the LDAP server isn't running or listening on the specified port.

2) The LDAP server requires encryption and you aren't allowing it (if
the port is SSL-enabled, you need to use ldaps:// for the URI, not
ldap://. If it's not SSL-enabled, you may need to enable TLS)

3) If you were using encryption, it could be a bad certificate chain,
and I don't think ReviewBoard allows you to manage this right now. It
would require being able to specify a CA certificate for verification
(or setting the validation to be permissive).

Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to