If you replace the config file generated by ReviewBoard installation. It
will work file. Modifying the configuration will have other problems.
Will you try to install it in the root path rather than a subdirectory path?

If you root drive is /var/www/html/

Your config value will be
WSGIScriptAlias "/" "/var/www/html/htdocs/reviewboard.wsgi"

Please let me know if you still have problems.


On Tue, Oct 11, 2011 at 4:54 PM, Jon <jonkei...@gmail.com> wrote:

> Yes, I am encountering similar problems.
> I opened a thread but no one replied.
> I would love to get a working configuration that will allow me to set
> up review board as a non root site.
>
> On Oct 11, 11:59 am, Rohini Kumar Tharigonda <rok...@gmail.com> wrote:
> > I am still having the same problem.
> > Any one have the same problem ?
> >
> > On Sep 12, 10:40 am, Rohini Kumar Tharigonda <rok...@gmail.com> wrote:
> >
> >
> >
> >
> >
> >
> >
> > > The following is my configuration..
> > > You can see that i commented   #WSGIScriptAlias "/reviewboard/" "/var/
> > > www/reviewboard/htdocs/reviewboard.wsgi".
> > > After doing this it started working.
> >
> > > <VirtualHost *:80>
> > >     ServerName localhost
> > >     DocumentRoot "/var/www/reviewboard/htdocs"
> >
> > >     # Error handlers
> > >     ErrorDocument 500 /errordocs/500.html
> >
> > >     WSGIPassAuthorization On
> > >     #WSGIScriptAlias "/reviewboard/" "/var/www/reviewboard/htdocs/
> > > reviewboard.wsgi"
> > >     WSGIScriptAlias "/" "/var/www/reviewboard/htdocs/reviewboard.wsgi"
> >
> > >     <Directory "/var/www/reviewboard/htdocs">
> > >         AllowOverride All
> > >     </Directory>
> >
> > >     # Alias static media requests to filesystem
> > >     Alias /reviewboard/media "/var/www/reviewboard/htdocs/media"
> > >     Alias /reviewboard/errordocs "/var/www/reviewboard/htdocs/
> > > errordocs"
> > >     Alias /reviewboard/favicon.ico "/var/www/reviewboard/htdocs/media/
> > > rbcommons/images/favicon.png"
> > > </VirtualHost>
> >
> > > On Sep 11, 11:37 am, Kannaiyan Natesan <gbpnk...@gmail.com> wrote:
> >
> > > > This is my working version.
> >
> > > > <VirtualHost *:80>
> > > >         ServerName internal.nq.corp
> > > >         DocumentRoot "/var/www/html/htdocs"
> >
> > > >         # Error handlers
> > > >         ErrorDocument 500 /errordocs/500.html
> >
> > > >         WSGIPassAuthorization On
> > > >         WSGIScriptAlias "/" "/var/www/html/htdocs/reviewboard.wsgi"
> >
> > > >         <Directory "/var/www/html/htdocs">
> > > >                 AllowOverride All
> > > >         </Directory>
> >
> > > >         # Alias static media requests to filesystem
> > > >         Alias /media "/var/www/html/htdocs/media"
> > > >         Alias /errordocs "/var/www/html/htdocs/errordocs"
> > > > </VirtualHost>
> >
> > > > On Sun, Sep 11, 2011 at 12:20 AM, Rohini Kumar Tharigonda
> > > > <rok...@gmail.com>wrote:
> >
> > > > > Following is the configuration in
> > > > > /var/www/reviewboard/conf/apache-wsgi.conf
> >
> > > > > <VirtualHost *:80>
> > > > >    ServerName localhost
> > > > >    DocumentRoot "/var/www/reviewboard/htdocs"
> >
> > > > >    # Error handlers
> > > > >    ErrorDocument 500 /errordocs/500.html
> >
> > > > >    WSGIPassAuthorization On
> > > > >     WSGIScriptAlias "/reviewboard/" "/var/www/reviewboard/htdocs/
> > > > > reviewboard.wsgi"
> >
> > > > >     <Directory "/var/www/reviewboard/htdocs">
> > > > >        AllowOverride All
> > > > >    </Directory>
> >
> > > > >    # Alias static media requests to filesystem
> > > > >    Alias /reviewboard/media "/var/www/reviewboard/htdocs/media"
> > > > >    Alias /reviewboard/errordocs "/var/www/reviewboard/htdocs/
> > > > > errordocs"
> > > > >    Alias /reviewboard/favicon.ico
> "/var/www/reviewboard/htdocs/media/
> > > > > rbcommons/images/favicon.png"
> > > > > </VirtualHost>
> >
> > > > > i did
> >
> > > > > ln -s /var/www/reviewboard/conf/apache-wsgi.conf /etc/httpd/conf.d/
> > > > > reviewboard.conf
> >
> > > > > It was not working .
> > > > > Then i changed
> > > > >  WSGIScriptAlias "/reviewboard/" "/var/www/reviewboard/htdocs/
> > > > > reviewboard.wsgi"
> > > > > to
> > > > >  WSGIScriptAlias "/" "/var/www/reviewboard/htdocs/reviewboard.wsgi"
> >
> > > > > It started working when i typed http:/localhost/reviewboard/
> >
> > > > > when i type http:/localhost/  , the should actually show fedora
> error
> > > > > page.
> > > > > Instead of that , it shows up reviewboard with error message.
> >
> > > > > On Sep 10, 11:13 pm, Christian Hammond <chip...@chipx86.com>
> wrote:
> > > > > > Can you attach your Apache configuration?
> >
> > > > > > Christian
> >
> > > > > > On Saturday, September 10, 2011, Rohini Kumar Tharigonda <
> > > > > rok...@gmail.com>
> > > > > > wrote:
> >
> > > > > > > Hi,
> > > > > > > I installed reviewboard 1.6.1 on fedora 15.
> > > > > > > I  set site path to /var/www/reviewboard/, site root
> /reviewboard/ .
> > > > > > > My expectation  is , when i typehttp://localhost/reviewboard/i
> > > > > > > should get reviewboard
> > > > > > > home page. But it is not working .
> >
> > > > > > > When i changed
> > > > > > >  WSGIScriptAlias "/reviewboard/" "/var/www/reviewboard/htdocs/
> > > > > > > reviewboard.wsgi"
> > > > > > > to
> > > > > > >    WSGIScriptAlias "/"
> "/var/www/reviewboard/htdocs/reviewboard.wsgi"
> > > > > > > in apache configuration it started working .
> >
> > > > > > > When i typehttp://localhost.
> > > > > > > It is getting redirected to reviewboard page and displays the
> > > > > > > following message.
> >
> > > > > > > The page you were looking for does not exist.
> > > > > > > If you're pretty sure this page does exist, try logging in and
> trying
> > > > > > > again.
> >
> > > > > > > When i typehttp://localhost. I do not want that reviewboard to
> show
> > > > > > > up.
> > > > > > > What do i need to do ?
> > > > > > > Thanks,
> > > > > > > Rohini Kumar
> >
> > > > > > > --
> > > > > > > Want to help the Review Board project? Donate today at
> >
> > > > > >http://www.reviewboard.org/donate/> Happy user? Let us know
> athttp://
> > > > >www.reviewboard.org/users/
> > > > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > > > To unsubscribe from this group, send email to
> >
> > > > > > reviewboard+unsubscr...@googlegroups.com> For more options,
> visit this
> > > > > group at
> >
> > > > > >http://groups.google.com/group/reviewboard?hl=en
> >
> > > > > > --
> > > > > > --
> > > > > > Christian Hammond - chip...@chipx86.com
> > > > > > Review Board -http://www.reviewboard.org
> > > > > > VMware, Inc. -http://www.vmware.com
> >
> > > > > --
> > > > > Want to help the Review Board project? Donate today at
> > > > >http://www.reviewboard.org/donate/
> > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > To unsubscribe from this group, send email to
> > > > > reviewboard+unsubscr...@googlegroups.com
> > > > > For more options, visit this group at
> > > > >http://groups.google.com/group/reviewboard?hl=en
> >
> > > > --
> > > > +1-650-605-3290
> > > > The best things in life are free
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>



-- 
+1-650-605-3290
The best things in life are free

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to