You should use the username and password you set up when you installed
Review Board.

Are you using any type of auth backend?

I believe there are issues with HTTP Basic Auth and fastcgi with Apache out
of the box. You should search and see if there are directives you need to
add to your Apache config file.

We recommend wsgi. Fastcgi is deprecated, as there have been issues that
have cropped up in the past and it tends to not perform as well.

Christian



On Thursday, November 10, 2011, MonicaS <castaneda.mon...@gmail.com> wrote:
> I forgot to add the debug information from the post-review command.
>
>>>> RBTools 0.3.4
>>>> Home = D:\USERS\winuser\Application Data
>>>> svn info
>>>> diff --version
>>>> repository info: Path: svn+ssh://reposerver/repo-path/dir1/dir2
>  Base path: /branches/Alpha1/include, Supports changesets: False
>>>> svn propget reviewboard:url
D:\svn\repo-path\dir1\dir2\braches\Alpha1\include
>>>> HTTP GETting api/
>>>> HTTP GETting http://eng-build2-f9/api/info/
>>>> Using the new web API
>>>> svn diff --diff-cmd=diff
>>>> svn info nrdef.h
>>>> svn info nsdefines.h
>>>> svn info nskeydef.h
>>>> svn info nrdef.h
>>>> svn info nrdef.h
>>>> svn info nrdef.h
>>>> svn info nsdefines.h
>>>> svn info nsdefines.h
>>>> svn info nsdefines.h
>>>> svn info nskeydef.h
>>>> svn info nskeydef.h
>>>> svn info nskeydef.h
>>>> HTTP GETting http://eng-build2-f9/api/repositories/
>>>> HTTP GETting http://eng-build2-f9/api/repositories/2/
>>>> HTTP GETting http://eng-build2-f9/api/repositories/2/info/
>>>> HTTP GETting http://eng-build2-f9/api/repositories/1/
>>>> HTTP GETting http://eng-build2-f9/api/repositories/1/info/
>>>> repository info: Path: svn+ssh://svnusername@reposerver
/repo-path/dir1/dir2
> winusername, Base path: /branches/Alpha1/include, Supports changesets:
> False
>>>> Attempting to create review request on
svn+ssh://svnusername@dreposerver/repo-path/dir1/dir2 for None
>>>> HTTP POSTing to http://eng-build2-f9/api/review-requests/:
{'repository': u svn+ssh://svnuser@reposerver/repo-path/dir1/dir2'}
> ==> HTTP Authentication Required
> Enter authorization information for "Web API" at eng-build2-f9
> Username:
>
> On Nov 10, 12:18 pm, MonicaS <castaneda.mon...@gmail.com> wrote:
>>  I need to present a reviewBoard demo to different applications teams,
>> I create a test environment with ReviewBoard 1.5.6 on a fedora box.
>>
>> The web server is working I was able to add a repositories and manual
>> diffs but when I tried to use post review I got problems.
>>
>> My subversion server is on SunOn
>> My ReviewBoard is on Fedora, Apache, FastCGI
>> The Client I'm working on right now is Windows XP. I'll need to test
>> on Linux and MAC later.
>>
>> I configured some users on reviewBoard
>> I have different users to access the repository
>> My windows user is different from the 2 above.
>>
>> To install post-review on Windows,
>>   Installed Active Python
>>   installed RBToolds
>>   Installed GNU Diff (setup package from GNUWIN32)
>>
>> I checkout and modify some files from subversion
>> Add the property to the folder: svn propset
reviewboard:urlhttp://eng-build2-f9
>> .
>>
>> When I tried post-review, I'm getting:
>> ==> HTTP Authentication Required
>> Enter authorization information for "Web API" at eng-build2-f9
>> Username:
>> Password:
>> Error creating review request: You are not logged in (HTTP 401, API
>> Error 103)
>>
>> Which username should I use there? I'm configure apache but I don't
>> know it very well.
>>
>> Could you help me please?
>
> --
> Want to help the Review Board project? Donate today at
http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
http://groups.google.com/group/reviewboard?hl=en

-- 
-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to