No, there's no way to do that. We wouldn't have enough info on the credentials 
to match up the user, and it'd be even less secure.

The best thing I can recommend is, if the repo has any SSH access, is to 
generate an SSH key in Review Board and grant read-only permissions for it on 
the server.

Christian


On Nov 17, 2011, at 5:48, Sharmila Saraswathi <sharmila...@gmail.com> wrote:

> Thanks Christian. I switched my installation to Linux RHEL and everything 
> worked fine.
> Installations were all fine and the page came out cool.
> 
> I had some queries on the same.
> Primarily I switched to the recent version of Reviewboard to check on the 
> functionality of access-control.
> 
> Can you please let me know if by any means the below feature is available or 
> it can be done.
> 
> My RB server is running a say user x.
> In some cases of ours, the user x itself will not have permissions to do any 
> svn operations on the repository. The repository is very much secured from 
> the user who is running the server itself.
> Is there any means that I can do my svn operations as the remote user who is 
> doing a post_review or the user who is creating/updating the reviewrequest 
> instead of the user x who is running the server as user x will not have 
> permissions to update/diff the repo.
> 
> Please let me know if I have to give more details on the same.
> Before switching on to any other solution, I wanted to get to know from RB 
> itself it there is an existing feature or if we can tweak RB code by some 
> means for the same.
> 
> thanks-
> Sharmila
> 
> 
> 
> On Tue, Nov 15, 2011 at 2:38 PM, Christian Hammond <chip...@chipx86.com> 
> wrote:
> What pycrypto error did you hit? Regardless of how you install, it should be 
> installing pycrypto (it's very much required).
> 
> I don't know what the issue is, but it looks as if somehow, not all of Review 
> Board is being found. Try:
> 
>     $ python
>     >>> import reviewboard
>     >>> print reviewboard.__file__
>     >>> from reviewboard.reviews.models import Group
> 
> See what that says, and if you get an error.
> 
> 
> Christian
> 
> -- 
> Christian Hammond - chip...@chipx86.com
> Review Board - http://www.reviewboard.org
> VMware, Inc. - http://www.vmware.com
> 
> 
> On Mon, Nov 14, 2011 at 7:32 PM, Sharmila Saraswathi <sharmila...@gmail.com> 
> wrote:
> Thanks Christian for the reply.
> easy_install doesn't work due to an issue with pycrypto. 
> (http://code.google.com/p/reviewboard/issues/detail?id=2346)
> So got pycrypto installed explicitly and then tried for the setup.py in 
> Reviewboard that takes care of all the dependencies installation.
> The dependencies installation went on fine. But when I did rb-site install it 
> failed with the below error.
> 
> Python version is 2.6 and database is mysql.
> Any idea? Can you please help us on the same.
> 
> thanks-
> Sharmila
> 
> On Tue, Nov 15, 2011 at 1:41 AM, Christian Hammond <chip...@chipx86.com> 
> wrote:
> Looks like some strange installation issue. You should be installing using 
> easy_install, though.
> 
> What version of Python, and which database?
> 
> Christian
> 
> -- 
> Christian Hammond - chip...@chipx86.com
> Review Board - http://www.reviewboard.org
> VMware, Inc. - http://www.vmware.com
> 
> 
> 
> On Mon, Nov 14, 2011 at 7:58 AM, Sharmila Saraswathi <sharmila...@gmail.com> 
> wrote:
> Hi RB guys,
> I am using the recent version of RB 1.6.2. Also tried the same in RB 1.6.1
> These are the steps that I did.
> 1. Downloaded the RB recent version
> 2. Installed them with setup.py
> 3. Then used rb-site install /rb-site upgrade
> 4. Both failed with the below error
> 5. I am installing this in Linux as in solaris I had issues with using 
> pycrypto.
> This is the error that I am getting when using rb-site install on the newly 
> setup version.
> >>>
> * Installing the site...
> Building site directories ... OK
> Building site configuration files ... OK
> Error: One or more models did not validate:
> scmtools.repository: 'review_groups' has an m2m relation with model 
> reviews.Group, which has either not been installed or is abstract.
> >>>
> 
> Can you please let me know from where the error should have occured and  why 
> is this happening ?
> 
> Should I get something else installed also ?
> thanks in advance for ur help-
> Sharmila
> 
> 
> 
> 

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to