Hey Chris,

Unfortunately, I'm not really sure what's wrong, but it still sounds like a
configuration issue. We definitely call initVM, but it looks like it's
failing in the second case.

In the first, I think what's happening is that we try to call initVM, but
we ignore the ValueError (since we may get this if we call initVM more than
once, which can easily happen with searches), and it's probably upset after
because initVM didn't actually succeed.

Shame that the ValueError doesn't have more information... Which JVM are
you using? I'd make sure it's Sun's/Oracle's.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Tue, Feb 21, 2012 at 11:56 PM, Chris Baron <topher.ba...@gmail.com>wrote:

> I made some progress.
>
> I updated my /etc/ld.so.conf so that it found the java .so files, then
> I ran ldconfig.
>
> Now, when I use the search via the web I get the following traceback :
>
> Traceback (most recent call last):
>
>  File "/usr/local/lib/python2.7/site-packages/Django-1.3.1-py2.7.egg/
> django/core/handlers/base.py", line 111, in get_response
>    response = callback(request, *callback_args, **callback_kwargs)
>
>  File "/usr/local/lib/python2.7/site-packages/ReviewBoard-1.6.3-
> py2.7.egg/reviewboard/accounts/decorators.py", line 21, in _check
>    return view_func(*args, **kwargs)
>
>  File "/usr/local/lib/python2.7/site-packages/ReviewBoard-1.6.3-
> py2.7.egg/reviewboard/reviews/views.py", line 1100, in search
>    store = lucene.FSDirectory.getDirectory(index_file, False)
>
> RuntimeError: initVM() must be called first
>
>
>
>
> When I try to run
>
> user@rb:/> sudo rb-site manage /var/www/rb.corp.good.com/ index -- --
> full
> There was an error trying to initialize the HPI library.
> Traceback (most recent call last):
>   File "/usr/local/bin/rb-site", line 8, in <module>
>    load_entry_point('ReviewBoard==1.6.3', 'console_scripts', 'rb-
> site')()
>  File "/usr/local/lib/python2.7/site-packages/ReviewBoard-1.6.3-
> py2.7.egg/reviewboard/cmdline/rbsite.py", line 1745, in main
>    command.run()
>  File "/usr/local/lib/python2.7/site-packages/ReviewBoard-1.6.3-
> py2.7.egg/reviewboard/cmdline/rbsite.py", line 1679, in run
>    site.run_manage_command(args[0], args[1:])
>  File "/usr/local/lib/python2.7/site-packages/ReviewBoard-1.6.3-
> py2.7.egg/reviewboard/cmdline/rbsite.py", line 469, in
> run_manage_command
>    execute_manager(reviewboard.settings, [__file__, cmd] + params)
>  File "/usr/local/lib/python2.7/site-packages/Django-1.3.1-py2.7.egg/
> django/core/management/__init__.py", line 438, in execute_manager
>    utility.execute()
>  File "/usr/local/lib/python2.7/site-packages/Django-1.3.1-py2.7.egg/
> django/core/management/__init__.py", line 379, in execute
>    self.fetch_command(subcommand).run_from_argv(self.argv)
>  File "/usr/local/lib/python2.7/site-packages/Django-1.3.1-py2.7.egg/
> django/core/management/__init__.py", line 261, in fetch_command
>    klass = load_command_class(app_name, subcommand)
>  File "/usr/local/lib/python2.7/site-packages/Django-1.3.1-py2.7.egg/
> django/core/management/__init__.py", line 67, in load_command_class
>    module = import_module('%s.management.commands.%s' % (app_name,
> name))
>  File "/usr/local/lib/python2.7/site-packages/Django-1.3.1-py2.7.egg/
> django/utils/importlib.py", line 35, in import_module
>    __import__(name)
>  File "/usr/local/lib/python2.7/site-packages/ReviewBoard-1.6.3-
> py2.7.egg/reviewboard/reviews/management/commands/index.py", line 16,
> in <module>
>    lucene.initVM(lucene.CLASSPATH)
> ValueError: An error occurred while creating Java VM
>
>
> On Feb 22, 1:03 am, Chris Baron <topher.ba...@gmail.com> wrote:
> > Hi,
> >
> > I've installed ReviewBoard.  I've migrated an old installation to
> > reviewboard.  Everything is running smoothly except search.
> >
> > I installed a PyLucene rpm on my SuSE 1..4 OS using yast.  python-
> > pylucene-2.4.1-2.4.x86_64.rpm  I'm running python 2.7.
> >
> > When at a python terminal :
> > import imp>>> imp.find_module("lucene")
> >
> > (None, '/usr/lib64/python2.7/site-packages/lucene', ('', '', 5))
> >
> > When I try to fun my first search index :
> > user@rb:~> rb-site manage /var/www/rb.corp.good.com/ index -- --full
> > PyLucene is required to build the search index.
> >
> > When I try to search on the web site an error message is emailed to
> > me :
> >
> > Traceback (most recent call last):
> >
> >   File "/usr/local/lib/python2.7/site-packages/Django-1.3.1-py2.7.egg/
> > django/core/handlers/base.py", line 111, in get_response
> >     response = callback(request, *callback_args, **callback_kwargs)
> >
> >   File "/usr/local/lib/python2.7/site-packages/ReviewBoard-1.6.3-
> > py2.7.egg/reviewboard/accounts/decorators.py", line 21, in _check
> >     return view_func(*args, **kwargs)
> >
> >   File "/usr/local/lib/python2.7/site-packages/ReviewBoard-1.6.3-
> > py2.7.egg/reviewboard/reviews/views.py", line 1087, in search
> >     import lucene
> >
> >   File "/usr/lib64/python2.7/site-packages/lucene/__init__.py", line
> > 2, in <module>
> >     import os, _lucene
> >
> > ImportError: libjvm.so: cannot open shared object file: No such file
> > or directory
> >
> > Any suggestions?  Thanks in advance,
> >
> > Chris
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to