Hi Stephen,

It's possible it runs with 1.2.x, but there is absolutely no testing of
this on our end anymore. 1.3 is compatible with 1.2.x, but I understand you
have certain guidelines to work with.

This is a difficult issue, but we basically can't stand still on our end.
It was a mistake for us not to just require 1.3 in 1.6.0, but from here on
out, that may just need to be our requirement. Another issue is that we
have dependencies that themselves require Django, and we may end up being
forced into some versions of Django before long.

We've talked internally about ways to speed up our releases, and likely in
1.7.x we'll end up staying on that release for some time, with new features
coming in, until the massive amount of work that 2.0 will need is done.
That will also mean the occasional dependency bump, which may include
Django versions. Perhaps we'd move to something closer to Chrome, with more
frequent releases without major version bumps.

I'd say on your end, for now, do some testing to see if it works with
1.2.x, and then perhaps patch your copy that you ship. If it works, maybe
we can roll back our version, but I'm certain this will come up again. If
the Django version can't be updated for RHEL/CentOS users, it may be
possible that we'll just have to cut off certain point releases for
RHEL/CentOS releases, and give more advanced users who know they want to
upgrade access to some repo that contains the version with a newer Django,
or just let them upgrade by themselves the old-fashioned way.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Mon, Feb 27, 2012 at 7:37 AM, Stephen Gallagher <
step...@gallagherhome.com> wrote:

> On Mon, 2012-02-27 at 00:53 -0800, Christian Hammond wrote:
> > Hey everyone,
> >
> > Tonight we pushed out releases for Review Board 1.6.4 and RBTools
> > 0.4.0. There's a lot in each release, so it's worth reading the
> > release notes and news posts.
>
> The requires.txt for ReviewBoard 1.6.4 claims that it now requires
> Django 1.3.1 or higher in order to run. Is this a true requirement, or
> will it still run against Django 1.2.6? (If it's not possible to run
> against 1.2.6, that's going to cause some serious issues with
> RHEL/CentOS 6 deployments)
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to