On Fri, Mar 2, 2012 at 2:38 PM, Anton Cohen <an...@antoncohen.com> wrote:

> On Fri, Mar 2, 2012 at 10:58 AM, Tucker <j...@gmail.com> wrote:
>> Should I do a whole new install and migrate the DB?
>> On Tue, Feb 28, 2012 at 2:43 PM, Tucker <j...@gmail.com> wrote:
>> > I decided to try and build pylucene again on CentOs 5.2.  I kept
>> > running into problems with python2.4, so I built jcc against python2.6
>> > (ActivePython).  I eventually got it working (using openjdk-1.6 and a
>> > modern version of ant) but ReviewBoard doesn't seem to agree and I
>> > can't enable search.  Since I built jcc with python2.6 and installed
>> > ReviewBoard using python2.4. this makes sense.
> If you can migrate to CentOS 6 your life will be easier.
> If you have to stay with CentOS 5, you can't "upgrade" Python, as in you
> can't replace Python 2.4 (/usr/bin/python). You can install Python 2.6
> in parallel. The EPEL <http://fedoraproject.org/wiki/EPEL> repository has
> a python26 package, and some dependencies you'll need like
> python26-distribute, python26-mysqldb,
> and python26-mod_wsgi. python26-distribute should provide a
> python26 specific version of pip/easy_install you can try to use to install
> Review Board. I've never tried it, but it's probably possible. Again,
> CentOS 6 is easier.
> -Anton
This is an important point.

We'll make a more formal announcement in time, but the next version of
Review Board will not be compatible with Python 2.4. So it's best to get a
2.6 or 2.7 setup if at all possible.


Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com

Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to