Hi Mark,

This is one of those really annoying and confusing Windows issues that I have 
no answer to. Hopefully someone else on this list does.

However, I *strongly* recommend ditching the Windows install and instead 
installing on Linux (Ubuntu or Fedora), either on a physical box or in a VM. 
You'll have an easier experience, fewer problems, better performance, and 
guaranteed compatibility with future features and releases (which we're not 
guaranteeing for Windows).

Christian



On May 23, 2012, at 20:11, "mark.har...@arcinnovations.co.nz" 
<mark.har...@arcinnovations.co.nz> wrote:

> I get the above error when I try and access a recently installed
> version of ReviewBoard.
> 
> I am running Windows 7, Apache httpd server v 2.2.22, ReviewBoard v
> 1.6. Everything is 32-bit as I was experiencing real problems when
> using 64-bit versions of the installed components.
> 
> Looking at the "access.log" file, it seems like there is an error
> occurring somewhere:
> 
> 127.0.0.1 - - [24/May/2012:14:53:37 +1200] "GET / HTTP/1.1" 500 1540
> 127.0.0.1 - - [24/May/2012:14:53:37 +1200] "GET /favicon.ico HTTP/1.1"
> 404 209
> 
> I have amended the server's "httpd.conf" file so that the LogLevel is
> set to debug. There are no errors raised when either the server starts
> up or I try and access ReviewBoard via a browser and get the "taking a
> nap" screen.
> 
> I don't know whether it is related but the following errors appear
> when I shut down the server:
> 
> [info] [client 127.0.0.1] mod_wsgi (pid=4684, process='',
> application='arc-review-board:8666|'): Loading WSGI script
> '<directory>/htdocs/reviewboard.wsgi'., referer: http://localhost:8666/
> [error] [client 127.0.0.1] mod_wsgi (pid=4684): Exception occurred
> processing WSGI script '<directory>/htdocs/reviewboard.wsgi'.,
> referer: http://localhost:8666/
> [error] [client 127.0.0.1] Traceback (most recent call last):,
> referer: http://localhost:8666/
> [error] [client 127.0.0.1]   File "<Python directory>\\lib\\site-
> packages\\django-1.3.1-py2.7.egg\\django\\core\\handlers\\wsgi.py",
> line 250, in __call__, referer: http://localhost:8666/
> [error] [client 127.0.0.1]     self.load_middleware(), referer:
> http://localhost:8666/
> [error] [client 127.0.0.1]   File "<Python directory>\\lib\\site-
> packages\\django-1.3.1-py2.7.egg\\django\\core\\handlers\\base.py",
> line 47, in load_middleware, referer: http://localhost:8666/
> [error] [client 127.0.0.1]     raise
> exceptions.ImproperlyConfigured('Error importing middleware %s: "%s"'
> % (mw_module, e)), referer: http://localhost:8666/
> [error] [client 127.0.0.1] ImproperlyConfigured: Error importing
> middleware reviewboard.admin.middleware: "DLL load failed: A dynamic
> link library (DLL) initialization routine failed.", referer:
> http://localhost:8666/
> 
> I have also changed the the site's "settings_local.py" file to include
> the line "DEBUG = True" but no output is added to the logs directory.
> 
> Thanks for any assistance.
> 
> -- 
> Want to help the Review Board project? Donate today at 
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to 
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at 
> http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to