Can you try running:

    $ rb-site manage /path/to/site/dir shell
    >>> from reviewboard.scmtools.models import Tool
    >>> Tool.objects.all()

And paste the results?

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Mon, Jun 11, 2012 at 2:34 AM, Dan Miller <email.mille...@gmail.com>wrote:

> Restarted the webserver and nothing changed there.  No Javascript
> errors are coming in the UI
>
> In Authentication I see:
>
> Standard Registration
> Active Directory
> LDAP
> NIS
> X.509 Public Key
> Legacy Authentication Module
>
> Dan
>
> On Jun 7, 9:42 pm, Christian Hammond <chip...@chipx86.com> wrote:
> > You shouldn't need to reinstall or anything if you fix PySVN. Maybe just
> > restart the web server.
> >
> > The JavaScript errors would be in your browser when you reach the page.
> > It's possible that's causing it, but my guess would be it's some issue
> with
> > how what's called "Python entrypoints" are registered.
> >
> > Actually, let's check that. Can you also go into the Authentication
> > Settings and see if NIS, LDAP, and ActiveDirectory are options?
> >
> > Christian
> >
> > --
> > Christian Hammond - chip...@chipx86.com
> > Review Board -http://www.reviewboard.org
> > VMware, Inc. -http://www.vmware.com
> >
> >
> >
> > On Thu, Jun 7, 2012 at 4:49 AM, Dan Miller <email.mille...@gmail.com>
> wrote:
> > > Understood about OEL support.  I kind of assumed it would work the
> > > same as RHEL but that might be true....
> >
> > > Where can I check for the JavaScript errors?  I don't remember seeing
> > > any during installation, were they logged anywhere?
> >
> > > I installed RB 1.6.7.1.
> >
> > > I thought I may have messed up the pysvn installation part.  Assuming
> > > I have corrected it now, do I just need to create a new ReviewBoard
> > > site via rb-site install /var/www/newsite?  Would that populate the
> > > dropdown list correctly?
> >
> > > Dan
> >
> > > On Jun 6, 1:53 pm, Christian Hammond <chip...@chipx86.com> wrote:
> > > > Hi Dan,
> >
> > > > This sounds like the installation once again partially failed. The
> list
> > > of
> > > > repository types is populated during install, and should be
> available in
> > > > that dropdown, but that may not be happening.
> >
> > > > Just to check, can you see if there are any JavaScript errors? If
> not,
> > > then
> > > > it was the installation.
> >
> > > > I should point out that we don't officially support Oracle
> Enterprise.
> > > > Given your previous e-mail and this one, it sounds like there may be
> some
> > > > issues...
> >
> > > > What version of Review Board did you install?
> >
> > > > Christian
> >
> > > > --
> > > > Christian Hammond - chip...@chipx86.com
> > > > Review Board -http://www.reviewboard.org
> > > > VMware, Inc. -http://www.vmware.com
> >
> > > > On Wed, Jun 6, 2012 at 10:08 AM, Dan Miller <
> email.mille...@gmail.com
> > > >wrote:
> >
> > > > > So I gave up on my previous installation that just wasn't
> returning my
> > > > > web requests.  No idea what was going on there, but I switched to a
> > > > > new machine running Oracle Enterprise Linux 5 this time.
> >
> > > > > I have RB up now and the web requests are working fine.  My problem
> > > > > now is that when I go to setup my source control repository the Add
> > > > > repository page has a blank "Repository Type" dropdown list.
> >
> > > > > I'm using subversion so my guess is that there is some problem
> with my
> > > > > pysvn installation.  I wasn't able to find an rpm package for my
> > > > > distro so I built it manually.  I downloaded 1.7.6 from
> > > > >http://pysvn.tigris.org/project_downloads.htmlandfollowed the
> > > > > instructions there.  The tests that I built seem to work so I'm not
> > > > > sure what could be wrong.
> >
> > > > > Does anyone have ideas about how I can troubleshoot this.  Am I on
> the
> > > > > right track that it's my pysvn installation that is the problem or
> is
> > > > > there some other cause of having an empty dropdown list there?
> >
> > > > > Thanks!
> >
> > > > > Dan
> >
> > > > > --
> > > > > Want to help the Review Board project? Donate today at
> > > > >http://www.reviewboard.org/donate/
> > > > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > > > -~----------~----~----~----~------~----~------~--~---
> > > > > To unsubscribe from this group, send email to
> > > > > reviewboard+unsubscr...@googlegroups.com
> > > > > For more options, visit this group at
> > > > >http://groups.google.com/group/reviewboard?hl=en-Hide quoted text -
> >
> > > > - Show quoted text -
> >
> > > --
> > > Want to help the Review Board project? Donate today at
> > >http://www.reviewboard.org/donate/
> > > Happy user? Let us know athttp://www.reviewboard.org/users/
> > > -~----------~----~----~----~------~----~------~--~---
> > > To unsubscribe from this group, send email to
> > > reviewboard+unsubscr...@googlegroups.com
> > > For more options, visit this group at
> > >http://groups.google.com/group/reviewboard?hl=en
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to