Hi Christian,

I installed a reviewboard instance following 
http://www.reviewboard.org/docs/manual/dev/admin/installation/linux/, and 
it seemed to work fine, but I cannot find out a way to add a github repo to 
the review board.

I can select GitHub as Hosting service, but I cannot choose an existing 
github account but always "link a new account" in account field. I also 
tried to give account username/password for "link a new account", still 
failed.

Any suggestion?

Thanks,
Jun

On Wednesday, July 4, 2012 3:27:37 PM UTC+8, Christian Hammond wrote:
>
> Hi,
>
> GitHub recently removed support for their old API, which is what we were 
> using before. In order to use Review Board with GitHub now, you'll need to 
> grab RB 1.6.9 and re-configure the repository as GitHub again. It will then 
> work fine.
>
> Christian
>
> -- 
> Christian Hammond - chip...@chipx86.com
> Review Board - http://www.reviewboard.org
> VMware, Inc. - http://www.vmware.com
>
>
> On Wed, Jul 4, 2012 at 12:24 AM, humble <eyuw...@gmail.com> wrote:
>
>> Hi,
>>
>> This may seem to be an easy question, but it doesn't work for me. 
>>
>> I registered a test repo on github: 
>> g...@github.com:MY_GITHUB_ID/MY_TEST_REPO.git 
>>
>> The Review Board version I'm using is 1.6.1. I went to the admin page to 
>> register that new repository. I entered the following info:
>>
>> Hosting service: GitHub
>> Repository type: Git
>> Project owner: MY_GITHUB_ID
>> Project name: MY_TEST_REPO
>>
>> Then I clicked save. Review Board shows the repository has been 
>> registered successfully.
>>
>> Next, I did a initial commit to add a README file with some text in it. 
>> Pushed that commit.
>>
>> Next, I made a local commit, and I tried to use post-review to create a 
>> code review. However, I'm always getting  the following error:
>>
>> >>> Got API Error 207 (HTTP code 400): The file was not found in the 
>> repository
>> >>> Error data: {u'stat': u'fail', u'file': u'master.cfg', u'err': 
>> {u'msg': u'The file was not found in the repository', u'code': 207}, 
>> u'revision': u'd017cb810fc6cd3c4b114bcc82ad07cc35d88565'}
>>
>> Error uploading diff
>>
>> Your review request still exists, but the diff is not attached.
>>
>>
>> Is there anything that I missed? Please help me.
>>
>> Thanks
>>
>>
>>  -- 
>> Want to help the Review Board project? Donate today at 
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to 
>> reviewboard+unsubscr...@googlegroups.com
>> For more options, visit this group at 
>> http://groups.google.com/group/reviewboard?hl=en
>
>
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to