Hi,

For the directory indexing, the DocumentRoot was specifying your sites as the 
default document root, which is why you were seeing indexes.

What does the Apache error log have to say about your connection error? After 
including the config file, is Apache even able to start?

Christian



On Jul 10, 2012, at 1:38, Maliken <pgr...@gmail.com> wrote:

> Hello I'm having trouble trying to get reviewboard working on my mac 
> mini(snow leopard).  I've successfully installed all of the 3rd party stuff 
> and am at this page  Creating The Review Site.  I've been able to run rb-site 
> install /var/www/reviews.example.com successfully and it creates all of the 
> files etc.  I've successfully changed all of the permissions to _www user. 
> Now when I view my site all I see is an "Index Of" page with the folders that 
> are included under the instal directory for reviewboard.  However, I only see 
> the directory listing when I DO NOT have the generated .conf symbolic link 
> placed in etc/apache2/other.  When I place the .conf file in that 
> directory(which is where others have mentioned they've put it when on OSX) 
> then I get the following:
> "Oops! Google Chrome could not connect"
> 
> 
> You might mention something about removing default file 
> from"/etc/apache2/sites-enabled".  However, I cannot find any corresponding 
> file on MacOSX.  And regardless my problem is when I put the symbolic link in 
> the folder mentioned above.
> 
> Install Parameters:
> Domain Name: www.mysite.com
> root path: /
> media url: media/
> database type: sqlite3(even though I have mysql it doesn't show up in the 
> list.... weird)
> Cache type: memcached
> memcache server: default value thingy
> web server: apache
> Python Loader: wsgi(i've also tried w/ fastcgi but i have exactly the same 
> problem as mentioned above)
> ...
> 
> * The site has been installed
> 
>     The site has been installed in /Users/me/Sites/reviewboard
> 
> 
> The technical details:
> Apache/2.2.21 (Unix)
> mod_wsgi-3.3
> SQLite3 module version 0.7-dev
> SQLite Library 3.7.7.1
> memcached 1.4.10
> pycrypto 2.6
> python 2.7.3
> using reviewboard with perforce(setup and working)
> 
> httpd.conf:
> -LoadModule wsgi_module libexec/apache2/mod_wsgi.so  (yes mod_wsgi.so actualy 
> exists and is installed in that directory)
> -User _www
> -Group _www
> -DocumentRoot "/Users/me/Sites"
> -<Directory "/Users/pgrigs/Sites">
>     #
>     # Possible values for the Options directive are "None", "All",
>     # or any combination of:
>     #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI 
> MultiViews
>     #
>     # Note that "MultiViews" must be named *explicitly* --- "Options All"
>     # doesn't give it to you.
>     #
>     # The Options directive is both complicated and important.  Please see
>     # http://httpd.apache.org/docs/2.2/mod/core.html#options
>     # for more information.
>     #
>     Options Indexes FollowSymLinks MultiViews
> 
>     #
>     # AllowOverride controls what directives may be placed in .htaccess files.
>     # It can be "All", "None", or any combination of the keywords:
>     #   Options FileInfo AuthConfig Limit
>     #
>     AllowOverride None
> 
>     #
>     # Controls who can get stuff from this server.
>     #
>     Order allow,deny
>     Allow from all
> </Directory>
> 
> -I've also tried "Include 
> /Users/pgrigs/sites/reviewboard/conf/apache-wsgi.conf" (not sure if I need to 
> do this or not)
> 
> httpd-vhosts.conf:
> <VirtualHost *:80>
>     ServerAdmin webmas...@mysite.com
>     DocumentRoot "/Users/me/Sites/reviewboard"
>     ServerName www.mysite.com
>     ErrorLog "/private/var/log/apache2/mysite.com-error_log"
>     CustomLog "/private/var/log/apache2/mysite.com-access_log" common
> </VirtualHost>
> 
> apache-wsgi.conf(which i create a symbolic link of and place in 
> etc/apache2/other)
> <VirtualHost *:80>
>       ServerName www.mysite.com
>       DocumentRoot "/Users/me/Sites/reviewboard/htdocs"
> 
>       # Error handlers
>       ErrorDocument 500 /errordocs/500.html
> 
>       WSGIPassAuthorization On
>       WSGIScriptAlias "/" 
> "/Users/me/Sites/reviewboard/htdocs/reviewboard.wsgi/"
> 
>       <Directory "/Users/me/Sites/reviewboard/htdocs">
>               AllowOverride All
>               Options -Indexes FollowSymLinks
>               Allow from all
>       </Directory>
> 
>       # Alias static media requests to filesystem
>       Alias /media "/Users/me/Sites/reviewboard/htdocs/media"
>       Alias /errordocs "/Users/me/Sites/reviewboard/htdocs/errordocs"
>       Alias /favicon.ico 
> "/Users/me/Sites/reviewboard/htdocs/media/rbcommons/images/favicon.png"
> </VirtualHost>
> 
> I think that's all the important info. Please help with this as I've used 
> reviewboard before and enjoyed it a lot.  I'd really like to get this up and 
> running for my team project as it's incredibly helpful!  Thank you for your 
> help!
> -- 
> Want to help the Review Board project? Donate today at 
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to 
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at 
> http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to