I have the same problem as Jun. I'm using nginx, and I've put the proxy 
exports in the nginx config file /etc/nginx/nginx.conf:

env http_proxy=http://proxy.example.com:3128

The error I'm getting is: 

Unknown error when linking the account: 'URLError' object has no attribute 
'read'


Review Board version: 1.6.9


I've also tried to export the proxy environment in the user's bash environment 
who runs review board process. still no luck.


Would appreciate any help.




On Monday, July 9, 2012 7:14:52 PM UTC-7, Christian Hammond wrote:
>
> No, it's unlikely to be aware. Apache doesn't run in a bash shell, so 
> those will be ignored. You can try setting the variables in your Apache 
> configuration using SetEnv.
>
> Christian
>
> -- 
> Christian Hammond - chip...@chipx86.com
> Review Board - http://www.reviewboard.org
> VMware, Inc. - http://www.vmware.com
>
>
> On Mon, Jul 9, 2012 at 7:13 PM, Jun <xiaojunt...@gmail.com> wrote:
>
>> yes, and i export http_proxy in /etc/profile, is reviewboard aware of 
>> this?
>>
>> Jun
>>
>>
>> On Tuesday, July 10, 2012 10:01:17 AM UTC+8, Christian Hammond wrote:
>>>
>>> Is your server behind a proxy server?
>>>
>>> Christian
>>>
>>> -- 
>>> Christian Hammond - chip...@chipx86.com
>>> Review Board - http://www.reviewboard.org
>>> VMware, Inc. - http://www.vmware.com
>>>
>>>
>>> On Mon, Jul 9, 2012 at 6:59 PM, Jun <xiaojunt...@gmail.com> wrote:
>>>
>>>> when i use `curl http://github.com/<my_github_**org>/<my_github_repo>/`
>>>>
>>>> it shows following, don't know if it is relevant:
>>>> <html>
>>>> <head><title>301 Moved Permanently</title></head>
>>>> <body bgcolor="white">
>>>> <center><h1>301 Moved Permanently</h1></center>
>>>> <hr><center>nginx/1.0.13</**center>
>>>> </body>
>>>> </html>
>>>>
>>>> Jun
>>>>
>>>>
>>>> On Tuesday, July 10, 2012 9:55:32 AM UTC+8, Jun wrote:
>>>>>
>>>>> When click save, one error on the web page shows "Unknown error when 
>>>>> linking the account: 'URLError' object has no attribute 'read'", and I 
>>>>> didn't find anything in reviewboard.log
>>>>>
>>>>> my input are:
>>>>> name: xxxx
>>>>> Hosting service: GitHub
>>>>> Account: link a new account
>>>>> Account username: my_github_account
>>>>> Account password: my_github_password
>>>>> Repository type: git
>>>>> Repository plan: Public Organization
>>>>> Organization name: my_github_org
>>>>> Repository name: my_github_repo
>>>>>
>>>>> and http://github.com/<my_github_**o**rg>/<my_github_repo>/ is 
>>>>> accessable from web browser.
>>>>>
>>>>> Thanks,
>>>>> Jun
>>>>>
>>>>>
>>>>>
>>>>> On Tuesday, July 10, 2012 9:10:36 AM UTC+8, Christian Hammond wrote:
>>>>>>
>>>>>> When you input the github username/password, fill out the repo info, 
>>>>>> and then save the repository, the account should be linked.
>>>>>>
>>>>>> If that's not happening, see if there's anything in the Review Board 
>>>>>> log files.
>>>>>>
>>>>>> Christian
>>>>>>
>>>>>> -- 
>>>>>> Christian Hammond - chip...@chipx86.com
>>>>>> Review Board - http://www.reviewboard.org
>>>>>> VMware, Inc. - http://www.vmware.com
>>>>>>
>>>>>>
>>>>>> On Mon, Jul 9, 2012 at 5:40 PM, Jun <xiaojunt...@gmail.com> wrote:
>>>>>>
>>>>>>> Reviewboard is 1.6.9.
>>>>>>>
>>>>>>> There is only "link a new account" in dropdown and no any account 
>>>>>>> appear, and that's also my question how to make it appear in the 
>>>>>>> dropdown? 
>>>>>>> Is it correct to input my github username/password as account 
>>>>>>> username/password when "link a new account".
>>>>>>>
>>>>>>> Thanks,
>>>>>>> Jun
>>>>>>>
>>>>>>>
>>>>>>> On Tuesday, July 10, 2012 3:30:18 AM UTC+8, Christian Hammond wrote:
>>>>>>>>
>>>>>>>> What version are you using?
>>>>>>>>
>>>>>>>> Do you get any errors when you link the account? Your GitHub 
>>>>>>>> username/password is required. Does the account appear in that 
>>>>>>>> dropdown?
>>>>>>>>
>>>>>>>> Christian
>>>>>>>>
>>>>>>>> -- 
>>>>>>>> Christian Hammond - chip...@chipx86.com
>>>>>>>> Review Board - http://www.reviewboard.org
>>>>>>>> VMware, Inc. - http://www.vmware.com
>>>>>>>>
>>>>>>>>
>>>>>>>> On Mon, Jul 9, 2012 at 11:43 AM, Jun <xiaojunt...@gmail.com> wrote:
>>>>>>>>
>>>>>>>>> Hi Christian,
>>>>>>>>>
>>>>>>>>> I installed a reviewboard instance following 
>>>>>>>>> http://www.reviewboard.org/**doc****s/manual/dev/admin/**
>>>>>>>>> installatio****n/linux/<http://www.reviewboard.org/docs/manual/dev/admin/installation/linux/>,
>>>>>>>>>  
>>>>>>>>> and it seemed to work fine, but I cannot find out a way to add a 
>>>>>>>>> github 
>>>>>>>>> repo to the review board.
>>>>>>>>>
>>>>>>>>> I can select GitHub as Hosting service, but I cannot choose an 
>>>>>>>>> existing github account but always "link a new account" in account 
>>>>>>>>> field. I 
>>>>>>>>> also tried to give account username/password for "link a new 
>>>>>>>>> account", 
>>>>>>>>> still failed.
>>>>>>>>>
>>>>>>>>> Any suggestion?
>>>>>>>>>
>>>>>>>>> Thanks,
>>>>>>>>> Jun
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> On Wednesday, July 4, 2012 3:27:37 PM UTC+8, Christian Hammond 
>>>>>>>>> wrote:
>>>>>>>>>>
>>>>>>>>>> Hi,
>>>>>>>>>>
>>>>>>>>>> GitHub recently removed support for their old API, which is what 
>>>>>>>>>> we were using before. In order to use Review Board with GitHub now, 
>>>>>>>>>> you'll 
>>>>>>>>>> need to grab RB 1.6.9 and re-configure the repository as GitHub 
>>>>>>>>>> again. It 
>>>>>>>>>> will then work fine.
>>>>>>>>>>
>>>>>>>>>> Christian
>>>>>>>>>>
>>>>>>>>>> -- 
>>>>>>>>>> Christian Hammond - chip...@chipx86.com
>>>>>>>>>> Review Board - http://www.reviewboard.org
>>>>>>>>>> VMware, Inc. - http://www.vmware.com
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> On Wed, Jul 4, 2012 at 12:24 AM, humble <eyuw...@gmail.com>wrote:
>>>>>>>>>>
>>>>>>>>>>> Hi,
>>>>>>>>>>>
>>>>>>>>>>> This may seem to be an easy question, but it doesn't work for 
>>>>>>>>>>> me. 
>>>>>>>>>>>
>>>>>>>>>>> I registered a test repo on github: g...@github.com:MY_GITHUB_ID/
>>>>>>>>>>> **MY******_TEST_REPO.git 
>>>>>>>>>>>
>>>>>>>>>>> The Review Board version I'm using is 1.6.1. I went to the admin 
>>>>>>>>>>> page to register that new repository. I entered the following info:
>>>>>>>>>>>
>>>>>>>>>>> Hosting service: GitHub
>>>>>>>>>>> Repository type: Git
>>>>>>>>>>> Project owner: MY_GITHUB_ID
>>>>>>>>>>> Project name: MY_TEST_REPO
>>>>>>>>>>>
>>>>>>>>>>> Then I clicked save. Review Board shows the repository has been 
>>>>>>>>>>> registered successfully.
>>>>>>>>>>>
>>>>>>>>>>> Next, I did a initial commit to add a README file with some text 
>>>>>>>>>>> in it. Pushed that commit.
>>>>>>>>>>>
>>>>>>>>>>> Next, I made a local commit, and I tried to use post-review to 
>>>>>>>>>>> create a code review. However, I'm always getting  the following 
>>>>>>>>>>> error:
>>>>>>>>>>>
>>>>>>>>>>> >>> Got API Error 207 (HTTP code 400): The file was not found in 
>>>>>>>>>>> the repository
>>>>>>>>>>> >>> Error data: {u'stat': u'fail', u'file': u'master.cfg', 
>>>>>>>>>>> u'err': {u'msg': u'The file was not found in the repository', 
>>>>>>>>>>> u'code': 
>>>>>>>>>>> 207}, u'revision': u'**d017cb810fc6cd3c4b114bcc82ad******07**
>>>>>>>>>>> cc35d88565'}
>>>>>>>>>>>
>>>>>>>>>>> Error uploading diff
>>>>>>>>>>>
>>>>>>>>>>> Your review request still exists, but the diff is not attached.
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> Is there anything that I missed? Please help me.
>>>>>>>>>>>
>>>>>>>>>>> Thanks
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>  -- 
>>>>>>>>>>> Want to help the Review Board project? Donate today at 
>>>>>>>>>>> http://www.reviewboard.org/**don******ate/<http://www.reviewboard.org/donate/>
>>>>>>>>>>> Happy user? Let us know at http://www.reviewboard.org/**use*****
>>>>>>>>>>> *rs/ <http://www.reviewboard.org/users/>
>>>>>>>>>>> -~----------~----~----~----~--********----~----~------~--~---
>>>>>>>>>>> To unsubscribe from this group, send email to 
>>>>>>>>>>> reviewboard+unsubscribe@**google******groups.com<reviewboard%2bunsubscr...@googlegroups.com>
>>>>>>>>>>> For more options, visit this group at http://groups.google.com/*
>>>>>>>>>>> *group******/reviewboard?hl=en<http://groups.google.com/group/reviewboard?hl=en>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>  -- 
>>>>>>>>> Want to help the Review Board project? Donate today at 
>>>>>>>>> http://www.reviewboard.org/**don****ate/<http://www.reviewboard.org/donate/>
>>>>>>>>> Happy user? Let us know at 
>>>>>>>>> http://www.reviewboard.org/**use****rs/<http://www.reviewboard.org/users/>
>>>>>>>>> -~----------~----~----~----~--******----~----~------~--~---
>>>>>>>>> To unsubscribe from this group, send email to 
>>>>>>>>> reviewboard+unsubscribe@**google****groups.com<reviewboard%2bunsubscr...@googlegroups.com>
>>>>>>>>> For more options, visit this group at http://groups.google.com/**
>>>>>>>>> group****/reviewboard?hl=en<http://groups.google.com/group/reviewboard?hl=en>
>>>>>>>>>
>>>>>>>>
>>>>>>>>  -- 
>>>>>>> Want to help the Review Board project? Donate today at 
>>>>>>> http://www.reviewboard.org/**don**ate/<http://www.reviewboard.org/donate/>
>>>>>>> Happy user? Let us know at 
>>>>>>> http://www.reviewboard.org/**use**rs/<http://www.reviewboard.org/users/>
>>>>>>> -~----------~----~----~----~--****----~----~------~--~---
>>>>>>> To unsubscribe from this group, send email to 
>>>>>>> reviewboard+unsubscribe@**google**groups.com<reviewboard%2bunsubscr...@googlegroups.com>
>>>>>>> For more options, visit this group at http://groups.google.com/**
>>>>>>> group**/reviewboard?hl=en<http://groups.google.com/group/reviewboard?hl=en>
>>>>>>>
>>>>>>
>>>>>>  -- 
>>>> Want to help the Review Board project? Donate today at 
>>>> http://www.reviewboard.org/**donate/<http://www.reviewboard.org/donate/>
>>>> Happy user? Let us know at 
>>>> http://www.reviewboard.org/**users/<http://www.reviewboard.org/users/>
>>>> -~----------~----~----~----~--**----~----~------~--~---
>>>> To unsubscribe from this group, send email to reviewboard+unsubscribe@*
>>>> *googlegroups.com <reviewboard%2bunsubscr...@googlegroups.com>
>>>> For more options, visit this group at http://groups.google.com/**
>>>> group/reviewboard?hl=en<http://groups.google.com/group/reviewboard?hl=en>
>>>>
>>>
>>>  -- 
>> Want to help the Review Board project? Donate today at 
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to 
>> reviewboard+unsubscr...@googlegroups.com
>> For more options, visit this group at 
>> http://groups.google.com/group/reviewboard?hl=en
>>
>
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to