Thanks peter for your inputs tried your inputs but still failed.
Here what i did-
*[root@svn CVSROOT]# cat commitinfo*
ALL  /opt/cvsroot/CVSROOT/postreview.sh

*[root@svn CVSROOT]# cat /opt/cvsroot/CVSROOT/postreview.sh*
echo "Post-review for $1"
name="kapila"
path=`echo $PATH`
export 
PATH=$path:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/javancss-32.53/bin:/opt/jdk1.7.0//bin:/usr/local/apache-ant-1.8.1//bin:/usr/local/apache-maven-2.1.0/bin:/usr/local/apr/bin:/usr/local/mysql/bin::/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/apache2/bin:/root/bin:/home/kapilacvs
echo $PATH
export HOME=/home/kapilacvs
echo $HOME
export GROUP=cvsdev
/usr/bin/post-review -dn --server=http://172.16.37.170:81   
--submit-as=$name  --repository-url=:pserver:kapilap@svn:/opt/cvsroot

*[root@svn CVSROOT]# id kapilap*
id: kapilap: No such user (since its cvs pserver user)
~

then i tried to commit 
[kapila.narang@svn ]$ ll /home/kapilacvs/test
[kapila.narang@svn ]$ cvs -d :pserver:kapilap@svn:/opt/cvsroot ci -m 
"BugID:47300 testing" test/document.txt
Post-review for /opt/cvsroot/test
/bin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/javancss-32.53/bin:/opt/jdk1.7.0//bin:/usr/local/apache-ant-1.8.1//bin:/usr/local/apache-maven-2.1.0/bin:/usr/local/apr/bin:/usr/local/mysql/bin::/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/apache2/bin:/root/bin:/home/kapilacvs
/home/kapilacvs
>>> RBTools 0.4.1
>>> Home = /home/kapilacvs
No supported repository could be accessed at the supplied url.
A commit is occurring in /opt/cvsroot/test
cvs commit: Pre-commit check failed
cvs [commit aborted]: correct above errors first!


Not able to understand what is causing error :(

On Tuesday, August 21, 2012 9:55:19 PM UTC+5:30, Peter Konneker wrote:
>
> So first I set the path, home, and group variable and exported them from 
> the svn hook.
>
> export 
>> PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin:/home/$AUTHOR/bin
>> export HOME=/home/$AUTHOR
>> export GROUP=mygroup
>
>
> If that doesn't work for you let me know. There's a ton of stuff I had to 
> try to get my hook working the way I wanted, haha.
>
> -Peter
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to