Hi,

We have a RB setup that has around ~50 users utilizing both post-review and 
the RB UI. 
As of today, all users are able to login successfully, however we have one 
user that is not able
to utilize post-review for some reason. Based on the debug output, the 
post-review command 
thinks we have an older setup and always attempts to use the deprecated API 
in order to login.
We are running version RB 1.6 RC2 and the latest RBTools. Here are the 
traces from the current run

 Password: 
>>> RBTools 0.4.1
>>> HTTP GETting api/
URL *http://<OUR_SERVER>/api/ <http://engin-server-01.austin.ibm.com/api/>*
==> HTTP Authentication Required
Enter authorization information for "Web API" at 
engin-server-01.austin.ibm.com
>>> Got HTTP error: 404: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /api/ was not found on this server.</p>
</body></html>

>>> Using the deprecated Review Board 1.0 web API
==> Review Board Login Required
Enter username and password for Review Board at 
*http://<OUR_SERVER>/<http://engin-server-01.austin.ibm.com/>
*
>>> Logging in with username "<USER>"
URL 
*http://<OUR_SERVER>/api/json/accounts/login/<http://engin-server-01.austin.ibm.com/api/json/accounts/login/>
*
>>> HTTP POSTing to 
>>> *http:/<OUR_SERVER>/api/json/accounts/login/:<http://engin-server-01.austin.ibm.com/api/json/accounts/login/:>
* {'username': '<USER>', 'password': '**************'}
>>> Got HTTP error: 404: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /api/json/accounts/login/ was not found on this 
server.</p>
</body></html>

Unable to log in: HTTP 404

All other users are able to utilize post review successfully except this 
one user. Maybe they forgot to pay their monthly tab or something :)
Any help or advise is much appreciated.
  

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to