Hi,

The problem you're hitting is that prior to a more recent-ish 1.6 release,
we weren't hard-coding specific versions of the packages we needed. We were
saying "XYZ or newer." Unfortunately, those packages are no longer
backwards-compatible.

If you really badly want 1.5.5, you'll need to get the correct versions of
Django (1.1.3) and Djblets (0.6.7). There may be other specific packages
you need, too.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Wed, Sep 5, 2012 at 5:20 PM, CudaPrime <cudapr...@gmail.com> wrote:

> Hi, sorry to horn in on this thread, but I'm having a similar issue.
> I'm trying to install version 1.5.5 on a test machine so I can then
> upgrade it to the current version before doing so on my production machine.
> When I attempt to use the command you list, easy_install ReviewBoard==1.5.5
> I get this output;
> #easy_install ReviewBoard==1.5.5
> Searching for ReviewBoard==1.5.5
> Best match: ReviewBoard 1.5.5
> Processing ReviewBoard-1.5.5-py2.4.egg
> Removing ReviewBoard 1.5.5 from easy-install.pth file
> Adding ReviewBoard 1.5.5 to easy-install.pth file
> Installing rb-site script to /usr/bin
> Installing rbssh script to /usr/bin
>
> Using /usr/lib/python2.4/site-packages/ReviewBoard-1.5.5-py2.4.egg
> Processing dependencies for ReviewBoard==1.5.5
> Searching for Djblets>=0.6.7
> Reading http://downloads.reviewboard.org/mirror/
> Reading http://downloads.reviewboard.org/releases/ReviewBoard/1.5/
> Reading http://pypi.python.org/simple/Djblets/
> Reading http://www.review-board.org/wiki/Djblets
> Reading http://downloads.review-board.org/releases/Djblets/0.6/
> Reading http://downloads.review-board.org/releases/
> Reading http://www.reviewboard.org/wiki/Djblets
> Reading http://downloads.reviewboard.org/releases/Djblets/0.7/
> Reading http://downloads.reviewboard.org/releases/Djblets/0.6/
> Reading http://downloads.review-board.org/releases/Djblets/0.5/
> Best match: Djblets 0.7.1
> Downloading
> http://downloads.reviewboard.org/releases/Djblets/0.7/Djblets-0.7.1.tar.gz
> Processing Djblets-0.7.1.tar.gz
> Running Djblets-0.7.1/setup.py -q bdist_egg --dist-dir
> /tmp/easy_install-PZQMbC/Djblets-0.7.1/egg-dist-tmp-MFddqC
> Traceback (most recent call last):
>   File "./contrib/internal/build-media.py", line 18, in ?
>     ret = call_command('collectstatic', interactive=False, verbosity=2)
>   File
> "/usr/lib/python2.4/site-packages/django/core/management/__init__.py", line
> 153, in call_command
>     klass = load_command_class(app_name, name)
>   File
> "/usr/lib/python2.4/site-packages/django/core/management/__init__.py", line
> 68, in load_command_class
>     return module.Command()
>   File
> "/usr/lib/python2.4/site-packages/django/contrib/staticfiles/management/commands/collectstatic.py",
> line 41, in __init__
>     self.storage = get_storage_class(settings.STATICFILES_STORAGE)()
>   File "/usr/lib/python2.4/site-packages/django/core/files/storage.py",
> line 265, in get_storage_class
>     raise ImproperlyConfigured('Error importing storage module %s: "%s"' %
> (module, e))
> django.core.exceptions.ImproperlyConfigured: Error importing storage
> module pipeline.storage: "No module named pipeline.storage"
> Traceback (most recent call last):
>   File "/usr/bin/easy_install", line 7, in ?
>     sys.exit(
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/command/easy_install.py",
> line 1712, in main
>     with_ei_usage(lambda:
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/command/easy_install.py",
> line 1700, in with_ei_usage
>     return f()
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/command/easy_install.py",
> line 1716, in <lambda>
>     distclass=DistributionWithoutHelpCommands, **kw
>   File "/usr/lib64/python2.4/distutils/core.py", line 149, in setup
>     dist.run_commands()
>   File "/usr/lib64/python2.4/distutils/dist.py", line 946, in run_commands
>     self.run_command(cmd)
>   File "/usr/lib64/python2.4/distutils/dist.py", line 966, in run_command
>     cmd_obj.run()
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/command/easy_install.py",
> line 211, in run
>     self.easy_install(spec, not self.no_deps)
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/command/easy_install.py",
> line 446, in easy_install
>     return self.install_item(spec, dist.location, tmpdir, deps)
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/command/easy_install.py",
> line 481, in install_item
>     self.process_distribution(spec, dists[0], deps, "Using")
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/command/easy_install.py",
> line 518, in process_distribution
>     distros = WorkingSet([]).resolve(
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/pkg_resources.py",
> line 563, in resolve
>     dist = best[req.key] = env.best_match(req, self, installer)
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/pkg_resources.py",
> line 799, in best_match
>     return self.obtain(req, installer) # try and download/install
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/pkg_resources.py",
> line 811, in obtain
>     return installer(requirement)
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/command/easy_install.py",
> line 446, in easy_install
>     return self.install_item(spec, dist.location, tmpdir, deps)
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/command/easy_install.py",
> line 476, in install_item
>     dists = self.install_eggs(spec, download, tmpdir)
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/command/easy_install.py",
> line 655, in install_eggs
>     return self.build_and_install(setup_script, setup_base)
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/command/easy_install.py",
> line 930, in build_and_install
>     self.run_setup(setup_script, setup_base, args)
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/command/easy_install.py",
> line 919, in run_setup
>     run_setup(setup_script, args)
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/sandbox.py",
> line 61, in run_setup
>     DirectorySandbox(setup_dir).run(
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/sandbox.py",
> line 105, in run
>     return func()
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/sandbox.py",
> line 64, in <lambda>
>     {'__file__':setup_script, '__name__':'__main__'}
>   File "setup.py", line 114, in ?
>   File "/usr/lib64/python2.4/distutils/core.py", line 149, in setup
>     dist.run_commands()
>   File "/usr/lib64/python2.4/distutils/dist.py", line 946, in run_commands
>     self.run_command(cmd)
>   File "/usr/lib64/python2.4/distutils/dist.py", line 966, in run_command
>     cmd_obj.run()
>   File
> "/usr/lib/python2.4/site-packages/setuptools-0.6c12dev_r88846-py2.4.egg/setuptools/command/bdist_egg.py",
> line 167, in run
>     self.run_command("egg_info")
>   File "/usr/lib64/python2.4/distutils/cmd.py", line 333, in run_command
>     self.distribution.run_command(command)
>   File "/usr/lib64/python2.4/distutils/dist.py", line 966, in run_command
>     cmd_obj.run()
>   File "setup.py", line 47, in run
>   File "/usr/lib64/python2.4/distutils/cmd.py", line 333, in run_command
>     self.distribution.run_command(command)
>   File "/usr/lib64/python2.4/distutils/dist.py", line 966, in run_command
>     cmd_obj.run()
>   File "setup.py", line 65, in run
> RuntimeError: Failed to build media files
>
>
> It appears to me that Python is only looking in the current release (1.6)
> directory, is there a way to modify that behavior so I can get the version
> I want?
>
>
> On Wednesday, June 20, 2012 3:26:45 AM UTC-7, NSJ wrote:
>>
>> Hi,
>>
>> I want to install Reviewboard version 1.6.1, but not the latest, Please
>> help me with the command to use.
>>
>> Regards,
>> Nilesh
>>
>  --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to