Hi Brian,

Haven't seen that before. Well, first thing that stands out to me is that you 
shouldn't need the Limit/Script lines, do I'd get rid of them.

You can get the 403 if you don't have cookies working right.

Which version of Review Board are you using, and which browser?

Most browsers have built-in development tools now, and you should be able to 
see the network activity. Can you find that, bring it up, and then reproduce 
it? You should be able to see the headers and the request/responses. If you can 
provide all these, it'd help me narrow it down.

Christian



On Sep 12, 2012, at 11:24, Brian Armstrong <kf7...@gmail.com> wrote:

> I am running reviewboard at the "/reviews" url of a server that handles many 
> different things. Whenever I try to edit a review it makes an ajax PUT 
> request to the API to update the item I changed.
> 
> Here is what the "Server Error Details" shows me
> Error Code: 403
> 
> Error Text: Forbidden
> 
> Request URL: /reviews/api/review-requests/1/draft/
> 
> Request Data: summary=Changing+the+summary
> 
> 
> This is being caused by apache2 (CentOS 5) with mod_wsgi.  The only thing I 
> get is an entry in the access log telling me the request was 403'd, nothing 
> else.
> 
> When using curl, I can get the requests to work every time by using POST 
> instead of PUT.
> 
> 
> Here is the config section specific to reviewboard
> 
> WSGIPassAuthorization On
> WSGIScriptAlias /reviews 
> /var/reviewboard/rb.dev.qualtrics.com/htdocs/reviewboard.wsgi/reviews
> <Directory /var/reviewboard/rb.dev.qualtrics.com/htdocs>
>     AllowOverride All
>     Options -Indexes FollowSymLinks +ExecCGI
>     
>     Order allow,deny
>     Allow from all
>     
>     <Limit PUT DELETE>
>         Allow from all
>     </Limit>
>     Script PUT /reviews
>     Script DELETE /reviews
> </Directory>
> # Static media for reviewboard
> Alias /reviews/media /var/reviewboard/rb.dev.qualtrics.com/htdocs/media
> Alias /reviews/errordocs 
> /var/reviewboard/rb.dev.qualtrics.com/htdocs/errordocs
> Alias /reviews/favicon.ico 
> /var/reviewboard/rb.dev.qualtrics.com/htdocs/media/rbcommons/images/favicon.png
> 
> I have searched the internet for hours trying to find a solution (since I 
> know 403 is the default response to PUT requests with apache), but I haven't 
> been able to find anything that works. I haven't been able to find anything 
> relevant in this mailing list either.
> 
> Wondering if anyone has any insight...
> -- 
> Want to help the Review Board project? Donate today at 
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to 
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at 
> http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to