Hello Christian,

Here is the command line description.

$ p4 describe 44720
Change 44720 by hpai@netlogic on 2012/10/17 06:28:06 *pending*

       This is for testing.

Affected files ...

... //depot/trunk/design/rel/readme#1 edit


What I think is the review board is not able to connect to perforce based 
on (http 400 error). We have large number of perforce ports configured., 
they are working fine. This is the newly configured perforce port we are 
facing error. 

In this perforce port we dont have password for the some users (security 
level 1). So while configuring a new repository in reviewboard we have 
given the user name and blank in password field. Usually we give the 
p4ticked id as password in the password field. 

Does this mean that the connection is not established properly.?





On Friday, October 19, 2012 12:20:41 AM UTC+5:30, Christian Hammond wrote:
>
> Hi,
>
> Those commands show that you have fiels that have changed, but I need to 
> see the contents of the change description and command line. We show that 
> error only when 'depotFile' in the change description has no data.
>
> Christian
>
> -- 
> Christian Hammond - chi...@chipx86.com <javascript:>
> Review Board - http://www.reviewboard.org
> VMware, Inc. - http://www.vmware.com
>
>
> On Thu, Oct 18, 2012 at 5:11 AM, Hari <hariha...@gmail.com 
> <javascript:>>wrote:
>
>> Hello Christan,
>>
>> The same thing I have done in cygwin command prompt. It produces the 
>> expected results. Its not a default changelist. I can see the diffs and all.
>>
>> Cygwin result.
>> ====================================================================
>> hpai@LTBLR-HPAI /cygdrive/c/Program Files/WinExePostReview
>> $  p4 print -o c:/temp/tmpbia4ir -q //depot/trunk/design/rel/readme
>>
>> hpai@LTBLR-HPAI /cygdrive/c/Program Files/WinExePostReview
>> $ pwd
>> /cygdrive/c/Program Files/WinExePostReview
>>
>> hpai@LTBLR-HPAI /cygdrive/c/Program Files/WinExePostReview
>> $ diff.exe  -urNp /cygdrive/c/temp/tmpbia4ir 
>> /cygdrive/C/Users/hpai/Perforce/netlogic/trunk/design/rel/readme
>> --- /cygdrive/c/temp/tmpbia4ir  2012-10-17 19:05:07.444325200 +0530
>> +++ /cygdrive/C/Users/hpai/Perforce/netlogic/trunk/design/rel/readme    
>> 2012-10-17 18:57:22.675972400 +0530
>> @@ -1,5 +1,5 @@
>>  ########################################################################
>> -# $Id: readme,v 1.1.1.1 2006/10/24 23:32:00 rporanki Exp $
>> +# $Id: readme,v 1.1.1.1 2006/10/24 23:32:00 rporanki Exp $ new
>>  ########################################################################
>>
>>  But When I try to do through p4v it throws the changelist empty error.
>>
>>
>>
>> On Thursday, 18 October 2012 13:18:57 UTC+5:30, Christian Hammond wrote:
>>
>>> Hi Hari,
>>>
>>> Are you 100% certain that the changeset is listing files, and that the 
>>> files aren't part of the default changeset? This is sounding like the 
>>> Perforce server is reporting that there's nothing in the changeset.
>>>
>>> If in doubt, contact your administrator and see if he's seen this issue 
>>> before.
>>>
>>> Christian
>>>
>>> -- 
>>> Christian Hammond - chi...@chipx86.com
>>>
>>> Review Board - http://www.reviewboard.org
>>> VMware, Inc. - http://www.vmware.com
>>>
>>>
>>> On Wed, Oct 17, 2012 at 11:33 PM, Hari <hariha...@gmail.com> wrote:
>>>
>>>>  Please Can some one look in to the issue and help me solve.?
>>>>
>>>>
>>>> On Wednesday, October 17, 2012 5:29:36 PM UTC+5:30, Hari wrote:
>>>>
>>>>> Hello,
>>>>>
>>>>> I am getting the following error while posting to reviewboard through 
>>>>> perforce.
>>>>>
>>>>> ==============================****==============================****
>>>>> =====================
>>>>>
>>>>> >>> RBTools 0.3.4
>>>>>
>>>>> >>> Home = C:\Users\hpai\AppData\Roaming\
>>>>>
>>>>> >>> User = hpai
>>>>>
>>>>> >>> Port = 
>>>>> >>> pf-sj1-netl.sj.broadcom.com:**49**001<http://pf-sj1-netl.sj.broadcom.com:49001>
>>>>>
>>>>> >>> p4 info
>>>>>
>>>>> >>> repository info: Path: 
>>>>> >>> pf-sj1-netl.sj.broadcom.com:**49**001<http://pf-sj1-netl.sj.broadcom.com:49001>,
>>>>> >>>  
>>>>> Base path: None, Supports changesets: True
>>>>>
>>>>> >>> options.p4_client=netlogic
>>>>>
>>>>> >>> server_url = http://rb.sj.broadcom.com
>>>>>
>>>>> >>> HTTP GETting api/
>>>>>
>>>>> >>> HTTP GETting 
>>>>> >>> http://rb.sj.broadcom.com/api/****info/<http://rb.sj.broadcom.com/api/info/>
>>>>>
>>>>> >>> Using the new web API
>>>>>
>>>>> >>> Generating diff for changenum 44718
>>>>>
>>>>> >>> p4 describe -s 44718
>>>>>
>>>>> >>> Processing edit of //depot/trunk/design/doc/eco/**T**
>>>>> estingthereviewboard.txt
>>>>>
>>>>> >>> Writing 
>>>>> >>> "//depot/trunk/design/doc/eco/****Testingthereviewboard.txt#3" 
>>>>> to "c:\temp\tmpu2a1z3"
>>>>>
>>>>> >>> p4 print -o c:\temp\tmpu2a1z3 -q //depot/trunk/design/doc/eco/**T*
>>>>> *estingthereviewboard.txt#3
>>>>>
>>>>> Diff command: C:\Program Files\WinExePostReview/diff.**ex**
>>>>> e,-urNp,/cygdrive/c/temp/**tmpu2**a1z3,/cygdrive/C/Users/**hpai/**
>>>>> Perforce/netlogic/trunk/**design**/doc/eco/**Testingthereviewboard**
>>>>> .txt
>>>>>
>>>>> >>> "C:\Program Files\WinExePostReview/diff.**ex**e" -urNp 
>>>>> /cygdrive/c/temp/tmpu2a1z3 /cygdrive/C/Users/hpai/**Perforc**
>>>>> e/netlogic/trunk/**design/doc/**eco/**Testingthereviewboard.txt
>>>>>
>>>>> Warning: //depot/trunk/design/doc/eco/**T**estingthereviewboard.txt 
>>>>> in your changeset is unmodified
>>>>>
>>>>> >>> Attempting to create review request on 
>>>>> pf-sj1-netl.sj.broadcom.com:**49**001<http://pf-sj1-netl.sj.broadcom.com:49001>for
>>>>>  44718
>>>>>
>>>>> >>> HTTP POSTing to 
>>>>> >>> http://rb.sj.broadcom.com/api/****review-requests/<http://rb.sj.broadcom.com/api/review-requests/>:
>>>>> >>>  
>>>>> {'changenum': '44718', 'repository': 'pf-sj1-netl.sj.broadcom.com:**4*
>>>>> *9001 <http://pf-sj1-netl.sj.broadcom.com:49001>'}
>>>>>
>>>>> >>> Got API Error 212 (HTTP code 400): The change number specified 
>>>>> represents an empty changeset
>>>>>
>>>>> >>> Error data: {u'stat': u'fail', u'err': {u'msg': u'The change 
>>>>> number specified represents an empty changeset', u'code': 212}}
>>>>>
>>>>> Error creating review request: The change number specified represents 
>>>>> an empty changeset.
>>>>>
>>>>> ==============================****==============================****
>>>>> ==============================****==============================****
>>>>> ==============================****==============
>>>>>
>>>>>
>>>>> Even though the changelist is not empty and it has a text file.Kindly 
>>>>> help me to solve this issue.
>>>>>
>>>>>
>>>>> Thanks and regards,
>>>>>
>>>>> Hari
>>>>>
>>>>  -- 
>>>> Want to help the Review Board project? Donate today at 
>>>> http://www.reviewboard.org/**donate/<http://www.reviewboard.org/donate/>
>>>> Happy user? Let us know at 
>>>> http://www.reviewboard.org/**users/<http://www.reviewboard.org/users/>
>>>> -~----------~----~----~----~--**----~----~------~--~---
>>>> To unsubscribe from this group, send email to reviewboard...@**
>>>> googlegroups.com
>>>>
>>>> For more options, visit this group at http://groups.google.com/**
>>>> group/reviewboard?hl=en<http://groups.google.com/group/reviewboard?hl=en>
>>>>
>>>
>>>  -- 
>> Want to help the Review Board project? Donate today at 
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to 
>> reviewboard...@googlegroups.com <javascript:>
>> For more options, visit this group at 
>> http://groups.google.com/group/reviewboard?hl=en
>>
>
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en


Reply via email to