I have issue with svn+ssh I have read these posts and they have gone some 
way to explain what is going on


I am trying to add a repository that uses svn+ssh protocol. I have 
generated a certificate through the reviewboard admin page and (I think) I 
have copied it to the server but its still not working. If I try and test 
it by doing:

sudo -u www-data ssh -v u...@server.com

I get: 

OpenSSH_6.0p1 Debian-3ubuntu1, OpenSSL 1.0.1c 10 May 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to server.com [x.x.x.x] port 22.
debug1: Connection established.
debug1: SELinux support disabled
Could not create directory '/var/www/.ssh'.
debug1: identity file /var/www/.ssh/id_rsa type -1
debug1: identity file /var/www/.ssh/id_rsa-cert type -1
debug1: identity file /var/www/.ssh/id_dsa type -1
debug1: identity file /var/www/.ssh/id_dsa-cert type -1
debug1: identity file /var/www/.ssh/id_ecdsa type -1
debug1: identity file /var/www/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
debug1: match: OpenSSH_4.3 pat OpenSSH_4*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.0p1 Debian-3ubuntu1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY

I thought my key was in /var/www/reviews.example.com/data/.ssh 

I know I am going to have svn connection issues once i've solved this but 
one thing at a time!

This is my reviewboard.log
2012-11-22 14:01:46,521 - DEBUG - SVNTool: Attempting ssh connection with 
host: server.com, username: user
2012-11-22 14:01:46,633 - DEBUG - starting thread (client mode): 0xc80ea350L
2012-11-22 14:01:46,638 - INFO - Connected (version 2.0, client OpenSSH_4.3)
2012-11-22 14:01:46,641 - DEBUG - kex 
algos:['diffie-hellman-group-exchange-sha1', 'diffie-hellman-group14-sha1', 
'diffie-hellman-group1-sha1'] server key:['ssh-rsa', 'ssh-dss'] client 
encrypt:['aes128-ctr', 'aes192-ctr', 'aes256-ctr', 'arcfour256', 
'arcfour128', 'aes128-cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc', 
'aes192-cbc', 'aes256-cbc', 'arcfour', 'rijndael-...@lysator.liu.se'] 
server encrypt:['aes128-ctr', 'aes192-ctr', 'aes256-ctr', 'arcfour256', 
'arcfour128', 'aes128-cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc', 
'aes192-cbc', 'aes256-cbc', 'arcfour', 'rijndael-...@lysator.liu.se'] 
client mac:['hmac-md5', 'hmac-sha1', 'hmac-ripemd160', 
'hmac-ripemd...@openssh.com', 'hmac-sha1-96', 'hmac-md5-96'] server 
mac:['hmac-md5', 'hmac-sha1', 'hmac-ripemd160', 
'hmac-ripemd...@openssh.com', 'hmac-sha1-96', 'hmac-md5-96'] client 
compress:['none', 'z...@openssh.com'] server compress:['none', 
'z...@openssh.com'] client lang:[''] server lang:[''] kex follows?False
2012-11-22 14:01:46,641 - DEBUG - Ciphers agreed: local=aes128-ctr, 
2012-11-22 14:01:46,641 - DEBUG - using kex diffie-hellman-group1-sha1; 
server key type ssh-rsa; cipher: local aes128-ctr, remote aes128-ctr; mac: 
local hmac-sha1, remote hmac-sha1; compression: local none, remote none
2012-11-22 14:01:46,689 - DEBUG - Switch to new keys ...
2012-11-22 14:01:46,699 - DEBUG - Trying SSH key 
2012-11-22 14:01:46,733 - DEBUG - userauth is OK
2012-11-22 14:01:46,841 - INFO - Authentication (publickey) failed.
2012-11-22 14:01:46,859 - DEBUG - Trying discovered key 
7e72c31c6c2ee6e4622a60ea14c3c3e6 in 
2012-11-22 14:01:46,861 - DEBUG - userauth is OK
2012-11-22 14:01:46,964 - INFO - Authentication (publickey) failed.

The fingerprint in the logs matches the one in the reviewboard admin page, 
if I use password authentication it works. I think i'm bumping into some 
issues in the links at the top but i'm unsure how to log in manaully as the 
reviewboard user from the command line


Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to