Hi,

I encounter a problem of post-review cannot figure out the right base path.
I have checked the svn URI of Review Board and .reviewboardrc.
What can I do for the next?

the svn repository is like this,
project - trunk


my .reviewboardrc,

REPOSITORY = 'http://localhost/svn/project/1024GB'
REVIEWBOARD_URL = 'http://172.23.20.241:8010'

the output in debug mode,

MT02385@twpcmt02385-02(build) ~/1000g/src $ post-review 
--tracking-branch=build --parent=HEAD^ -d
>>> RBTools 0.4.2
>>> Python 2.7.3 (default, Nov 30 2012, 17:31:35)
[GCC 4.5.3]
>>> Running on CYGWIN_NT-6.1-1.7.17-0.262-5-3-i686-32bit
>>> Home = C:\Users\mt02385\AppData\Roaming
>>> Current Directory = /cygdrive/d/397/src
>>> Checking the repository type. Errors shown below are mostly harmless.
DEBUG:root:Checking for a CVS repository...
DEBUG:root:Checking for a ClearCase repository...
DEBUG:root:Checking for a Git repository...
DEBUG:root:Running: git rev-parse --git-dir
DEBUG:root:Running: git config core.bare
DEBUG:root:Running: git rev-parse --show-toplevel
DEBUG:root:Running: git symbolic-ref -q HEAD
DEBUG:root:Running: git config --get branch.build.merge
DEBUG:root:Running: git config --get branch.build.remote
DEBUG:root:Running: git config --get remote.build.url
DEBUG:root:Command exited with rc 1: ['git', 'config', '--get', 
'remote.build.url']
---
DEBUG:root:repository info: Path: 
http://subversion.zyxel.com.tw/svn/MSAN_SW/MSC1024GB/branches/397, Base 
path: , Supports changesets: False
>>> Finished checking the repository type.
>>> HTTP GETting api/
>>> HTTP GETting http://172.23.20.241:8010/api/info/
>>> Using the new web API
DEBUG:root:Running: git merge-base build refs/heads/build
DEBUG:root:Running: git diff --no-color --full-index --no-ext-diff 
--ignore-submodules HEAD^
DEBUG:root:Running: git diff --no-color --full-index --no-ext-diff 
--ignore-submodules 20d5486b27c7fb61b8118112b15b7e763084dcd2..HEAD^
>>> Attempting to create review request on 
http://subversion.zyxel.com.tw/svn/MSAN_SW/MSC1024GB/branches/397 for None
>>> HTTP POSTing to http://172.23.20.241:8010/api/review-requests/: 
{'repository': 
'http://subversion.zyxel.com.tw/svn/MSAN_SW/MSC1024GB/branches/397'}
>>> Review request created
>>> Uploading diff, size: 4978
>>> Uploading parent diff, size: 4978
>>> HTTP POSTing to 
http://172.23.20.241:8010/api/review-requests/24/diffs/: {}
>>> Got API Error 105 (HTTP code 400): One or more fields had errors
>>> Error data: {u'fields': {u'basedir': [u'This field is required.']}, 
u'stat': u'fail', u'err': {u'msg': u'One or more fields had errors', 
u'code': 105}}

Error uploading diff

The generated diff file was empty. This usually means no files were
modified in this change.

Try running with --output-diff and --debug for more information.

Your review request still exists, but the diff is not attached.


Thanks for the help.

TingHan



-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en


Reply via email to