I'm getting a confusing error when I try to run post-review

  Failed to execute command: ['git', 'config', 'core.bare']

I've tried running this command directly in the repository (a non-bare 
clone) and it simply returns. I'm not sure what response the script is 
expecting. I'm using git version and RBTools 0.4.2. I've tried 
specifying the URL of the ReviewBoard instance in ~/.reviewboard.rc as well 
as in the git config, but that makes no difference; I don't think that 
post-review is getting far enough to us the URL anyway,

Any ideas?

Debug output is as follows:

post-review --debug
>>> RBTools 0.4.2
>>> Python 2.7.3 (default, Aug  1 2012, 05:14:39) 
[GCC 4.6.3]
>>> Running on Linux-3.2.0-33-generic-x86_64-with-Ubuntu-12.04-precise
>>> Home = <<removed>>
>>> Current Directory = <<removed>>
>>> Checking the repository type. Errors shown below are mostly harmless.
DEBUG:root:Checking for a CVS repository...
DEBUG:root:Checking for a ClearCase repository...
DEBUG:root:Checking for a Git repository...
DEBUG:root:Running: git rev-parse --git-dir
DEBUG:root:Running: git config core.bare
Failed to execute command: ['git', 'config', 'core.bare']

Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to