Hi Joe,

Sorry for the late response. Looks like gmail flagged this as spam. Odd.

You may need to add a <Location "/static"> that works just like the media
one. The static files are probably going through Review Board, which won't
know how to serve them.

As for the "Couldn't find manual update check" error, we just have a bug
where a second resolve-check prints that. I assume it worked the first time.

If the <Location> doesn't fix things, we'll do some debugging with your
setup and see what we can find.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com



On Mon, Dec 17, 2012 at 8:15 PM, Joe Attardi <jatta...@gmail.com> wrote:

> I updated my site to 1.7.0.1-py2.7 and I'm still getting 404 errors for
> anything under /static
>
> I added the alias for /static and restarted Apache 2, but it seems to have
> no effect. Am I missing something obvious?
>
> My Apache 2 configuration:
>
> <VirtualHost *:80>
>         ServerName uxworks-reviewboard.mysite.com
>         DocumentRoot "/var/www/uxworks-reviewboard/htdocs"
>
>         # Error handlers
>         ErrorDocument 500 /errordocs/500.html
>
>         # Serve django pages
>         <Location "/">
>                 PythonPath "['/var/www/uxworks-reviewboard/conf'] +
> sys.path"
>                 SetEnv DJANGO_SETTINGS_MODULE reviewboard.settings
>                 SetEnv PYTHON_EGG_CACHE
> "/var/www/uxworks-reviewboard/tmp/egg_cache"
>                 SetEnv HOME "/var/www/uxworks-reviewboard/data"
>                 SetHandler mod_python
>                 PythonHandler django.core.handlers.modpython
>                 PythonAutoReload Off
>                 PythonDebug Off
>                 # Used to run multiple mod_python sites in the same apache
>                 PythonInterpreter reviewboard_uxworks-reviewboard
>         </Location>
>
>         # Serve static media without running it through mod_python
>         # (overrides the above)
>         <Location "/media">
>                 SetHandler None
>         </Location>
>         <Location "/errordocs">
>                 SetHandler None
>         </Location>
>
>         <Directory "/var/www/uxworks-reviewboard/htdocs">
>                 AllowOverride All
>         </Directory>
>
>         # Alias static media requests to filesystem
>         Alias /media "/var/www/uxworks-reviewboard/htdocs/media"
>         Alias /errordocs "/var/www/uxworks-reviewboard/htdocs/erordocs"
>         Alias /static "/var/www/uxworks-reviewboard/htdocs/static"
> </VirtualHost>
>
> I tried running rb-site manage /var/www/uxworks-reviewboard resolve-check
> static-media but it gave me an error: Couldn't find manual update check
> 'static-media'
>
> Any help would be appreciated. Thanks!
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>
>
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en


Reply via email to