Hi,

What version were you using before that worked? Nothing has changed with
SSH in a few releases. Did anything else change? Subversion version?

This sounds more like the server dropped the connection during our access.
I wouldn't be able to tell you why.

You'll probably need to add the environment variables to your
reviewboard.wsgi file in your site's htdocs folder. Otherwise, it won't
carry over.

Being able to see the SVN path you're trying to use would help a lot.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com



On Mon, Dec 17, 2012 at 5:56 PM, Liam Reimers <liam.reim...@gmail.com>wrote:

> Seeing the same issue reported at the last post on:
> https://groups.google.com/d/msg/reviewboard-issues/TDF0cWON4TI/LNNh_RM_K50J
>
> This is reviewboard 1.6.15 on OS X.
>
> To get this far, I did have to: ln -s /usr/local/bin/rbssh /usr/bin/rbssh
>
> When I try to add a repo I get this in the GUI:
>
> A repository was not found at the specified path.
>
> The log shows:
>
> 2012-12-17 17:38:08,773 - DEBUG - SVNTool: Attempting ssh connection with
> host: <host>, username: <username>
> 2012-12-17 17:38:08,778 - DEBUG - starting thread (client mode): 0xd213590L
> 2012-12-17 17:38:08,788 - INFO - Connected (version 2.0, client
> OpenSSH_5.2)
> 2012-12-17 17:38:08,791 - DEBUG - kex
> algos:['diffie-hellman-group-exchange-sha256',
> 'diffie-hellman-group-exchange-sha1', 'diffie-hellman-group14-sha1',
> 'diffie-hellman-group1-sha1'] server key:['ssh-rsa', 'ssh-dss'] client
> encrypt:['aes128-ctr', 'aes192-ctr', 'aes256-ctr', 'arcfour256',
> 'arcfour128', 'aes128-cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc',
> 'aes192-cbc', 'aes256-cbc', 'arcfour', 'rijndael-...@lysator.liu.se']
> server encrypt:['aes128-ctr', 'aes192-ctr', 'aes256-ctr', 'arcfour256',
> 'arcfour128', 'aes128-cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc',
> 'aes192-cbc', 'aes256-cbc', 'arcfour', 'rijndael-...@lysator.liu.se']
> client mac:['hmac-md5', 'hmac-sha1', 'umac...@openssh.com',
> 'hmac-ripemd160', 'hmac-ripemd...@openssh.com', 'hmac-sha1-96',
> 'hmac-md5-96'] server mac:['hmac-md5', 'hmac-sha1', 'umac...@openssh.com',
> 'hmac-ripemd160', 'hmac-ripemd...@openssh.com', 'hmac-sha1-96',
> 'hmac-md5-96'] client compress:['none', 'z...@openssh.com'] server
> compress:['none', 'z...@openssh.com'] client lang:[''] server lang:['']
> kex follows?False
> 2012-12-17 17:38:08,791 - DEBUG - Ciphers agreed: local=aes128-ctr,
> remote=aes128-ctr
> 2012-12-17 17:38:08,791 - DEBUG - using kex diffie-hellman-group1-sha1;
> server key type ssh-rsa; cipher: local aes128-ctr, remote aes128-ctr; mac:
> local hmac-sha1, remote hmac-sha1; compression: local none, remote none
> 2012-12-17 17:38:08,812 - DEBUG - Switch to new keys ...
> 2012-12-17 17:38:08,814 - DEBUG - Trying SSH key <key id>
> 2012-12-17 17:38:08,817 - DEBUG - userauth is OK
> 2012-12-17 17:38:09,693 - INFO - Authentication (publickey) successful!
> 2012-12-17 17:38:09,794 - DEBUG - EOF in transport thread
> 2012-12-17 17:38:10,285 - ERROR - SVN: Failed to get repository
> information for <svn url>: To better debug SSH connection problems, remove
> the -q option from 'ssh' in the [tunnels] section of your Subversion
> configuration file.
> Network connection closed unexpectedly
>
> When trying rbssh from the command line:
>
> $ sudo -s
> bash-3.2# sudo -u _www -s
> bash-3.2$ export HOME=/Library/Server/Web/Data/Sites/<site>/data
> bash-3.2$ export DEBUG_RBSSH=1
> bash-3.2$ rbssh svn+ssh://<username>@<server>/path/to/repo
>
> Welcome to <server>.
>
> <server>:~ $ logout
> bash-3.2$
>
> In other words, it appeared to work fine.
>
> Incidentally, I added the rbssh environment vars to my apache config and
> no logs are showing up.
>
> SetEnv DEBUG_RBSSH 1
> SetEnv RBSSH_LOG_DIR /var/log/reviewboard
>
> Any help or advice would be greatly appreciated.
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>
>
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en


Reply via email to