Hmm... did that, and it seems like it should work but it got the same error 
in the reviewboard.log and this in the rbssh log:

12-18 14:16 root               DEBUG    ['/usr/bin/rbssh', 
'<username>@<hostname>', 'svnserve', '-t']
12-18 14:16 root               DEBUG    PID 61223
12-18 14:16 root               DEBUG    !!! <hostname>, <username>, 
['svnserve', '-t']

Username was the one I provided via the path change you suggested above.

Any other thoughts?

On Tuesday, December 18, 2012 2:15:09 PM UTC-8, Christian Hammond wrote:
>
> That looks like the culprit.
>
> We're telling SVN of the username, but that's not being passed to rbssh.
>
> What you can do is change the path to be svn+ssh://username@blah, and then 
> set Mirror Path to be the one without the username@ (in order to be able to 
> look it up properly). See if that works.
>
> Christian
>
> -- 
> Christian Hammond - chi...@chipx86.com <javascript:>
> Review Board - http://www.reviewboard.org
> VMware, Inc. - http://www.vmware.com
>
>
>
> On Tue, Dec 18, 2012 at 1:59 PM, Liam Reimers 
> <liam.r...@gmail.com<javascript:>
> > wrote:
>
>> Well, this is interesting...
>>
>> $ cat /var/log/reviewboard/rbssh-61048.log 
>> 12-18 13:56 root               DEBUG    ['/usr/bin/rbssh', '<svn 
>> hostname>', 'svnserve', '-t']
>> 12-18 13:56 root               DEBUG    PID 61048
>> 12-18 13:56 root               DEBUG    !!! <svn hostname>, _www, 
>> ['svnserve', '-t']
>>
>> Does this mean it's trying to run a command as _www? This is the user 
>> that the web server runs as, but it's not the user that I configured the 
>> repository to use!
>>
>> On Tuesday, December 18, 2012 12:37:35 PM UTC-8, Christian Hammond wrote:
>>
>>> Hi,
>>>
>>> What version were you using before that worked? Nothing has changed with 
>>> SSH in a few releases. Did anything else change? Subversion version?
>>>
>>> This sounds more like the server dropped the connection during our 
>>> access. I wouldn't be able to tell you why.
>>>
>>> You'll probably need to add the environment variables to your 
>>> reviewboard.wsgi file in your site's htdocs folder. Otherwise, it won't 
>>> carry over.
>>>
>>> Being able to see the SVN path you're trying to use would help a lot.
>>>
>>> Christian
>>>
>>  -- 
>> Want to help the Review Board project? Donate today at 
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to 
>> reviewboard...@googlegroups.com <javascript:>
>> For more options, visit this group at 
>> http://groups.google.com/group/reviewboard?hl=en
>>  
>>  
>>
>
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en


Reply via email to