Hello Christian,

Have you had a chance to investigate this any further? I'm running into the 
exact same problem on a Mac OS X Lion install.

-- Serhat

On Tuesday, December 18, 2012 7:36:41 PM UTC-8, Christian Hammond wrote:
>
> Hi Liam,
>
> I'm really not sure what to say. It's strange that it works in the case of 
> running it locally, but not when run inside Apache.
>
> We haven't tested any production installs running on MacOS X (we recommend 
> Linux for hosting), so maybe it's related to something there, or maybe it's 
> just some odd setup/configuration issue. Without having access to the 
> machine or having a repro case I can use, I can't really test it.
>
> If I think of any other things to check, I'll e-mail you, but for the 
> time-being, I'm just not sure what to suggest.
>
> Christian
>
>
> On Dec 18, 2012, at 3:43 PM, Liam Reimers <liam.r...@gmail.com<javascript:>> 
> wrote:
>
> Yes, /svn is the folder where all the repo roots live on this server. 
> /svn/devtech is the root of this particular repository.
>
> $ sudo HOME=/Library/Server/Web/Data/Sites/<site>/data SVN_SSH=rbssh svn 
> info svn+ssh://<username>@<server>/svn/devtech
> Path: devtech
> URL: svn+ssh://<username>@<server>/svn/devtech
> Repository Root: svn+ssh://<username>@<server>/svn/devtech
> Repository UUID: <uuid>
> Revision: 262170
> Node Kind: directory
> Last Changed Author: <other-user>
> Last Changed Rev: 262170
> Last Changed Date: 2012-12-18 15:40:28 -0800 (Tue, 18 Dec 2012)
>
> $
>
> On Tuesday, December 18, 2012 3:35:24 PM UTC-8, Christian Hammond wrote:
>>
>> I'm not really sure off-hand.
>>
>> One thing I want to check is that the root of your entire SVN repo is 
>> /svn/devtech, and not /svn. We need the root of the repo, rather than a 
>> subdir inside of it. Though, I haven't seen that break in this particular 
>> way.
>>
>> Can you also try running:
>>
>>     HOME=/path/to/sitedir/data SVN_SSH=rbssh svn info svn+ssh://....
>>
>> And see what that does. (You may need to be your www user first.)
>>
>> Christian
>>
>> -- 
>> Christian Hammond - chi...@chipx86.com
>> Review Board - http://www.reviewboard.org
>> VMware, Inc. - http://www.vmware.com
>>
>>
>>
>> On Tue, Dec 18, 2012 at 3:25 PM, Liam Reimers <liam.r...@gmail.com>wrote:
>>
>>> That is the entirety of the rbssh log, here is the relevant section of 
>>> the reviewboard.log:
>>>
>>> 2012-12-18 14:16:28,154 - DEBUG - SVNTool: Attempting ssh connection 
>>> with host: <hostname>, username: <username>
>>> 2012-12-18 14:16:28,159 - DEBUG - starting thread (client mode): 
>>> 0xcbde990L
>>> 2012-12-18 14:16:28,170 - INFO - Connected (version 2.0, client 
>>> OpenSSH_5.2)
>>> 2012-12-18 14:16:28,172 - DEBUG - kex 
>>> algos:['diffie-hellman-group-exchange-sha256', 
>>> 'diffie-hellman-group-exchange-sha1', 'diffie-hellman-group14-sha1', 
>>> 'diffie-hellman-group1-sha1'] server key:['ssh-rsa', 'ssh-dss'] client 
>>> encrypt:['aes128-ctr', 'aes192-ctr', 'aes256-ctr', 'arcfour256', 
>>> 'arcfour128', 'aes128-cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc', 
>>> 'aes192-cbc', 'aes256-cbc', 'arcfour', 'rijnda...@lysator.liu.se'] 
>>> server encrypt:['aes128-ctr', 'aes192-ctr', 'aes256-ctr', 'arcfour256', 
>>> 'arcfour128', 'aes128-cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc', 
>>> 'aes192-cbc', 'aes256-cbc', 'arcfour', 'rijnda...@lysator.liu.se'] 
>>> client mac:['hmac-md5', 'hmac-sha1', 'uma...@openssh.com', 
>>> 'hmac-ripemd160', 'hmac-ri...@openssh.com', 'hmac-sha1-96', 
>>> 'hmac-md5-96'] server mac:['hmac-md5', 'hmac-sha1', 'uma...@openssh.com', 
>>> 'hmac-ripemd160', 'hmac-ri...@openssh.com', 'hmac-sha1-96', 
>>> 'hmac-md5-96'] client compress:['none', 'zl...@openssh.com'] server 
>>> compress:['none', 'zl...@openssh.com'] client lang:[''] server 
>>> lang:[''] kex follows?False
>>> 2012-12-18 14:16:28,172 - DEBUG - Ciphers agreed: local=aes128-ctr, 
>>> remote=aes128-ctr
>>> 2012-12-18 14:16:28,172 - DEBUG - using kex diffie-hellman-group1-sha1; 
>>> server key type ssh-rsa; cipher: local aes128-ctr, remote aes128-ctr; mac: 
>>> local hmac-sha1, remote hmac-sha1; compression: local none, remote none
>>> 2012-12-18 14:16:28,192 - DEBUG - Switch to new keys ...
>>> 2012-12-18 14:16:28,196 - DEBUG - Trying SSH key 
>>> 011fe7608290ff77642a0f43f6e3cfae
>>> 2012-12-18 14:16:28,199 - DEBUG - userauth is OK
>>> 2012-12-18 14:16:29,078 - INFO - Authentication (publickey) successful!
>>> 2012-12-18 14:16:29,180 - DEBUG - EOF in transport thread
>>> 2012-12-18 14:16:29,472 - ERROR - SVN: Failed to get repository 
>>> information for svn+ssh://<username>@<hostname>/svn/devtech: To better 
>>> debug SSH connection problems, remove the -q option from 'ssh' in the 
>>> [tunnels] section of your Subversion configuration file.
>>> Network connection closed unexpectedly
>>>
>>> On Tuesday, December 18, 2012 2:53:03 PM UTC-8, Christian Hammond wrote:
>>>
>>>> Is there anything else in those logs? I'd like to see the entire thing 
>>>> to get more of a complete picture.
>>>>
>>>> Christian
>>>>
>>>> -- 
>>>> Christian Hammond - chi...@chipx86.com
>>>> Review Board - http://www.reviewboard.org
>>>> VMware, Inc. - http://www.vmware.com
>>>>
>>>>
>>>>
>>>> On Tue, Dec 18, 2012 at 2:49 PM, Liam Reimers <liam.r...@gmail.com>wrote:
>>>>
>>>>> Hmm... did that, and it seems like it should work but it got the same 
>>>>> error in the reviewboard.log and this in the rbssh log:
>>>>>
>>>>> 12-18 14:16 root               DEBUG    ['/usr/bin/rbssh', 
>>>>> '<username>@<hostname>', 'svnserve', '-t']
>>>>> 12-18 14:16 root               DEBUG    PID 61223
>>>>> 12-18 14:16 root               DEBUG    !!! <hostname>, <username>, 
>>>>> ['svnserve', '-t']
>>>>>
>>>>> Username was the one I provided via the path change you suggested 
>>>>> above.
>>>>>
>>>>> Any other thoughts?
>>>>>
>>>>> On Tuesday, December 18, 2012 2:15:09 PM UTC-8, Christian Hammond 
>>>>> wrote:
>>>>>
>>>>>> That looks like the culprit.
>>>>>>
>>>>>> We're telling SVN of the username, but that's not being passed to 
>>>>>> rbssh.
>>>>>>
>>>>>> What you can do is change the path to be svn+ssh://username@blah, 
>>>>>> and then set Mirror Path to be the one without the username@ (in order 
>>>>>> to 
>>>>>> be able to look it up properly). See if that works.
>>>>>>
>>>>>> Christian
>>>>>>
>>>>>> -- 
>>>>>> Christian Hammond - chi...@chipx86.com
>>>>>>
>>>>>> Review Board - http://www.reviewboard.org
>>>>>> VMware, Inc. - http://www.vmware.com
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Tue, Dec 18, 2012 at 1:59 PM, Liam Reimers <liam.r...@gmail.com>wrote:
>>>>>>
>>>>>>>  Well, this is interesting...
>>>>>>>
>>>>>>> $ cat /var/log/reviewboard/rbssh-**610**48.log 
>>>>>>> 12-18 13:56 root               DEBUG    ['/usr/bin/rbssh', '<svn 
>>>>>>> hostname>', 'svnserve', '-t']
>>>>>>> 12-18 13:56 root               DEBUG    PID 61048
>>>>>>> 12-18 13:56 root               DEBUG    !!! <svn hostname>, _www, 
>>>>>>> ['svnserve', '-t']
>>>>>>>
>>>>>>> Does this mean it's trying to run a command as _www? This is the 
>>>>>>> user that the web server runs as, but it's not the user that I 
>>>>>>> configured 
>>>>>>> the repository to use!
>>>>>>>
>>>>>>> On Tuesday, December 18, 2012 12:37:35 PM UTC-8, Christian Hammond 
>>>>>>> wrote:
>>>>>>>
>>>>>>>> Hi,
>>>>>>>>
>>>>>>>> What version were you using before that worked? Nothing has changed 
>>>>>>>> with SSH in a few releases. Did anything else change? Subversion 
>>>>>>>> version?
>>>>>>>>
>>>>>>>> This sounds more like the server dropped the connection during our 
>>>>>>>> access. I wouldn't be able to tell you why.
>>>>>>>>
>>>>>>>> You'll probably need to add the environment variables to your 
>>>>>>>> reviewboard.wsgi file in your site's htdocs folder. Otherwise, it 
>>>>>>>> won't 
>>>>>>>> carry over.
>>>>>>>>
>>>>>>>> Being able to see the SVN path you're trying to use would help a 
>>>>>>>> lot.
>>>>>>>>
>>>>>>>> Christian
>>>>>>>>
>>>>>>>
>>>>>>> -- 
>>>>>>> Want to help the Review Board project? Donate today at 
>>>>>>> http://www.reviewboard.org/**don**ate/<http://www.reviewboard.org/donate/>
>>>>>>> Happy user? Let us know at 
>>>>>>> http://www.reviewboard.org/**use**rs/<http://www.reviewboard.org/users/>
>>>>>>> -~----------~----~----~----~--****----~----~------~--~---
>>>>>>> To unsubscribe from this group, send email to reviewboard...@**
>>>>>>> googlegroups.**com
>>>>>>>
>>>>>>> For more options, visit this group at http://groups.google.com/**
>>>>>>> group**/reviewboard?hl=en<http://groups.google.com/group/reviewboard?hl=en>
>>>>>>>  
>>>>>>>  
>>>>>>>
>>>>>>
>>>>>>
>>>>
>>> -- 
>>> Want to help the Review Board project? Donate today at 
>>> http://www.reviewboard.org/donate/
>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>> -~----------~----~----~----~------~----~------~--~---
>>> To unsubscribe from this group, send email to 
>>> reviewboard...@googlegroups.com
>>>
>>> For more options, visit this group at 
>>> http://groups.google.com/group/reviewboard?hl=en
>>>  
>>>  
>>>
>>
>>
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en


Reply via email to