Hi Gavin,

Thanks for the detailed info.

The fact that the LDAP setup isn't working shouldn't prevent Review Board from 
showing you the option in the list, so that's unlikely to be it.

Try this on the server and see what happens:

    $ python
    >>> import pkg_resources
    >>> list(pkg_resources.iter_entry_points('reviewboard.auth_backends'))

If that shows an empty list, then the installed packages are failing to bundle 
the provided entry points correctly, which is how we scan for known auth 
backends. (You can see the file in the ReviewBoard-*/EGG-INFO/entrypoints.txt 
file). I don't know off-hand what the problem would be, but hopefully that'll 
give you a start in diagnosing it.

Christian


-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com

On Jan 15, 2013, at 11:53 PM, Gav Main <gavm...@gmail.com> wrote:

> Hi Christian, 
> 
> I appreciate you replying so quickly. We have the RH supplied version 
> installed (python-ldap-2.3.10-1.el6.x86_64). 
> 
> To give you a bit more information. We are looking to move from ReviewBoard 
> 1.6.5 -> 1.6.15. I have setup a lab instance of ReviewBoard 1.6.5 running on 
> RHEL 6.3, which points to a clone of the production MySQL database, which I 
> created with mysqldump . I am deploying all ReviewBoard dependencies as 
> custom built RPM's via Puppet. 'rb-site upgrade' complained that some of the 
> dependencies were out of date, so I've repackaged those (they are starred).
> 
> python-dateutil-1.5
> python-django-1.3.4*
> python-django-evolution-0.6.7
> python-djblets-0.6.27*
> python-flup-1.0.3.dev-20110405
> python-feedparser-5.1.2*
> python-memcached-1.48
> python-paramiko-1.7.7.1
> python-pil-1.1.7
> python-pycrypto-2.5
> python-pygments-1.5
> python-pysvn-1.7.6
> python-pytz-2012c
> python-recaptcha-client-1.0.6
> python-reviewboard-1.6.15*
> python-setuptools-0.6c11
> 
> I've typically been building the RPMS with:
> %build
> CFLAGS="$RPM_OPT_FLAGS" %{__python} -c 'import setuptools; 
> execfile("setup.py")' build
> ...
> %{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build 
>  --root $RPM_BUILD_ROOT --install-lib 
> %{_basedir}/%{sw_name}-%{sw_version}/site-packages --install-data 
> %{_basedir}/%{sw_name}-%{sw_version}/site-packages
> 
> 
> When I run rb-site upgrade I get this:
> # rb-site -d upgrade /local/apache
> Rebuilding directory structure
> Updating database. This may take a while.
> /opt/local/site-packages/djblets/gravatars/__init__.py:26: 
> DeprecationWarning: the md5 module is deprecated; use hashlib instead
>   from md5 import md5
> Creating tables ...
> Creating table hostingsvcs_hostingserviceaccount
> Upgrading Review Board from 1.6.5 to 1.6.15
> There are unapplied evolutions for reviews.
> There are unapplied evolutions for scmtools.
> Adding baseline version for new models
> Project signature has changed - an evolution is required
> Installing custom SQL ...
> Installing indexes ...
> No fixtures found.
> Evolution successful.
> Resetting in-database caches.
> Upgrade complete.
> 
> After writing all this, I have just realised that I have LDAP connection 
> problems on my lab server, which is a bit of a fail on my part. Would that be 
> enough for ReviewBoard to not populate the authentication drop-down list?
> 
> Cheers,
> Gavin
> 
> 
> On 16 January 2013 14:30, Christian Hammond <chip...@chipx86.com> wrote:
> Hi Gavin,
> 
> You'll need the Python ldap module, if you don't have it already.
> 
> Even though you're not using easy_install remotely, are you using it for the 
> eggs you download, or are you using another method?
> 
> Christian
> 
> -- 
> Christian Hammond - chip...@chipx86.com
> Review Board - http://www.reviewboard.org
> VMware, Inc. - http://www.vmware.com
> 
> On Jan 15, 2013, at 8:05 PM, Gavin Main <gavm...@gmail.com> wrote:
> 
>> I am facing the same issue. I unfortunately don't have the luxury of using 
>> easy_install as this requires a direct connection to the interwebs 
>> (something we can't allow). I have packaged up every ReviewBoard 1.6.15 
>> dependency by hand. 'rb-site' upgrade hinted that I needed the following... 
>> Djblets (0.6.27), Django (1.3.4) and Feedparser (5.1.2), but when I start 
>> Reviewboard after successfully running 'rb-site upgrade /path/to/site', I 
>> lose my LDAP settings. 'DEBUG = True' doesn't give much away.
>> 
>> Any help would be greatly appreciated. Oh and while I'm here... we love 
>> ReviewBoard. 
>> 
>> Cheers!
>> 
>> On Wednesday, 10 October 2012 13:05:36 UTC+8, shravanthi s wrote:
>> I am facing a similar issue. Actually I had successfully configured LDAP and 
>> it was working fine (I am using version 1.6.5). However I had an issue with 
>> uploading jpeg images so I uninstalled PIL and did some modifications to 
>> setup.py (JPEG_ROOT = "/usr/lib") and reinstalled PIL along with 
>> libjpeg-devel. I was able to upload jpeg images.
>> 
>>  However a new issue popped up, my LDAP configuration was gone and when i 
>> checked Authentication settings, there was no LDAP option at all! Only two 
>> authentication methods were available. Not sure what went wrong. Would an 
>> upgrade of Review Board resolve the issue? Appreciate your help..
>> 
>> On Tuesday, 2 October 2012 02:15:14 UTC+5:30, Christian Hammond wrote:
>> Running 'easy_install ReviewBoard' won't actually do much of anything. You'd 
>> need to pass -U to do an upgrade.
>> 
>> Christian
>> 
>> -- 
>> Christian Hammond - chi...@chipx86.com
>> Review Board - http://www.reviewboard.org
>> VMware, Inc. - http://www.vmware.com
>> 
>> 
>> On Sat, Sep 29, 2012 at 12:32 AM, 周培青 <zpq...@gmail.com> wrote:
>> Hi Christian,
>> 
>> I remember I used easy_install and I tried running easy_install ReviewBoard 
>> command again and got below information,
>> >> easy_install ReviewBoard
>> Searching for ReviewBoard
>> Best match: ReviewBoard 1.6.11
>> Processing ReviewBoard-1.6.11-py2.6.egg
>> ReviewBoard 1.6.11 is already the active version in easy-install.pth
>> Installing rb-site script to /usr/bin
>> Installing rbssh script to /usr/bin
>> 
>> Using /usr/lib/python2.6/site-packages/ReviewBoard-1.6.11-py2.6.egg
>> Processing dependencies for ReviewBoard
>> Finished processing dependencies for ReviewBoard
>> 
>> Any ideas...
>> 
>> 在 2012年9月22日星期六UTC+8上午7时12分04秒,Christian Hammond写道:
>> How did you install Review Board? It looks like the registrations are 
>> missing, which indicates you may have used pip or something, instead of 
>> easy_install.
>> 
>> Christian
>> 
>> -- 
>> Christian Hammond - chi...@chipx86.com
>> 
>> Review Board - http://www.reviewboard.org
>> VMware, Inc. - http://www.vmware.com
>> 
>> 
>> On Fri, Sep 21, 2012 at 1:37 AM, 周培青 <zpq...@gmail.com> wrote:
>> Hi all,
>> 
>> I installed ReviewBoard 1.6.11 on CentOS and I was trying to enable LDAP as 
>> authentication method, but I cannot even select LDAP from the Authentication 
>> Method dropdown in Authentication --> Authentication Settings tab, see the 
>> attached screenshot.
>> 
>> What's going on...
>> 
>> I would be very appreciate for your help.
>> 
>> 
>> -- 
>> Want to help the Review Board project? Donate today at 
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to reviewboard...@googlegroups.com
>> 
>> For more options, visit this group at 
>> http://groups.google.com/group/reviewboard?hl=en
>> 
>> 
>> -- 
>> Want to help the Review Board project? Donate today at 
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to reviewboard...@googlegroups.com
>> For more options, visit this group at 
>> http://groups.google.com/group/reviewboard?hl=en
>> 
>> 
>> -- 
>> Want to help the Review Board project? Donate today at 
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to 
>> reviewboard+unsubscr...@googlegroups.com
>> For more options, visit this group at 
>> http://groups.google.com/group/reviewboard?hl=en
>>  
>>  
> 
> 
> -- 
> Want to help the Review Board project? Donate today at 
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to 
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at 
> http://groups.google.com/group/reviewboard?hl=en
>  
>  
> 
> 
> -- 
> Want to help the Review Board project? Donate today at 
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to 
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at 
> http://groups.google.com/group/reviewboard?hl=en
>  
>  

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en


Reply via email to