Hello,

On Wednesday, January 25, 2012 6:33:11 PM UTC+7, Bart Celary wrote:
>
> Hi, 
> I have tried to 'pip install' the latest git snapshot of the 
> Reviewboard. I am working in a clean virtualenv (setuptools/pip only). 
> It failed with an error: 
>

 Is there any progress on this report? One year later, I'm encountering the 
same problem trying to install djblets 0.7.8 (the latest available version) 
in virtualenv.

Thanks,

-- 
Michel Alexandre Salim


> pip install -e /data/Work/Development/reviewboard 
> Obtaining file:///data/Work/Development/reviewboard 
>   Running setup.py egg_info for package from 
> file:///data/Work/Development/reviewboard 
>     Traceback (most recent call last): 
>       File "<string>", line 14, in <module> 
>       File "/data/Work/Development/reviewboard/setup.py", line 169, in 
> <module> 
>         "Topic :: Software Development :: Quality Assurance", 
>       File "/usr/lib/python2.7/distutils/core.py", line 152, in setup 
>         dist.run_commands() 
>       File "/usr/lib/python2.7/distutils/dist.py", line 953, in 
> run_commands 
>         self.run_command(cmd) 
>       File "/usr/lib/python2.7/distutils/dist.py", line 972, in 
> run_command 
>         cmd_obj.run() 
>       File "/data/Work/Development/reviewboard/setup.py", line 65, in 
> run 
>         egg_info.run(self) 
>       File "<string>", line 7, in replacement_run 
>     AttributeError: class egg_info has no attribute 
> 'iter_entry_points' 
>     Complete output from command python setup.py egg_info: 
>     running egg_info 
>
> creating ReviewBoard.egg-info 
>
> Traceback (most recent call last): 
>   File "<string>", line 14, in <module> 
>   File "/data/Work/Development/reviewboard/setup.py", line 169, in 
> <module> 
>     "Topic :: Software Development :: Quality Assurance", 
>   File "/usr/lib/python2.7/distutils/core.py", line 152, in setup 
>     dist.run_commands() 
>   File "/usr/lib/python2.7/distutils/dist.py", line 953, in 
> run_commands 
>     self.run_command(cmd) 
>   File "/usr/lib/python2.7/distutils/dist.py", line 972, in 
> run_command 
>     cmd_obj.run() 
>   File "/data/Work/Development/reviewboard/setup.py", line 65, in run 
>     egg_info.run(self) 
>   File "<string>", line 7, in replacement_run 
> AttributeError: class egg_info has no attribute 'iter_entry_points' 
> ---------------------------------------- 
> Command python setup.py egg_info failed with error code 1 
>
>
> Looks like commit be1dac2d made that change. Following patch fixed it 
> for me. 
>
> ----8<----8<----8<---- 
> diff --git a/setup.py b/setup.py 
> index 7e572cd..7732aa9 100755 
> --- a/setup.py 
> +++ b/setup.py 
> @@ -13,7 +13,7 @@ from ez_setup import use_setuptools 
>  use_setuptools() 
>
>  from setuptools import setup, find_packages 
> -from setuptools.command.egg_info import egg_info 
> +from setuptools.command import egg_info 
>  from distutils.command.install_data import install_data 
>  from distutils.command.install import INSTALL_SCHEMES 
>  from distutils.core import Command 
> @@ -51,7 +51,7 @@ class osx_install_data(install_data): 
>          install_data.finalize_options(self) 
>
>
> -class BuildEggInfo(egg_info): 
> +class BuildEggInfo(egg_info.egg_info): 
>      def run(self): 
>          # Conditionally build the media files if there's a 
> settings_local 
>          # file. If there isn't one, we assume this is a new dev tree, 
> in which 
> @@ -62,7 +62,7 @@ class BuildEggInfo(egg_info): 
>          if os.path.exists('settings_local.py'): 
>              self.run_command('build_media') 
>
> -        egg_info.run(self) 
> +        egg_info.egg_info.run(self) 
>
>
>  class BuildMedia(Command): 
> ----8<----8<----8<---- 
>
> Bartek

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en


Reply via email to