I'm not sure how to run as a rb shell, I was just running in python

On Tuesday, 22 January 2013 11:07:28 UTC-8, Christian Hammond wrote:
>
> Running that likely wont give you an accurate repro case. There's a lot 
> that goes on to configure what's used for SSH and how the key is loaded.
>
> Are you just running that in Python, or using 'rb-site manage 
> /path/to/site shell'?
>
> Christian
>
>
> On Jan 22, 2013, at 10:55, Alex Edwards <edward...@gmail.com <javascript:>> 
> wrote:
>
> that didn't seem to change anything.
>
> If i do this:
>
> >>> client = pysvn.Client()
> >>> client.set_default_username('<user>')
> >>> client.info2('svn+ssh://<host>/<repo>')
> Password:
>
>
> should I see some content? or does python just exit?
>
>
> On Tuesday, 22 January 2013 10:44:20 UTC-8, Christian Hammond wrote:
>>
>> I don't think Apache really factors into this.
>>
>> One more thing to try is to edit your site's conf/settings_local.py file 
>> and add:
>>
>> TIME_ZONE = 'US/Pacific'
>>
>> And then restart Apache and try again.
>>
>> If it works, it's a bandaid. I have thoughts on a better fix, but I want 
>> to check that first.
>>
>> Christian
>>
>> -- 
>> Christian Hammond - chi...@chipx86.com
>> Review Board - http://www.reviewboard.org
>> VMware, Inc. - http://www.vmware.com 
>>
>> On Jan 22, 2013, at 8:43 AM, Alex Edwards <edward...@gmail.com> wrote:
>>
>> All servers are running on PST, I had already configured the timezone (or 
>> reviewboard has done it for me) to US/Pacific. I tried reviewboard on UTC 
>> same errors in the logs, ive checked and they are all in sync. Does apache 
>> keep a default location/timezone as well that I might need to change?
>>
>> On Monday, 21 January 2013 23:05:28 UTC-8, Christian Hammond wrote:
>>>
>>> I've spent the past couple hours looking into this. I doubt I will have 
>>> a fix by tomorrow, unfortunately. This is a very strange bug.
>>>
>>> Here's what's basically going on:
>>>
>>> Review Board 1.7 uses Django 1.4, which introduced timezone support, 
>>> used to specify timezone info in the database and allow for per-user 
>>> timezone localization. We made use of this and set the default server 
>>> timezone to UTC.
>>>
>>> Somehow, setting this timezone to UTC causes a problem I think between 
>>> libsvn and rbssh. rbssh's stdin is interrupted early, causing rbssh's 
>>> connection to the server to terminate, causing Review Board to see an 
>>> error, indicating the repository isn't valid.
>>>
>>> Something, somewhere fails when the timezone configured for Review Board 
>>> doesn't match the system timezone.
>>>
>>> Now, what would help is if you could run a test or two for me.
>>>
>>> First off, what timezone is your actual server in/set to?
>>>
>>> Can you try setting your timezone in Review Board's admin UI to match 
>>> that timezone, and try again?
>>>
>>> Christian
>>>
>>> -- 
>>> Christian Hammond - chi...@chipx86.com
>>> Review Board - http://www.reviewboard.org
>>> VMware, Inc. - http://www.vmware.com
>>>
>>>
>>> On Mon, Jan 21, 2013 at 8:17 PM, Christian Hammond 
>>> <chi...@chipx86.com>wrote:
>>>
>>>> Good news. I was able to reproduce this.
>>>>
>>>> I'm going to figure out the root cause and get it into the RB 1.7.3 
>>>> release. This will be late tomorrow or, more likely, the day after.
>>>>
>>>> Christian
>>>>
>>>> -- 
>>>> Christian Hammond - chi...@chipx86.com
>>>> Review Board - http://www.reviewboard.org
>>>> VMware, Inc. - http://www.vmware.com 
>>>>
>>>> On Jan 21, 2013, at 8:04 PM, Alex Edwards <edward...@gmail.com> wrote:
>>>>
>>>> I'm not certain what version it was I will check in the morning it 
>>>> would have been 1.6.14 or 1.6.15, how would I test rbssh? 
>>>>
>>>> I dont particularly need to use a certificate, can I get this working 
>>>> with a password? I just assumed it only worked with keys! I can set the 
>>>> ssh 
>>>> user to have the same password as the svn account, not that secure but I 
>>>> am 
>>>> primarily trying to get this working to get it introduced into the process 
>>>> where I have recently started.
>>>>
>>>> thanks
>>>> Alex
>>>>
>>>> On Monday, 21 January 2013 19:51:30 UTC-8, Christian Hammond wrote:
>>>>>
>>>>> Specifying your own ssh will actually make it worse. It needs to use 
>>>>> our own rbssh in order to use your key.
>>>>>
>>>>> What 1.6.x release did you first have this problem in? I'm trying to 
>>>>> determine if there's some big regression in us, in pysvn/svn, or if 
>>>>> there's 
>>>>> some common configuration problem.
>>>>>
>>>>> Christian
>>>>>
>>>>>
>>>>> On Jan 21, 2013, at 10:13, Alex Edwards <edward...@gmail.com> wrote:
>>>>>
>>>>> I have also tried adding this to the svn config file in <site 
>>>>> root>/data/.subversion/config
>>>>>
>>>>> ssh = ssh -i 
>>>>> /var/www/test.com/data/.ssh/**id_dsa<http://test.com/data/.ssh/id_dsa>
>>>>>
>>>>> but that doesnt seem to change anything either!
>>>>>
>>>>> On Monday, 21 January 2013 10:04:30 UTC-8, Alex Edwards wrote:
>>>>>>
>>>>>> the server with apache and RB is runnning ubuntu, the svn server has 
>>>>>> selinux but it has been disabled
>>>>>>
>>>>>> I tried using pysvn and was prompted for a password, after which it 
>>>>>> hung for a while then seems to have exited python (i think), should I 
>>>>>> have 
>>>>>> still been in the python shell after executing that command?
>>>>>>
>>>>>> aedwards@aedwards-vm1:~$ sudo -u www-data python
>>>>>> [sudo] password for aedwards: 
>>>>>> Python 2.7.3 (default, Sep 26 2012, 21:51:14) 
>>>>>> [GCC 4.7.2] on linux2
>>>>>> Type "help", "copyright", "credits" or "license" for more information.
>>>>>> >>> import pysvn
>>>>>> >>> client = pysvn.Client()
>>>>>> >>> client.info2('svn+ssh://aedwar**d...@myserver.com/export/cvs/**
>>>>>> svn/repos <http://aedwa...@myserver.com/export/cvs/svn/repos>')
>>>>>> aedw...@myserver.com's password: 
>>>>>>
>>>>>> aedwards@aedwards-vm1:~$
>>>>>>
>>>>>> On Monday, 21 January 2013 09:47:03 UTC-8, Matthew Woehlke wrote:
>>>>>>>
>>>>>>> On 2013-01-21 12:42, Alex Edwards wrote: 
>>>>>>> > I am still having trouble getting this to work, I am unsure what I 
>>>>>>> am doing 
>>>>>>> > differently to others. I started with rb 1.6 but couldn't get it 
>>>>>>> working so 
>>>>>>> > I thought I would have a go with rb 1.7.1 I reinstalled 
>>>>>>> reviewboard and 
>>>>>>> > rbtools. And I am still facing the same problems. 
>>>>>>> > 
>>>>>>> >     - I have created an ssh key pair and uploaded the key to 
>>>>>>> reviewboard 
>>>>>>> >     (and the server). 
>>>>>>> >     - I can ssh to the server using the key 
>>>>>>> >     - I can ssh to the server using the apache user (and key) 
>>>>>>> > 
>>>>>>> > When I attempt to add a repository I get an error "A repository 
>>>>>>> was not 
>>>>>>> > found at the specified path". 
>>>>>>>
>>>>>>> This sounds suspiciously like Jonathan's recent git troubles... is 
>>>>>>> your 
>>>>>>> server using SELinux? If yes, have you checked your SELinux log for 
>>>>>>> denials? 
>>>>>>>
>>>>>>> -- 
>>>>>>> Matthew 
>>>>>>>
>>>>>>
>>>>> -- 
>>>>> Want to help the Review Board project? Donate today at 
>>>>> http://www.reviewboard.org/**donate/<http://www.reviewboard.org/donate/>
>>>>> Happy user? Let us know at 
>>>>> http://www.reviewboard.org/**users/<http://www.reviewboard.org/users/>
>>>>> -~----------~----~----~----~--**----~----~------~--~---
>>>>> To unsubscribe from this group, send email to reviewboard...@**
>>>>> googlegroups.com
>>>>> For more options, visit this group at http://groups.google.com/**
>>>>> group/reviewboard?hl=en<http://groups.google.com/group/reviewboard?hl=en>
>>>>>  
>>>>>  
>>>>>
>>>>>
>>>> -- 
>>>> Want to help the Review Board project? Donate today at 
>>>> http://www.reviewboard.org/donate/
>>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>>> -~----------~----~----~----~------~----~------~--~---
>>>> To unsubscribe from this group, send email to 
>>>> reviewboard...@googlegroups.com
>>>> For more options, visit this group at 
>>>> http://groups.google.com/group/reviewboard?hl=en
>>>>  
>>>>  
>>>>
>>>>
>>>>
>>>
>> -- 
>> Want to help the Review Board project? Donate today at 
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to 
>> reviewboard...@googlegroups.com
>> For more options, visit this group at 
>> http://groups.google.com/group/reviewboard?hl=en
>>  
>>  
>>
>>
>>  -- 
> Want to help the Review Board project? Donate today at 
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to 
> reviewboard...@googlegroups.com <javascript:>
> For more options, visit this group at 
> http://groups.google.com/group/reviewboard?hl=en
>  
>  
>
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en


Reply via email to