So on CentOS, your package manager is called "yum". This is going to be an 
essential part of managing your CentOS install, so you'll need to make sure 
you're familiar with it.

"yum search ldap" will return a list of packages matching "ldap." There should 
be some sort of -devel package for it. openldap-devel perhaps (I don't have 
CentOS here).

When in doubt, Google for how to install the Python ldap module on CentOS. 
Surely someone has detailed instructions.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com

On Feb 11, 2013, at 11:17 PM, kapila narang <kapilanar...@gmail.com> wrote:

> CentOS release 5.8 (Final)
> 
> 
> On Tue, Feb 12, 2013 at 12:43 PM, Christian Hammond <chip...@chipx86.com> 
> wrote:
> Assuming this is a Linux system, what distro/version is it?
> 
> Christian
> 
> -- 
> Christian Hammond - chip...@chipx86.com
> Review Board - http://www.reviewboard.org
> VMware, Inc. - http://www.vmware.com
> 
> On Feb 11, 2013, at 11:13 PM, kapila narang <kapilanar...@gmail.com> wrote:
> 
>> thanks Christian for the reply. But can you elaborate what you meant by 
>> package manager here.
>> I installed from easy_install so what i m missing here? 
>> 
>> 
>> On Tue, Feb 12, 2013 at 11:51 AM, Christian Hammond <chip...@chipx86.com> 
>> wrote:
>> Looks like you're missing the appropriate LDAP development headers. You can 
>> likely get this from your package manager.
>> 
>> Christian
>> 
>> -- 
>> Christian Hammond - chip...@chipx86.com
>> Review Board - http://www.reviewboard.org
>> VMware, Inc. - http://www.vmware.com
>> 
>> On Feb 11, 2013, at 10:20 PM, cmuser <kapilanar...@gmail.com> wrote:
>> 
>>> 
>>> Any help is appreciated.
>>> Error-
>>> $>easy_install python-ldap
>>> 
>>> Searching for python-ldap
>>> Reading http://pypi.python.org/simple/python-ldap/
>>> Reading http://www.python-ldap.org/
>>> Best match: python-ldap 2.4.10
>>> Downloading 
>>> http://pypi.python.org/packages/source/p/python-ldap/python-ldap-2.4.10.tar.gz#md5=a15827ca13c90e9101e5e9405c1d83be
>>> Processing python-ldap-2.4.10.tar.gz
>>> Running python-ldap-2.4.10/setup.py -q bdist_egg --dist-dir 
>>> /tmp/easy_install-cI4tUz/python-ldap-2.4.10/egg-dist-tmp-O-OCjt
>>> defines: HAVE_SASL HAVE_TLS HAVE_LIBLDAP_R
>>> extra_compile_args:
>>> extra_objects:
>>> include_dirs: /opt/openldap-RE24/include /usr/include/sasl /usr/include
>>> library_dirs: /opt/openldap-RE24/lib /usr/lib
>>> libs: ldap_r
>>> file Lib/ldap.py (for module ldap) not found
>>> file Lib/ldap/controls.py (for module ldap.controls) not found
>>> file Lib/ldap/extop.py (for module ldap.extop) not found
>>> file Lib/ldap/schema.py (for module ldap.schema) not found
>>> warning: no files found matching 'Makefile'
>>> warning: no files found matching 'Modules/LICENSE'
>>> file Lib/ldap.py (for module ldap) not found
>>> file Lib/ldap/controls.py (for module ldap.controls) not found
>>> file Lib/ldap/extop.py (for module ldap.extop) not found
>>> file Lib/ldap/schema.py (for module ldap.schema) not found
>>> file Lib/ldap.py (for module ldap) not found
>>> file Lib/ldap/controls.py (for module ldap.controls) not found
>>> file Lib/ldap/extop.py (for module ldap.extop) not found
>>> file Lib/ldap/schema.py (for module ldap.schema) not found
>>> In file included from Modules/LDAPObject.c:9:
>>> Modules/errors.h:8:18: error: lber.h: No such file or directory
>>> Modules/errors.h:9:18: error: ldap.h: No such file or directory
>>> In file included from Modules/LDAPObject.c:9:
>>> Modules/errors.h:12: error: expected â)â before â*â token
>>> In file included from Modules/LDAPObject.c:11:
>>> Modules/LDAPObject.h:12:2: error: #error Current python-ldap requires 
>>> OpenLDAP 2.x
>>> In file included from Modules/LDAPObject.c:11:
>>> Modules/LDAPObject.h:23: error: expected specifier-qualifier-list before 
>>> âLDAPâ
>>> Modules/LDAPObject.h:31: error: expected â)â before â*â token
>>> In file included from Modules/LDAPObject.c:12:
>>> Modules/ldapcontrol.h:11: error: expected â)â before â*â token
>>> Modules/ldapcontrol.h:12: error: expected declaration specifiers or â...â 
>>> before âLDAPControlâ
>>> Modules/ldapcontrol.h:13: error: expected â)â before â*â token
>>> In file included from Modules/LDAPObject.c:13:
>>> Modules/message.h:11: error: expected â)â before â*â token
>>> In file included from Modules/LDAPObject.c:14:
>>> Modules/berval.h:10: warning: âstruct bervalâ declared inside parameter list
>>> Modules/berval.h:10: warning: its scope is only this definition or 
>>> declaration, which is probably not what you want
>>> Modules/berval.h:12: warning: âstruct bervalâ declared inside parameter list
>>> Modules/berval.h:13: warning: âstruct bervalâ declared inside parameter list
>>> Modules/LDAPObject.c:18:18: error: sasl.h: No such file or directory
>>> Modules/LDAPObject.c:26: error: expected â)â before â*â token
>>> Modules/LDAPObject.c: In function âdeallocâ:
>>> Modules/LDAPObject.c:42: error: âLDAPObjectâ has no member named âldapâ
>>> Modules/LDAPObject.c:43: error: âLDAPObjectâ has no member named âvalidâ
>>> Modules/LDAPObject.c:44: error: âLDAPObjectâ has no member named â_saveâ
>>> Modules/LDAPObject.c:44: error: âLDAPObjectâ has no member named â_saveâ
>>> Modules/LDAPObject.c:45: warning: implicit declaration of function 
>>> âldap_unbind_extâ
>>> Modules/LDAPObject.c:45: error: âLDAPObjectâ has no member named âldapâ
>>> Modules/LDAPObject.c:46: error: âLDAPObjectâ has no member named â_saveâ
>>> Modules/LDAPObject.c:46: error: âLDAPObjectâ has no member named â_saveâ
>>> Modules/LDAPObject.c:47: error: âLDAPObjectâ has no member named âvalidâ
>>> Modules/LDAPObject.c:49: error: âLDAPObjectâ has no member named âldapâ
>>> Modules/LDAPObject.c: In function ânot_validâ:
>>> 
>>> pip freeze
>>> Django==1.4.3
>>> Djblets==0.7.10
>>> JCC==2.15
>>> Jinja2==2.6
>>> Markdown==2.2.1
>>> MySQL-python==1.2.4
>>> PIL==1.1.7
>>> Pygments==1.6
>>> RBTools==0.4.3
>>> ReviewBoard==1.7.5
>>> Sphinx==1.1.3
>>> django-evolution==0.6.8
>>> django-pipeline==1.2.24
>>> docutils==0.10
>>> feedparser==5.1.3
>>> mimeparse==0.1.3
>>> nose==1.2.1
>>> paramiko==1.9.0
>>> pycrypto==2.6
>>> python-dateutil==1.5
>>> python-memcached==1.48 
>>> 
>>> 
>>> 
>>> -- 
>>> Want to help the Review Board project? Donate today at 
>>> http://www.reviewboard.org/donate/
>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>> -~----------~----~----~----~------~----~------~--~---
>>> To unsubscribe from this group, send email to 
>>> reviewboard+unsubscr...@googlegroups.com
>>> For more options, visit this group at 
>>> http://groups.google.com/group/reviewboard?hl=en
>>> --- 
>>> You received this message because you are subscribed to the Google Groups 
>>> "reviewboard" group.
>>> To unsubscribe from this group and stop receiving emails from it, send an 
>>> email to reviewboard+unsubscr...@googlegroups.com.
>>> For more options, visit https://groups.google.com/groups/opt_out.
>>>  
>>>  
>> 
>> 
>> -- 
>> Want to help the Review Board project? Donate today at 
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to 
>> reviewboard+unsubscr...@googlegroups.com
>> For more options, visit this group at 
>> http://groups.google.com/group/reviewboard?hl=en
>> --- 
>> You received this message because you are subscribed to the Google Groups 
>> "reviewboard" group.
>> To unsubscribe from this group and stop receiving emails from it, send an 
>> email to reviewboard+unsubscr...@googlegroups.com.
>> For more options, visit https://groups.google.com/groups/opt_out.
>>  
>>  
>> 
>> 
>> -- 
>> Want to help the Review Board project? Donate today at 
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to 
>> reviewboard+unsubscr...@googlegroups.com
>> For more options, visit this group at 
>> http://groups.google.com/group/reviewboard?hl=en
>> --- 
>> You received this message because you are subscribed to the Google Groups 
>> "reviewboard" group.
>> To unsubscribe from this group and stop receiving emails from it, send an 
>> email to reviewboard+unsubscr...@googlegroups.com.
>> For more options, visit https://groups.google.com/groups/opt_out.
>>  
>>  
> 
> 
> -- 
> Want to help the Review Board project? Donate today at 
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to 
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at 
> http://groups.google.com/group/reviewboard?hl=en
> --- 
> You received this message because you are subscribed to the Google Groups 
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an 
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>  
>  
> 
> 
> -- 
> Want to help the Review Board project? Donate today at 
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to 
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at 
> http://groups.google.com/group/reviewboard?hl=en
> --- 
> You received this message because you are subscribed to the Google Groups 
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an 
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>  
>  

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to