Can you show me a log of exactly which commands you used to build and
install p4python?


-David


On Wed, Feb 13, 2013 at 12:00 PM, chuck j <cjerry2...@gmail.com> wrote:

> Dear  All,
>
> Its seems i have got some success while configuring ssl.
>
> Now that our perforce server is running on ssl
>
> I am try to add the repository, while doing so i am getting below error
> message.
>
>
>    - *The specified Perforce port includes ssl:, but the p4python library
>    was built without SSL support or the system library path is incorrect.
>    *
>
> As we have not able to find rpm for RHEL 2.6 OpenSSL 1.0.1, we have to
> build openssl 1.0.1, which eventually got installed at /usr/local/ssl/bin/
> /usr/local/ssl/ then we have build p4python with --ssl option.
>
> But its seems that still reviewboard reports about the above error
> message. Please help us know where to add the path of new build openssl
> library for which reviewboard server is looking for, if some pointer will
> be highly appreciated.
>
> -Chuck
>
>
>
>
>
> On Wed, Feb 13, 2013 at 7:24 AM, chuck j <cjerry2...@gmail.com> wrote:
>
>>
>> Does my p4 info output gave expected output.
>>
>>
>>
>> [root@svrrb1 works]# p4 info
>> User name: chuckj
>> Client name: svrrb1
>> Client host: svrrb1.na.software.com
>> Client unknown.
>> Current directory: /works
>> Peer address: 182.16.43.144:42238
>> Client address: <my ip address>
>> Server address: <some ip>:1666
>> Server root: /PFMETA/p4root
>> Server date: 2013/02/12 01:09:47 -0800 PST
>> Server uptime: 286:15:29
>> Server version: P4D/LINUX26X86_64/2012.2/577770 (2013/01/18)
>> Server encryption: encrypted
>> Server cert expires: Jan 31 10:22:47 2015 GMT
>> Server license: Software Corporation users (expires 2013/02/21)
>> Server license-ip: <some ip>:1666
>> Case Handling: sensitive
>>
>>>
>>>
>> On Tuesday, February 12, 2013 4:49:40 PM UTC+5:30, chuck j wrote:
>>>
>>> Since i couldn't find openssl 1.0.1 rpm, I have to manually compile and
>>> build then install it to the default path, then later i have build p4python.
>>>
>>> root@svrrb1 p4python-2012.2.549493# python setup.py build --apidir
>>> /works/p4api-2012.2.585708/ --ssl /usr/local/
>>> root@svrrb1 p4python-2012.2.549493# python setup.py install --apidir
>>> /works/p4api-2012.2.585708/
>>>
>>> Assuming everything above working fine i test by providing below command
>>> line.
>>>
>>> >>> import P4
>>> >>> p4 = P4.P4()
>>> >>> p4.connect()
>>> Traceback (most recent call last):
>>>   File "<stdin>", line 1, in <module>
>>>   File "/usr/local/lib/python2.7/**site-packages/P4.py", line 642, in
>>> connect
>>>     P4API.P4Adapter.connect( self )
>>> P4.P4Exception: [P4.connect()] Connect to server failed; check $P4PORT.
>>> SSL library must be at least version 1.0.1.
>>>
>>> Does my P4Python is build with OpenSSL.1.0.1 libarary, What is missing
>>> in my setup?
>>>
>>> I know this is not the right forum for above queries but this may
>>> provide some hint why adding repository to reviewboard is giving error.
>>>
>>> Please let me know if you need any more info, log for the same.
>>>
>>> - Chuck
>>>
>>>
>>>
>>>
>>> On Tuesday, February 12, 2013 2:51:15 PM UTC+5:30, chuck j wrote:
>>>>
>>>> Hi ,
>>>>
>>>> This is what i get for p4 info
>>>>
>>>> [root@svrrb1 works]# export P4USER=chuckj
>>>> [root@svrrb1 works]# export P4PORT=ssl:<some ip>:1666
>>>> [root@svrrb1 works]# p4 login
>>>> Enter password:
>>>> User chuckj logged in.
>>>>
>>>> [root@svrrb1 works]# p4 info
>>>> User name: chuckj
>>>> Client name: svrrb1
>>>> Client host: svrrb1.na.software.com
>>>> Client unknown.
>>>> Current directory: /works
>>>> Peer address: 182.16.43.144:42238
>>>> Client address: <my ip address>
>>>> Server address: <some ip>:1666
>>>> Server root: /PFMETA/p4root
>>>> Server date: 2013/02/12 01:09:47 -0800 PST
>>>> Server uptime: 286:15:29
>>>> Server version: P4D/LINUX26X86_64/2012.2/**577770 (2013/01/18)
>>>> Server encryption: encrypted
>>>> Server cert expires: Jan 31 10:22:47 2015 GMT
>>>> Server license: Software Corporation users (expires 2013/02/21)
>>>> Server license-ip: <some ip>:1666
>>>> Case Handling: sensitive
>>>>
>>>> The authentication of user is done using LDAP.
>>>>
>>>> Regards
>>>> Chuck.
>>>>
>>>> On Tuesday, February 12, 2013 2:27:33 PM UTC+5:30, Christian Hammond
>>>> wrote:
>>>>>
>>>>> Hi Chuck,
>>>>>
>>>>> I just wanted to give you a quick response. The person who would know
>>>>> the best on the project would be David, but he's out for the night (1AM
>>>>> here), so there will be a delay before he can respond.
>>>>>
>>>>> One thing to verify is that, on the command line (with that version of
>>>>> p4), you can do:
>>>>>
>>>>> P4PORT=ssl:blah p4 info
>>>>>
>>>>> Also, what sort of authentication mechanism are you using for Perforce?
>>>>>
>>>>> Christian
>>>>>
>>>>> --
>>>>> Christian Hammond - chi...@chipx86.com
>>>>> Review Board - http://www.reviewboard.org
>>>>> VMware, Inc. - http://www.vmware.com
>>>>>
>>>>> On Feb 12, 2013, at 12:52 AM, chuck j <cjerr...@gmail.com> wrote:
>>>>>
>>>>> Dear All,
>>>>>
>>>>> Now that we have made the RB server works with 1.7.4 + RBTools to work.
>>>>>
>>>>> We need to add perforce repository to reviewboard, when i add normal
>>>>> repository its gets added but when i add perforce repository will 
>>>>> prefixing
>>>>> ssl: i am getting error message
>>>>>
>>>>> "A repository was not found at the specified path."
>>>>>
>>>>> Following steps has been done from my end.
>>>>>
>>>>> Build P4Python with "--ssl" option providing the path of ssl libaray
>>>>>
>>>>> Updated the p4 client to 2012.2
>>>>>
>>>>> Anybody encountered such issues, am i missing something.
>>>>>
>>>>> Regards,
>>>>> Chuck
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Want to help the Review Board project? Donate today at
>>>>> http://www.reviewboard.org/**donate/<http://www.reviewboard.org/donate/>
>>>>> Happy user? Let us know at 
>>>>> http://www.reviewboard.org/**users/<http://www.reviewboard.org/users/>
>>>>> -~----------~----~----~----~--**----~----~------~--~---
>>>>> To unsubscribe from this group, send email to
>>>>> reviewboard...@googlegroups.**com
>>>>> For more options, visit this group at http://groups.google.com/**
>>>>> group/reviewboard?hl=en<http://groups.google.com/group/reviewboard?hl=en>
>>>>> ---
>>>>> You received this message because you are subscribed to the Google
>>>>> Groups "reviewboard" group.
>>>>> To unsubscribe from this group and stop receiving emails from it, send
>>>>> an email to reviewboard...@googlegroups.**com.
>>>>> For more options, visit 
>>>>> https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
>>>>> .
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>  --
>> Want to help the Review Board project? Donate today at
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to
>> reviewboard+unsubscr...@googlegroups.com
>> For more options, visit this group at
>> http://groups.google.com/group/reviewboard?hl=en
>> ---
>> You received this message because you are subscribed to the Google Groups
>> "reviewboard" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to reviewboard+unsubscr...@googlegroups.com.
>> For more options, visit https://groups.google.com/groups/opt_out.
>>
>>
>>
>
>  --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to