Did you revert to your state before the previous test, or is this on top of the 
previous? It's possible the previous test will have caused a problem for this 
one (though unlikely).

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com

On Mar 1, 2013, at 11:42 AM, Steve <seide.al...@gmail.com> wrote:

> Now I get this error:
> 
> (1054, "Unknown column 'reviews_reviewrequest.local_site_id' in 'on clause'")
> Request Method:       GET
> Request URL:  https://crush/dashboard/
> Django Version:       1.4.5
> Exception Type:       DatabaseError
> Exception Value:      
> (1054, "Unknown column 'reviews_reviewrequest.local_site_id' in 'on clause'")
> Exception Location:   
> /usr/lib/python2.6/site-packages/MySQL_python-1.2.3-py2.6-linux-x86_64.egg/MySQLdb/connections.py
>  in defaulterrorhandler, line 36
> Python Executable:    /usr/bin/python
> Python Version:       2.6.6
> Python Path:  
> ['/var/www/reviewboard/conf',
>  '/usr/lib64/python2.6/site-packages/JCC-2.14-py2.6-linux-x86_64.egg',
>  '/usr/lib64/python2.6/site-packages/lucene-3.6.1-py2.6-linux-x86_64.egg',
>  '/usr/lib/python2.6/site-packages/distribute-0.6.27-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/MySQL_python-1.2.3-py2.6-linux-x86_64.egg',
>  '/usr/lib/python2.6/site-packages/recaptcha_client-1.0.6-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/python_dateutil-1.5-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/flup-1.0.3.dev_20110405-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/Pygments-1.5-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/PIL-1.1.7-py2.6-linux-x86_64.egg',
>  '/usr/lib/python2.6/site-packages/pycrypto-2.6-py2.6-linux-x86_64.egg',
>  '/usr/lib/python2.6/site-packages/feedparser-5.1.3-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/ReviewBoard-1.7.6-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/pytz-2012j-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/paramiko-1.9.0-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/mimeparse-0.1.3-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/Markdown-2.2.1-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/docutils-0.10-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/django_pipeline-1.2.24-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/Djblets-0.7.11-py2.6.egg',
>  '/usr/lib/python2.6/site-packages/Django-1.4.5-py2.6.egg',
>  
> '/usr/lib/python2.6/site-packages/django_evolution-0.6.9alpha0.dev-py2.6.egg',
>  '/usr/lib64/python26.zip',
>  '/usr/lib64/python2.6',
>  '/usr/lib64/python2.6/plat-linux2',
>  '/usr/lib64/python2.6/lib-tk',
>  '/usr/lib64/python2.6/lib-old',
>  '/usr/lib64/python2.6/lib-dynload',
>  '/usr/lib64/python2.6/site-packages',
>  '/usr/lib64/python2.6/site-packages/gst-0.10',
>  '/usr/lib64/python2.6/site-packages/gtk-2.0',
>  '/usr/lib64/python2.6/site-packages/webkit-1.0',
>  '/usr/lib/python2.6/site-packages']
> 
> 
> Maybe I should try on a fresh database.
> 
> --Steve
> 
> On Friday, March 1, 2013 11:26:36 AM UTC-8, Christian Hammond wrote:
> That's the wrong Django Evolution. Can you try downloading the one from that 
> URL and just passing it directly to easy_install?
> 
> Christian
> 
> -- 
> Christian Hammond - chi...@chipx86.com
> Review Board - http://www.reviewboard.org
> VMware, Inc. - http://www.vmware.com
> 
> On Mar 1, 2013, at 11:20 AM, Steve <seide...@gmail.com> wrote:
> 
>> Sorry for the long, messy output, here's what happened when I tested the 
>> fix. This is an attempt to upgrade a 1.5.5 database to 1.7.6.
>> 
>> [root@crush]~/ReviewBoard# easy_install -U django_evolution -f 
>> http://downloads.reviewboard.org/temp/django-evolution/
>> Searching for django-evolution
>> Reading http://pypi.python.org/simple/django_evolution/
>> Reading http://code.google.com/p/django-evolution/
>> Best match: django-evolution 0.6.8
>> Downloading 
>> http://pypi.python.org/packages/2.6/d/django_evolution/django_evolution-0.6.8-py2.6.egg#md5=7527e0ca398639c87b68969ceb1cd2d7
>> Processing django_evolution-0.6.8-py2.6.egg
>> removing '/usr/lib/python2.6/site-packages/django_evolution-0.6.8-py2.6.egg' 
>> (and everything under it)
>> creating /usr/lib/python2.6/site-packages/django_evolution-0.6.8-py2.6.egg
>> Extracting django_evolution-0.6.8-py2.6.egg to 
>> /usr/lib/python2.6/site-packages
>> django-evolution 0.6.8 is already the active version in easy-install.pth
>> 
>> Installed /usr/lib/python2.6/site-packages/django_evolution-0.6.8-py2.6.egg
>> Processing dependencies for django-evolution
>> Finished processing dependencies for django-evolution
>> Searching for -f
>> Reading http://pypi.python.org/simple/-f/
>> Couldn't find index page for '-f' (maybe misspelled?)
>> Scanning index of all packages (this may take a while)
>> Reading http://pypi.python.org/simple/
>>   C-c C-c^Cinterrupted
>> 
>> I don't know why easy_install got confused by '-f', but I did get a new 
>> django_evolution, so I tried updating my broken site:
>> 
>> [root@crush]~/ReviewBoard# cat rb-upgrade.log
>> Error: Model 'reviews.FileAttachmentComment' already has a field named 
>> 'extra_data'
>> Rebuilding directory structure
>> Updating database. This may take a while.
>> 
>> The log output below, including warnings and errors,
>> can be ignored unless upgrade fails.
>> 
>> ------------------ <begin log output> ------------------
>> Creating tables ...
>> There are unapplied evolutions for auth.
>> There are unapplied evolutions for accounts.
>> There are unapplied evolutions for changedescs.
>> There are unapplied evolutions for diffviewer.
>> There are unapplied evolutions for reviews.
>> There are unapplied evolutions for scmtools.
>> Project signature has changed - an evolution is required
>> Installing custom SQL ...
>> Installing indexes ...
>> Installed 0 object(s) from 0 fixture(s)
>> 
>> Now when I log in to my site, I get this:
>> 
>> (1054, "Unknown column 'accounts_profile.is_private' in 'field list'")
>> Request Method:      GET
>> Request URL: https://crush/
>> Django Version:      1.4.5
>> Exception Type:      DatabaseError
>> Exception Value:     
>> (1054, "Unknown column 'accounts_profile.is_private' in 'field list'")
>> Exception Location:  
>> /usr/lib/python2.6/site-packages/MySQL_python-1.2.3-py2.6-linux-x86_64.egg/MySQLdb/connections.py
>>  in defaulterrorhandler, line 36
>> Python Executable:   /usr/bin/python
>> Python Version:      2.6.6
>> Python Path: 
>> ['/var/www/reviewboard/conf',
>>  '/usr/lib64/python2.6/site-packages/JCC-2.14-py2.6-linux-x86_64.egg',
>>  '/usr/lib64/python2.6/site-packages/lucene-3.6.1-py2.6-linux-x86_64.egg',
>>  '/usr/lib/python2.6/site-packages/distribute-0.6.27-py2.6.egg',
>>  
>> '/usr/lib/python2.6/site-packages/MySQL_python-1.2.3-py2.6-linux-x86_64.egg',
>>  '/usr/lib/python2.6/site-packages/recaptcha_client-1.0.6-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/python_dateutil-1.5-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/flup-1.0.3.dev_20110405-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/Pygments-1.5-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/PIL-1.1.7-py2.6-linux-x86_64.egg',
>>  '/usr/lib/python2.6/site-packages/pycrypto-2.6-py2.6-linux-x86_64.egg',
>>  '/usr/lib/python2.6/site-packages/feedparser-5.1.3-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/ReviewBoard-1.7.6-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/pytz-2012j-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/paramiko-1.9.0-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/mimeparse-0.1.3-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/Markdown-2.2.1-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/docutils-0.10-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/django_pipeline-1.2.24-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/Djblets-0.7.11-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/Django-1.4.5-py2.6.egg',
>>  '/usr/lib/python2.6/site-packages/django_evolution-0.6.8-py2.6.egg',
>>  '/usr/lib64/python26.zip',
>>  '/usr/lib64/python2.6',
>>  '/usr/lib64/python2.6/plat-linux2',
>>  '/usr/lib64/python2.6/lib-tk',
>>  '/usr/lib64/python2.6/lib-old',
>>  '/usr/lib64/python2.6/lib-dynload',
>>  '/usr/lib64/python2.6/site-packages',
>>  '/usr/lib64/python2.6/site-packages/gst-0.10',
>>  '/usr/lib64/python2.6/site-packages/gtk-2.0',
>>  '/usr/lib64/python2.6/site-packages/webkit-1.0',
>>  '/usr/lib/python2.6/site-packages']
>> Server time: Fri, 1 Mar 2013 19:08:48 +0000
>> 
>> 
>> I may try it again on a pristine 1.5.5 database.
>> 
>> --Steve
>> 
>> On Wednesday, February 27, 2013 12:16:03 AM UTC-8, Christian Hammond wrote:
>> Hi everyone,
>> 
>> So some of you have hit database upgrade issues before when upgrading to 1.7 
>> (or, in some cases, 1.6). We've managed to figure out solutions for some of 
>> you, but not all.
>> 
>> I've spent a lot of time trying to figure out solutions, find the common 
>> cases, and figure out a fix. Today, I have one that should fix it for at 
>> least some of you. What I really need are volunteers to help test it.
>> 
>> If you're having issues now, or have had issues in the past and still have a 
>> broken database dump handy, I'd appreciate your help. Heck, even if you have 
>> had no issues, and have an old database dump to test.
>> 
>> I have a test version of Django Evolution up at 
>> http://downloads.reviewboard.org/temp/django-evolution/
>> 
>> This version has some new logic that tries to avoid applying database 
>> upgrades for things that are already in the database, which was the core 
>> problem most of you hit.
>> 
>> If you can give this a try, here's what I'd like you to do:
>> 
>> 1) Get an installation going with your broken or pre-upgrade database.
>> 
>> 2) Install django_evolution from the above URL, using:
>> 
>>     $ sudo easy_install -U django_evolution -f 
>> http://downloads.reviewboard.org/temp/django-evolution/
>> 
>> 3) Attempt a Review Board upgrade (rb-site manage /path/to/site upgrade)
>> 
>> 4) Assuming it works, try to access the site and make sure things generally 
>> work on it.
>> 
>> 
>> Please then reply to this post with the following information:
>> 
>> 1) The complete log output.
>> 
>> 2) Whether you were testing with a dump from before a past broken upgrade 
>> attempt, or a dump made after that past upgrade attempt failed.
>> 
>> 
>> For extra credit, if you have did have a working database dump, 
>> sanity-checking that you don't have any upgrade problems and that the site 
>> runs would also really help me out.
>> 
>> Thanks! Sooner I get some feedback, the sooner I can put this problem to 
>> rest.
>> 
>> - Christian
>> 
>> -- 
>> Christian Hammond - chi...@chipx86.com
>> Review Board - http://www.reviewboard.org
>> VMware, Inc. - http://www.vmware.com
>> 
>> 
>> -- 
>> Want to help the Review Board project? Donate today at 
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to reviewboard...@googlegroups.com
>> For more options, visit this group at 
>> http://groups.google.com/group/reviewboard?hl=en
>> --- 
>> You received this message because you are subscribed to the Google Groups 
>> "reviewboard" group.
>> To unsubscribe from this group and stop receiving emails from it, send an 
>> email to reviewboard...@googlegroups.com.
>> For more options, visit https://groups.google.com/groups/opt_out.
>>  
>>  
> 
> 
> -- 
> Want to help the Review Board project? Donate today at 
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to 
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at 
> http://groups.google.com/group/reviewboard?hl=en
> --- 
> You received this message because you are subscribed to the Google Groups 
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an 
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>  
>  

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to